Hacking Updating to more recent versions of CFW

Lupinthe3d

Member
OP
Newcomer
Joined
Sep 25, 2017
Messages
20
Trophies
0
Age
30
XP
206
Country
Italy
Hi guys,

it has been quite a while since I have last used my 3ds due to a severe lack of work.

I just turned it on today and I started to realize there a tons of things not working anymore.
I currently have a 3ds xl with Luma 8.1.1 and FW version 11.6.0-39E but nothing seems to work anymore/
1. When In FBI I look for title DB I get an error (HTTP request returned error) code 0xD963F802. I also get an error if I try to download via QR coad, this time it fails to verify TLS certificate - 0xD8A0A03c
2. If I open Luma updater (I have v 2.2 on my 3ds) the console simply freezes
3. If I open the homebrew launcher (Rosalina 2.0) I still see very old stuff, different from what is now (based on YT videos).
4. fftp won't work anymore - Filezilla tells me this server doesn't support ftp over TLS - here not sure if it is my 3ds or the new network connection.


What shall be my next moves to make things back to normal working?

Thanks.
 

KleinesSinchen

GBAtemp's Backup Reminder + Fearless Testing Sina
Member
GBAtemp Patron
Joined
Mar 28, 2018
Messages
3,060
Trophies
2
XP
8,021
Country
Germany
  1. Titledb does not exist anymore. You have an old version of FBI not compatible with newer encryption for downloading via QR-code
    • Update FBI
  2. Luma updater probably the same → Defeats the purpose of an updater when you have to manually update the updater first.
  3. Update Luma3DS and the Homebrew Launcher (both in the .zip file). Get new versions of essential software; refer to the finalizing page.
  4. Try this one: https://github.com/mtheall/ftpd – works for me.
If you update the official firmware before putting the new boot.firm on the SD (and I recommend Section VI of the finalizing page as well) you will get the infamous “Failed to apply 1 Firm patch(es)” message.
 
Last edited by KleinesSinchen,

Lupinthe3d

Member
OP
Newcomer
Joined
Sep 25, 2017
Messages
20
Trophies
0
Age
30
XP
206
Country
Italy
  1. Titledb does not exist anymore. You have an old version of FBI not compatible with newer encryption for downloading via QR-code
    • Update FBI
  2. Luma updater probably the same → Defeats the purpose of an updater when you have to manually update the updater first.
  3. Update Luma3DS and the Homebrew Launcher (both in the .zip file). Get new versions of essential software; refer to the finalizing page.
  4. Try this one: https://github.com/mtheall/ftpd – works for me.
If you update the official firmware before putting the new boot.firm on the SD (and I recommend Section VI of the finalizing page as well) you will get the infamous “Failed to apply 1 Firm patch(es)” message.
Big thanks, with th site you linked me I was able to update FBI and luma installer so now I have the latest versions of everything (including homebrew launcher).

Still couldn't solve the ftp issue - I had the one you linked me already - thus I did not put godmode. But thanks :)

Shall I now update my 3ds fw?
 
  • Like
Reactions: Alexander1970
General chit-chat
Help Users
    KenniesNewName @ KenniesNewName: @Costello rigged it