Trying to upgrade from GEN-B to D3

Discussion in 'PSP - Games & Content' started by mainframe004, Dec 24, 2010.

Dec 24, 2010
  1. mainframe004
    OP

    Newcomer mainframe004 Member

    Joined:
    Jul 8, 2010
    Messages:
    43
    Country:
    Philippines
    Okay, I've tried everything so far, and every time I hit the install CFW button on the D3 installer, the PSP just crashes and I have to restart it, with no change in the firmware at all. I have myself a PSP-1000. Anyone know how to fix this?

    Then again, if all else fails, I think I'll just go back to M33. Is it even possible to go back from 5.50 to 5.00 this way, though? Also, does anyone know if gpSP (the latest version) will run on M33 and/or GEN-D3?
     
  2. Rasas

    Banned Rasas Banned

    Joined:
    Apr 7, 2010
    Messages:
    643
    Country:
    United States
    Both firmwares should run gpSP just fine.

    Hellcat's Recovery Flasher should be one of the easiest ways to downgrade your firmware to 5.00 m33

    There are many reasons your D3 firmware upgrade won't work but I'm pretty sure you'll find 5.00 m33 a little more stable though your save games might not work but there is a fix for that.
     
  3. mainframe004
    OP

    Newcomer mainframe004 Member

    Joined:
    Jul 8, 2010
    Messages:
    43
    Country:
    Philippines
    And with patched ISOs, I suppose I wouldn't really need Prometheus, anyway. I'd rather have a more stable firmware than one that bugs all over the place.
     

Share This Page