Trying to play a GBA game on an R4 running YSauto.

Discussion in 'R4 DS' started by Mikecardii, Jun 4, 2009.

  1. Mikecardii
    OP

    Newcomer Mikecardii Member

    Joined:
    Dec 11, 2007
    Messages:
    43
    Country:
    United States
    When I try to play Golden Sun and save it says, "unable to detect backup memory". Is there a fix? Is this a known problem?

    edit: slot 2 device is an ez flash 3-in-1. Anything else you need to know just post.
     
  2. triassic911

    Member triassic911 Burst Mode

    Joined:
    May 9, 2007
    Messages:
    2,743
    Location:
    NYC, USA
    Country:
    United States
    Have you tried SRAM patching it?
     
  3. Mikecardii
    OP

    Newcomer Mikecardii Member

    Joined:
    Dec 11, 2007
    Messages:
    43
    Country:
    United States
    The game? Yes, I have. I've also switched to the official R4 1.18 firmware and put GBAExpLoader on there and loaded both the vanilla rom and the sram patched rom in both exploader modes. I've also dldi patched the gba exploader, it creates the rom image folder and the rom saves folder. I'm pretty much stuck at this point. That error no longer displays, but when I get to select a save slot, no matter which slot I choose it says the game failed to save.
     
  4. triassic911

    Member triassic911 Burst Mode

    Joined:
    May 9, 2007
    Messages:
    2,743
    Location:
    NYC, USA
    Country:
    United States
    Those slots are for having more than 1 save, which is pointless unless you are sharing the game with a relative or so. Disable it in the .ini file.
     
  5. Mikecardii
    OP

    Newcomer Mikecardii Member

    Joined:
    Dec 11, 2007
    Messages:
    43
    Country:
    United States
    I'm not sure how to do this
     
  6. TrolleyDave

    Former Staff TrolleyDave Philosolosophising

    Joined:
    Jan 1, 2007
    Messages:
    7,762
    Location:
    Wales, UK
    Country:
    United Kingdom
    What program did you use to patch it? Are other games definitely saving?
     
  7. Mikecardii
    OP

    Newcomer Mikecardii Member

    Joined:
    Dec 11, 2007
    Messages:
    43
    Country:
    United States
    I haven't tried other games, used gbata
     
  8. triassic911

    Member triassic911 Burst Mode

    Joined:
    May 9, 2007
    Messages:
    2,743
    Location:
    NYC, USA
    Country:
    United States
    Open the .ini file for gbaexploader with notepad and remove the # in front of nomultisave as well as the !. Then click file then save.

    Also...... if you install ysmenu, you won't need gbaexploader anymore as it supports the 3in1 natively.
     
  9. TrolleyDave

    Former Staff TrolleyDave Philosolosophising

    Joined:
    Jan 1, 2007
    Messages:
    7,762
    Location:
    Wales, UK
    Country:
    United Kingdom
    Try some other games and see if they save/load fine.
     
  10. Emeraldman94

    Member Emeraldman94 GBAtemp Regular

    Joined:
    Dec 22, 2008
    Messages:
    296
    Country:
    United States
    I am having the same issue on ys menu. with ez flas 3 in one. I also have this saving issue with crash bandicoot's huge adventure, spyro season of flame and Golden Sun so far.... Please help me fix these issues, none of them save!!!!!!!
     
  11. Mikecardii
    OP

    Newcomer Mikecardii Member

    Joined:
    Dec 11, 2007
    Messages:
    43
    Country:
    United States
    I can't find my microsd usb adopter atm so I can't try new games for now. I'll post once I get a new adopter. I wish I hadn't gotten one that is so damn small, I set it someplace and completely forget where I put it. It could also be all the illicit drugs I do.
     
  12. Mikecardii
    OP

    Newcomer Mikecardii Member

    Joined:
    Dec 11, 2007
    Messages:
    43
    Country:
    United States
    alright so I had some help from another site too, and came to the conclusion that the save battery had died. I've had the EZFlash for about a year and a half, so it makes sense that the battery died. I intend to use this guide to replace it: http://gbatemp.net/index.php?showtopic=132872 thanks to everyone for the responses I received.

    Also to finish up a few questions, no other games saved. Not Astro Boy, and not LoZ Minish Cap.
     
  13. TrolleyDave

    Former Staff TrolleyDave Philosolosophising

    Joined:
    Jan 1, 2007
    Messages:
    7,762
    Location:
    Wales, UK
    Country:
    United Kingdom
    If no other games saved I was going to suggest it might be a dead battery, which is why I asked you to try it! [​IMG]
     
  14. Mikecardii
    OP

    Newcomer Mikecardii Member

    Joined:
    Dec 11, 2007
    Messages:
    43
    Country:
    United States
    Haha thank you [​IMG] well I got the situation all figured out I think. I intend to go to radio shack today to pick up that battery and hopefully have it all done today.
     

Share This Page