Discussion SX OS - Error and Solutions Thread

Discussion in 'Switch - Backup Loaders & Modchips' started by OhhSheetz, Jun 19, 2018.

?
  1. Yes

    158 vote(s)
    75.6%
  2. No

    41 vote(s)
    19.6%
  3. Will verify soon

    10 vote(s)
    4.8%
  1. alkar

    alkar GBAtemp Fan

    Member
    5
    Apr 30, 2013
    United States
  2. Raiden_Wins

    Raiden_Wins Member

    Newcomer
    1
    Sep 10, 2018
    United Kingdom
    Just a quick question. Is it only really worth installing the emunand option if you use .nsp's to keep them separate. I have only ever used .xci as suggested by TX
     
  3. sergux

    sergux Advanced Member

    Newcomer
    3
    Jul 14, 2018
    Afghanistan
    Without CDNSP operative, and after multiple searches i dont find a decent updates list i get a problem when i tried to play Attack on titan 2 the game ask me to download updates to be played but before i updated it across original firmware and now i had a couple of nsp games installed and i could be banned. What options i have?
     
    Last edited by sergux, Oct 4, 2018
  4. Raiden_Wins

    Raiden_Wins Member

    Newcomer
    1
    Sep 10, 2018
    United Kingdom
    Unless you backed up a clean nand I think the wheels already turning. I think someone was banned for having cleaned the logs once but you will have to check the banning forum or maybe someone can confirm.
     
    sergux likes this.
  5. sergux

    sergux Advanced Member

    Newcomer
    3
    Jul 14, 2018
    Afghanistan
    Sorry my english is too bad i didnt explain it good, i just want to update attack on titans 2 to play it.
    Anyway i have a clean backup ready when i decide to use emunand and upgrade to 6.0 ofw.
    My problem is the way to update that game, i just find a pair of updates seaching on google, but attack on titans have now 5 updates aprox i dont know extactly.
     
    Raiden_Wins likes this.
  6. Raiden_Wins

    Raiden_Wins Member

    Newcomer
    1
    Sep 10, 2018
    United Kingdom
    I have only ever used xci format and updated everything in ofw. Went straight to 6.0 so I can't be any help. What firmware do you have right now? If it's not 3.x.x is it worth not updating?
     
  7. trecenters

    trecenters Newbie

    Newcomer
    1
    Sep 26, 2018
    United States
    OFW 3.0.1

    Booting CFW SX OS 1.9: Working

    Boot to SX OS 2.0 Boot Menu : Working
    Emunand Backup: Working

    Booting to OFW 3.0.1 from SX OX 2.0 Boot Menu: Working

    Booting to CFW SX OS 2.0: FAIL "Shows Battery Logo then Black Screen"
    Booting to CFW SX OS 2.0 Emunand: FAIL "Shows Battery Logo then Black Screen"
     
  8. sergux

    sergux Advanced Member

    Newcomer
    3
    Jul 14, 2018
    Afghanistan
    im in 5.1 i dont want update beacuse telemetry of 6.0 and right now games dont need 6.0 so i supose i will update when pokemon launch maybe that game require 6.0
    im too lazy for migrate to emunand :D i prefer only play
     
    Last edited by sergux, Oct 4, 2018
    Raiden_Wins likes this.
  9. cynique

    cynique GBAtemp Regular

    Member
    2
    Feb 12, 2015
    Afghanistan
    Sorry for a noob question.I use use sx pro on mu switch.I tried to play some .xci game and it requires updating the game.Booted to OFW and but this this time i cant update the game without a system update.How can i solve this
     
  10. AnalogMan

    AnalogMan ultraSuMoFramework Dev

    Member
    12
    Apr 20, 2007
    United States
    The easiest solution would be to update your Switch.
     
    Raiden_Wins likes this.
  11. cynique

    cynique GBAtemp Regular

    Member
    2
    Feb 12, 2015
    Afghanistan
    will i be able to use sx pro after ?
     
  12. Raiden_Wins

    Raiden_Wins Member

    Newcomer
    1
    Sep 10, 2018
    United Kingdom
    Yes mine is ofw 6.0 with sx os version 2.0.1
    All fine. Sx os 2.0 is a bit rocky don't bother updating to that beta trial for cheat engine if your on exfat as that may corrupt your sd card
     
  13. Hahyestwo

    Hahyestwo Member

    Newcomer
    1
    Dec 21, 2017
    United States
    I was hoping the 2.0.1 stability update would fix the issues I've been having with emunand crashing on sleep, but I'm still having those issues. Hopefully they'll fix this sometime soon.
     
  14. carlskie

    carlskie Member

    Newcomer
    2
    Dec 21, 2017
    Philippines
    im having a problem with tinfoil on sx os 2.1 running 5.1 i got an error 2168-0002 when i click on album, but i can play the games i install on tinfoil
     
  15. SigmaSebas

    SigmaSebas Member

    Newcomer
    2
    Jan 4, 2016
    Cote d'Ivoire
    cant open regular album wth
     
  16. SgtP3pp3r

    SgtP3pp3r Member

    Newcomer
    1
    Mar 2, 2017
    Ok, i am having a weird issue injecting the payload. I have been using SX OS practically since it launched, im on version 2.0.1
    I was adding a few nsp files and xci this afternoon when i ran into an xci file that wouldnt load (dark souls). So i figured the file might not have downloaded correctly. I redownloaded it, and put it back on the sd card but now, for some reason TegraRCMGUI wont inject the payload. It just hangs while injecting. I tried rebooting the pc, reinstalling TegraRcmGUI with a newer version, and even replacing the boot.dat for SX OS but the problem persists. I tried injecting from my phone and it works fine (dark souls still wont work so i figure it mustve been a bad dump), but im in unable to inject from my pc anymore. Anyone have any idea what could be causing it? It was working fine literally a few minutes before it jammed up, and i did not install anything into my pc in that time frame.
     
  17. Draxzelex

    Draxzelex GBAtemp Legend

    Member
    18
    Aug 6, 2017
    United States
    New York City
    Try using TegraRCMSmash instead since TegraRCMGUI has been known to have various issues not present in the program its based on.
     
  18. SgtP3pp3r

    SgtP3pp3r Member

    Newcomer
    1
    Mar 2, 2017
    I reinstalled the APX Device Driver and then did another reboot, and it seems to be working. It seems alright, but for some reason one of the usb ports takes longer to inject than the others. The offending port takes 3-5 seconds to inject the payload, while another port takes much less than 1 second consistently.
    I'll try using just TegraRCMsmash like you suggest in a bit to see if that helps, but i think it might be the usb port going bad. I wonder if that is related to the switch tho? I mean, on account of the power delivery and demands that the switch may have on the usb port.
    Also, it had been working fine and seems as tho it started failing specifically after hooking up the switch. When i bought the cable, i asked the vendor if it had a 56k ohm resistor, and they replied that it did... But now im thinking i might've been had.
     
  19. jlee13

    jlee13 Newbie

    Newcomer
    1
    Jun 27, 2018
    United States
    I'm having a weird issue, where any version of SX OS I try to load beyond 1.0 crashes my switch. Usually it's when I go to the album, it'll scan for a couple of seconds and then give me an error screen. On 1.4 it crashed on boot. But on 1.0 it works perfectly. I'm on 5.1 firmware, it's a 256GB Sandisk, card has worked great since I got it and continues to work great if I use the 1.0 boot.dat file. Any ideas?
     
  20. gnmmarechal

    gnmmarechal GBAtemp Guru

    Member
    13
    GBAtemp Patron
    gnmmarechal is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Jul 13, 2014
    Portugal
    https://gs2012.xyz
    if you're interested in not burning any efuses when you update, it might be a good idea to check out ChoiDujourNX.
     
Quick Reply
Draft saved Draft deleted
Loading...