SWITCH NOOB PARADISE - Ask questions here

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by epickid37, Nov 1, 2017.

  1. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    18
    Aug 6, 2017
    United States
    New York City
    Even though exFAT is notorious for corruption on the Switch, I don't believe its causing issues with USB install. Although if you are using USB install, there is no point in having exFAT. The cluster size for FAT32 should be set to default or 32K if there is no default option. I should also mention the cluster size for exFAT is 128K.
     
    blaisedinsd likes this.
  2. blaisedinsd

    blaisedinsd GBAtemp Maniac

    Member
    4
    Dec 6, 2012
    United States
    I have had no luck intalling NSP from SD, USB has worked better as I have had 2 successes. Is installing from SD more reliable in general? I have followed guide.sdsetup.com I have tried redownloading from multiple links and I am now on FAT32 with default cluster size that Easus partition manager used. I have been stuck trying to install one update and a third game since yesterday. Frustrating process, is it normally unreliable or do I just have bad files or am doing something else wrong possibly. If goldleaf reports 0 MB/s and is just hanging that means its not going to work right? Are there certain characters in the file name it doesnt like maybe?

    Does 90 DNS break youtube?
     
    Last edited by blaisedinsd, Mar 3, 2019
  3. Adran_Marit

    Adran_Marit Walküre's Hacker

    Member
    9
    Oct 3, 2015
    Australia
    42*South
    What are you using to install the games/updates?

    It breaks the official youtube app, you need to install a patched version that bypasses the nintendo checks
     
    blaisedinsd likes this.
  4. blaisedinsd

    blaisedinsd GBAtemp Maniac

    Member
    4
    Dec 6, 2012
    United States
    I have tried using goldleaf from usb and sd and tinfoil from sd. Both are the versions that were included in the guide.sdsetup.com as of last night. I am thinking now my issues may be related to being on the latest firmware possibly? I found some info about patches for atmosphere that may help but not sure how to use them yet. Tinfoil reports metadata errors I think.
     
  5. Adran_Marit

    Adran_Marit Walküre's Hacker

    Member
    9
    Oct 3, 2015
    Australia
    42*South
    Use the latest kosmos (make sure to delete old folder first) if you want atmos and sigpatched as for goldleaf you need to use ver 0.3 for usb or the 0.5 nightly for sd and usb on fw 7.0.x
     
    blaisedinsd likes this.
  6. doingitwrong

    doingitwrong Member

    Newcomer
    1
    Oct 5, 2015
    United States
    I have a switch on 2.3, I would like now to install atmosphere.

    I have backed up my nand, I used the website "sdsetup" to download atmosphere and some additional tools. What do I do now?...
    1 Enable autorcm
    2 Use hekate to launch CFW then use ChoiDujour to update to 5.1 (for smash)
    3 somehow use tinfoil and usb to install botw with dlc. my sdcard is fat32 and the file size is larger than 4gb (pretty unclear on this step, also I found an xci not a nsp [if that matters])
    4 repeat for any other games

    please help correct this process/fill in the blanks. Thanks very much

    edit: I own multiple switch carts (including zelda), should I just dump them instead?
     
    Last edited by doingitwrong, Mar 4, 2019
  7. nutsack

    nutsack Advanced Member

    Newcomer
    2
    Nov 14, 2018
    United States
    So 7.0.1 is still a mess and no real reason to upgrade from 6.2.0? If it stays like this I'm just sticking to 6.2.0 until the heavy hitters like Astral Chain and Link's Awakening come out.
     
  8. doingitwrong

    doingitwrong Member

    Newcomer
    1
    Oct 5, 2015
    United States
    I don't think any games require 7.x right now so I don't see the point, I plan to upgrade to 5.1 only unless someone tells me otherwise.
     
  9. nutsack

    nutsack Advanced Member

    Newcomer
    2
    Nov 14, 2018
    United States
    The point would probably be stuff like FF VII and Yoshi's Crafted World later this month, but neither of those seem like they're worth the headache. Especially when I can play the original FF VII on Retroarch.
     
  10. blaisedinsd

    blaisedinsd GBAtemp Maniac

    Member
    4
    Dec 6, 2012
    United States
    well I think I am on the latest kosmos since I just followed the guid last night and it seems the site is currently down. I couldn't find .5 nightly build but I got 0.3 and USB install has better success rate. I did successfully install a couple of updates but the game still nags it needs an update, is there maybe just a newer one than I downloaded and how does it even know since internet is blocked?
     
  11. michaelpatko

    michaelpatko Member

    Newcomer
    1
    Dec 25, 2018
    United States
    My switch came with OFW 4.1.0.
    I'm using SX OS 2.5.3
    My SD cards are formatted FAT32
    Some games seem to install, but don't work.
    I'm guessing they require a firmware newer than 4.1.0
    I want to upgrade my firmware, and I don't care about burning fuses.
    I researched ChoixDuJourNX, and it seems like a hassle with the potential to render your cartridge port unusable, and it enabling AutoRCM.
    What is the safest way to upgrade my firmware without rendering the cartridge port unusable?
    Thank you everyone
     
  12. Budsixz

    Budsixz GBAtemp Regular

    Member
    3
    Oct 27, 2018
    India
    Hey guys 1 more question
    So I tried to install zelda dlc via goldleaf but its weird because at first it gave me some error saying metafile not found or something like that but after a while i tried again and it installed but then when i launched the game it gave me an error saying cant launch game as dlc data is corrupted
    what am i doing wrong?
     
  13. natkoden

    natkoden GBAtemp Maniac

    Member
    6
    Jul 25, 2006
    Argentina
    try with tinfoil or n1dus
     
    Budsixz likes this.
  14. Budsixz

    Budsixz GBAtemp Regular

    Member
    3
    Oct 27, 2018
    India
    thanks for the reply, ill try it once i get home and let you know

    — Posts automatically merged - Please don't double post! —

    also is there a way to only delete a dlc or update without deleting the entire game?
     
  15. Adran_Marit

    Adran_Marit Walküre's Hacker

    Member
    9
    Oct 3, 2015
    Australia
    42*South
    devmenu
     
    Budsixz likes this.
  16. Budsixz

    Budsixz GBAtemp Regular

    Member
    3
    Oct 27, 2018
    India
    where do i download it from?
     
  17. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    18
    Aug 6, 2017
    United States
    New York City
    One thing you should be aware of is that there is a one time, irreversible update for the cartridge slot on firmware 4.0. This update renders the slot unusable on firmwares below 4.0. This is useful in case you wish to downgrade in the future when a better exploit is released for lower firmwares where you either want to play your retail cartridges or if the exploit involves using a cartridge. If you wish to prevent it from being updated, you must break the cartridge slot. In other words, if you want to retain the ability to play cartridges on firmwares below 4.0, you cannot play cartridges on firmwares above 4.0. This method differs from CFW to CFW; Atmosphere applies it automatically if it knows you can downgrade to a firmware below 4.0 while ReiNX requires an extension-less file named nogc placed in the ReiNX folder. If you don't care about it being updated, then you can just ignore everything I said as your above steps are fine for general hacking purposes (unless by ChoiDujour you mean ChoiDujourNX because ChoiDujour is a Windows program that takes a lot longer to update your firmware with than the homebrew equivalent and should not be mixed up).

    If you read my post above, rendering your cartridge post is not only optional but only necessary if your firmware is below 4.0. Since you don't care about burning fuses, I would recommend you update normally but since you are using SX OS, it doesn't support the latest firmware so your only choice in the matter is ChoiDujourNX.

    Google.
     
    Budsixz likes this.
  18. Adran_Marit

    Adran_Marit Walküre's Hacker

    Member
    9
    Oct 3, 2015
    Australia
    42*South
    Google, I posted the hash of the file maybe half dozen pages back
     
    Budsixz likes this.
  19. MadysoN

    MadysoN Member

    Newcomer
    1
    Feb 20, 2019
    Iran
    can someone please teach me how to install XCI games ? I really don't get how it works
     
  20. pLaYeR^^

    pLaYeR^^ Doctor Switch

    Member
    8
    GBAtemp Patron
    pLaYeR^^ is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Sep 18, 2014
    Austria
    Austria
    You don’t need to install them. You can simply play them from usb hdd or stick.
     
Loading...