1. wizball1973

    OP wizball1973 Advanced Member
    Newcomer

    Joined:
    Nov 4, 2012
    Messages:
    59
    Country:
    Senegal
    Hi all,

    I notice some game updates (World Conqueror X, Aces of the Luftwaffe) make the game require an online check. Which I fail as I'm superbanned. Anyway to install these updates with this check disabled?

    Thanks,

    Jaz
     
  2. Kubas_inko

    Kubas_inko "Something funny goes here."
    Member

    Joined:
    Feb 3, 2017
    Messages:
    6,307
    Country:
    Czech Republic
    Update them via nsps.
     
    Albytrozz likes this.
  3. wizball1973

    OP wizball1973 Advanced Member
    Newcomer

    Joined:
    Nov 4, 2012
    Messages:
    59
    Country:
    Senegal
    I did. The update initiates the online check.
     
  4. Kubas_inko

    Kubas_inko "Something funny goes here."
    Member

    Joined:
    Feb 3, 2017
    Messages:
    6,307
    Country:
    Czech Republic
    Try removing it by booting to recovery/maintenance mode (vol up + down) and never go online again.
     
  5. wizball1973

    OP wizball1973 Advanced Member
    Newcomer

    Joined:
    Nov 4, 2012
    Messages:
    59
    Country:
    Senegal
    I removed the updates but the game now tells me an update is needed and wont start.
     
  6. wizball1973

    OP wizball1973 Advanced Member
    Newcomer

    Joined:
    Nov 4, 2012
    Messages:
    59
    Country:
    Senegal
    Anyone have a solution to this?

    A select few of the .NSP files I have installed have an issue.

    When installing the latest update, a feature of this new update is they MUST connect to an online server to validate that they have been purchased.

    Is there a way to remove this?

    Example:

    I have Aces of the Luftwaffe .NSP.
    I install it but it will not boot as it MUST be updated. The base game alone will not run.
    I install the required update.
    Now, the game attempts to validate itself online before booting.
    It fails as I am superbanned and have no internet access.

    Any way to remove this validation? Note, merely installing just the base game does not work for the reasons outlined above.
     
  7. shadoom

    shadoom GBAtemp Regular
    Member

    Joined:
    Sep 14, 2009
    Messages:
    294
    Country:
    Taiwan
    Are you on 6.0.1?
     
  8. bundat

    bundat ¿
    Member

    Joined:
    Jul 25, 2018
    Messages:
    454
    Country:
    Antarctica
    I don't have these games so I'm not sure if this is exactly the scenario that you are in.

    But if you install an update, then remove it, the Switch still remembers the latest update a game had and refuses to run a lower version of that game.

    Back in 5.x, the solution was to use the "ResetRequiredVersion" feature of devmenu. Not sure if there is a solution for firmware 6.x (factory restore maybe?)
     
  9. arianadark

    arianadark GBAtemp Advanced Fan
    Member

    Joined:
    Nov 20, 2016
    Messages:
    716
    Country:
    United States
    reinstall the games using tinfoil and ignore required firmware
     
    spenat, Lacius and Erol like this.
  10. wizball1973

    OP wizball1973 Advanced Member
    Newcomer

    Joined:
    Nov 4, 2012
    Messages:
    59
    Country:
    Senegal
    That won't stop it validating online though.
     
  11. arianadark

    arianadark GBAtemp Advanced Fan
    Member

    Joined:
    Nov 20, 2016
    Messages:
    716
    Country:
    United States
    ill install one of those games and see if I have issues when I get home
     
  12. wizball1973

    OP wizball1973 Advanced Member
    Newcomer

    Joined:
    Nov 4, 2012
    Messages:
    59
    Country:
    Senegal
    Thanks! Aces of Luftwaffe does it, as does World Conqueror X. Both games I did actually pay for :(
     
  13. Undi

    Undi TRASH 悲しい天使
    Member

    Joined:
    Feb 22, 2014
    Messages:
    327
    Country:
    Belgium
    I have the same problem.
    Connected the Switch one time to check if I was banned, and I am superbanned.
    I have done the last update offline, and now I can't play game I have updated offline.
    Never tried the Vol up + down tough.
    Never got online check for a game.
     
    Last edited by Undi, Oct 28, 2018
  14. peteruk

    peteruk GBAtemp Addict
    Member

    Joined:
    Jun 26, 2015
    Messages:
    2,694
    Country:
    United Kingdom
  15. Undi

    Undi TRASH 悲しい天使
    Member

    Joined:
    Feb 22, 2014
    Messages:
    327
    Country:
    Belgium
    Yes something is wrong with the last firmware update, I tried to update the games I have with last update, but I can't play it on 6.0.1.
    I'm sure the updates I installed are the lastest updates available...
     
    Last edited by Undi, Oct 28, 2018
    Albytrozz likes this.
  16. peteruk

    peteruk GBAtemp Addict
    Member

    Joined:
    Jun 26, 2015
    Messages:
    2,694
    Country:
    United Kingdom
    It's going to be interesting if any more users develop this problem and more so if a way around it can be found. This could potentially be a match winner for N if this becomes a thing
     
    kop365, Citrus-Hombre and Alex-Kidd like this.
  17. illumunatic1981

    Newcomer

    Joined:
    Sep 25, 2018
    Messages:
    16
    Country:
    Germany
    i'm on latest firmware,more than 100 games are on the latest update,can play em all without problems. i'm banned and can't update games official but with nsp it works without issues....
     
    Don Jon and matias3ds like this.
  18. BL4Z3D247

    BL4Z3D247 GBAtemp Stoner
    Member

    Joined:
    Oct 22, 2008
    Messages:
    1,943
    Country:
    United States
    Are any of the 100 games World Conqueror X or Aces of the Luftwaffe(or any game that requires online validation in order to play)? If not your input isn't very useful.

    The OP said those games specifically are giving them the issue they described, if you have those games test them out and report back so people can get some useful feedback when they're searching this issue.
     
    stephrk398, GaaraPrime and Albytrozz like this.
  19. therocker12

    therocker12 Member
    Newcomer

    Joined:
    Mar 8, 2018
    Messages:
    20
    Country:
    Germany
    the only thing you can try right now is a factory reset. once you install a update the switch remembers that state and does not let you play base games without a update anymore. because apparantly the newest update forces a onlinecheck it seems that game is pretty much unplayable for you now. i personally dont know if a factory reset deletes the "memory" of the switch that you had a update of the game installed. depends if you want to go through the trouble of wiping everything on your switch to see if atleast you can get the base game running again with a prior update that did not have these online checks

    — Posts automatically merged - Please don't double post! —

    i tried world conquerer x out for you. installed the update (version nr. 1.0.4) and the game runs without a online check. it boots without a problem in the game menu.

    i am on firmware. 6.0 though.

    another edit:

    i factory reset my switch for you. i did not really have any long games going on so it did not matter to me if i lose save data. if you factory reset your switch the base games are playable again. so like i said before. if you want to jump through the hoops atleast you will be able to play the base game again in case you want to do a factory reset.
     
    Last edited by therocker12, Oct 28, 2018
    peteruk likes this.
  20. arianadark

    arianadark GBAtemp Advanced Fan
    Member

    Joined:
    Nov 20, 2016
    Messages:
    716
    Country:
    United States
    i installed Aces of the Luftwaffe( and it did say to me that there was an update but it allowed me to play it just fine
     
    Don Jon and felixsrg like this.
  21. Zumoly

    Zumoly GBATemp Analyst
    Member

    Joined:
    Apr 27, 2018
    Messages:
    1,761
    Country:
    Mali
    Maybe this is happening with legit games tied to the Nintendo account? If so Nintendo really is going extra lengths (putting ban detect mechanics in updates) to make life hard for banned consoles.
    At any rate if 6.0.1 is at fault you could always use choixdujour to downgrade to either 6.0 or 5.1 (AutoRCM + CFWa allow this).
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - Checking, Updates, License