All games requires updates

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by Gwandoya, Oct 28, 2018.

  1. Gwandoya
    OP

    Gwandoya Newbie

    Newcomer
    1
    Oct 28, 2018
    Germany
    Hello,

    recently i've modded console and got banned :(
    Yesterday i wanted to play Mario Kart 8 dx and the console forced me to update the game.
    This didn't work (Error Code 2181-4008). so i tested all my games and no one worked.

    Is there a work arround or something, i can do?

    The Systemversion is 6.0.1 and my games are on cards. (Not online)

    - GwanDoya
     
  2. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    18
    Aug 6, 2017
    United States
    New York City
  3. Ashura66

    Ashura66 GBAtemp Advanced Maniac

    Member
    7
    Feb 1, 2016
    Portugal
    Under my bed
    Someone was talking about this on another thread but it seems games now have to validate online before actually launching on 6.0.1, even if you have the latest updates installed. Any info on this?
     
  4. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    18
    Aug 6, 2017
    United States
    New York City
    I just read through that other thread and I have to say that's really peculiar. This seems like a recent problem as I have no idea how to fix or even what triggers it but I suppose the easiest fix is by undoing the update with DevMenu.
     
  5. Ashura66

    Ashura66 GBAtemp Advanced Maniac

    Member
    7
    Feb 1, 2016
    Portugal
    Under my bed
    But isn't DevMenu non functional on 6.0.1?
     
  6. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    18
    Aug 6, 2017
    United States
    New York City
    Who said you would be running DevMenu on 6.0.1 :P
     
  7. eyeliner

    eyeliner Has an itch needing to be scratched.

    Member
    6
    Feb 17, 2006
    Portugal
    Well, that's a very crappy thing to do. But, what if you are oneof those people that don't want to/can't connect your switch online?
    You can't play your games?
     
  8. Ashura66

    Ashura66 GBAtemp Advanced Maniac

    Member
    7
    Feb 1, 2016
    Portugal
    Under my bed
    That's exactly the thing that's being discussed on the other thread. Like for example if you're banned and this happens to you, you're pretty much screwed, not even CFW would help you
     
  9. illumunatic1981

    illumunatic1981 Member

    Newcomer
    1
    Sep 25, 2018
    Germany
    Waldkraiburg/Bavaria/Germany
    i'm on latest firmware,more than 100 games are on the latest update,can play em all without problems. i'm banned and can't update games official but with nsp it works without issues....
     
  10. Gwandoya
    OP

    Gwandoya Newbie

    Newcomer
    1
    Oct 28, 2018
    Germany
    where do i get those nsps?
    edit: i never asked but thanks
     
    Last edited by Gwandoya, Oct 28, 2018
    illumunatic1981 likes this.
  11. illumunatic1981

    illumunatic1981 Member

    Newcomer
    1
    Sep 25, 2018
    Germany
    Waldkraiburg/Bavaria/Germany
    google it,it's not allowed here ;) but a little bird whispered "theres a DARK UMBRellA" over the world.....
     
    Multimegamander likes this.
  12. Nerdtendo

    Nerdtendo Your friendly neighborhood idiot

    Member
    7
    Sep 29, 2016
    United States
    Technically, you're not supposed to ask. Google is your friend and if you run into any black umbrellas you're on the right track.
     
    illumunatic1981 likes this.
  13. Nerdtendo
    This message by Nerdtendo has been removed from public view by Joe88, Oct 28, 2018.
    Oct 28, 2018
  14. LordRahl72

    LordRahl72 Advanced Member

    Newcomer
    3
    Jun 12, 2018
    United States
    Had the same issue today with a few random games that I know is already on the latest version. After rebooting into the stock firmware and manually running an update then rebooting into custom firmware I was able to boot the games. Strange thing is that I am pretty sure nothing actually seemed to have downloaded and updated on the games.

    I also noticed this only happened after installing an NSP of some random pre-released game earlier today.
     
    lordelan likes this.
  15. lordelan

    lordelan GBAtemp Psycho!

    Member
    11
    Jan 4, 2015
    Germany
    I'm on 6.0.1 without any problems but this sounds pretty bad. Ninty is trying to get things handled as it seems.

    Diablo 3? :D
     
  16. Albytrozz

    Albytrozz GBAtemp Regular

    Member
    4
    Jun 10, 2018
    United States
    I keep my Switch offline on 5.1.0... I let it online ONCE in SX OS for a few mins a couple weeks ago to try FTP and it phoned home because I started to get all kinds of 6.0 update prompts I didn't get before. I learned I can't go online at all at anytime, no matter if you never run a game or anything Nin related when you are. I also haven't updated to 6.0+ yet but with Tinfoil 'Ignore Version' feature I haven't had to yet and don't plan to ever let it online again for these reasons, Nin is getting sneakier.
     
  17. lordelan

    lordelan GBAtemp Psycho!

    Member
    11
    Jan 4, 2015
    Germany
    No need to stay offline:
    https://gbatemp.net/threads/90dns-dns-server-for-blocking-all-nintendo-servers.516234/
    That'll do for all homebrews and FTP related stuff while keeping Nintendo out of the game.
     
    Albytrozz likes this.
  18. Clydefrosch

    Clydefrosch GBAtemp Guru

    Member
    11
    Jan 2, 2009
    Germany
  19. lordelan

    lordelan GBAtemp Psycho!

    Member
    11
    Jan 4, 2015
    Germany
    Obviously. That's why you do it just inside the settings of your Switch internet connection. :)
     
  20. sh0wst0pper
    This message by sh0wst0pper has been removed from public view by x65943, Dec 22, 2018, Reason: Asking for warez.
    Dec 22, 2018
  21. Lacius

    Lacius GBAtemp Guru

    Member
    17
    May 11, 2008
    United States
    You should be able to use DevMenu to remove the required version for each game, eliminating the game update nag.
     
    sh0wst0pper likes this.
  22. bbert

    bbert Newbie

    Newcomer
    1
    Oct 20, 2018
    Philippines
    I'm just wondering how the update works. Is it like an incremental update that you need to install update 1.1 first before you can install 1.2 and so on. Or if there's a new release update, is it like a one package contains the whole update from before?
     
  23. masagrator

    masagrator File digger

    Member
    6
    Oct 14, 2018
    Poland
    You need to install only last patch.
     
    bbert likes this.
  24. lordelan

    lordelan GBAtemp Psycho!

    Member
    11
    Jan 4, 2015
    Germany
    All updates include all previous ones.
    So base game + most recent update is always enough. This goes for 3DS, Wii U and Switch.
     
    bbert likes this.
Loading...