Stay on 6.1 or update?

Discussion in '3DS - Flashcards & Custom Firmwares' started by arasch, Nov 3, 2013.

  1. arasch
    OP

    arasch Member

    Newcomer
    14
    5
    Jan 22, 2008
    Gambia, The
    Hi,

    I have a question regarding the latest firmware.
    I'm currently on 6.1 but i'd love to play Ace Attorney.
    Now I'm currently waiting for the Gateway to support firmware version above 4.5, but since the Gateway has been released, there is no hint on a new exploit on higher firmwares.
    Now I've read something about not to update above 6.2. What would you recommend?

    Thanks in advance :)
     
  2. redkeyboard

    redkeyboard GBAtemp Advanced Fan

    Member
    627
    154
    Jan 8, 2013
    United States
    It seems very unlikely that Gateway will support anything over 4.5 anytime soon. I would update, if you're still interested in the Gateway the best thing to do would be selling your 3DS and getting one with 4.5 . You can play Ace Attorney when the emuNAND update releases.
     
  3. kyogre123

    kyogre123 Mexican Pride

    Member
    2,919
    1,260
    Sep 23, 2013
    Mexico
    I think there's not too much difference between 5.1 and 6.3 with respect of possible exploits. I recommend the above tip though.
     
  4. omega

    omega Newbie

    Newcomer
    4
    0
    Nov 4, 2013
    France
    I actually doubt there will be a similar exploit for newer firmwares anytime soon.
    The priority is NAND emulation support in order to play ROMS requring a newer firmware from 4.5.

    The reason why it says it's not recommended to go beyond 6.2.0 is that it's likely Nintendo got
    their hands on a GATEWAY 3DS from that time as well and they obviously will attempt to stop it
    from functioning properly.
     
  5. Rob Blou

    Rob Blou GBAtemp Advanced Fan

    Member
    642
    297
    Jul 16, 2013
    Canada
    I'm on 5.1 :( I was at my friend's place yesterday and he has a red XL just like me ... he haven't played for a while since he was injured so I had hope he was on 4.5 and I could trade my 3DS for his ... I went in the settings and it was on 5.0 :/
     
  6. Jao Chu

    Jao Chu GBAtemp Advanced Maniac

    Member
    1,917
    1,211
    Aug 20, 2013
    straya m8
    If the gateway team team find a kernel exploit for 5.x firmwares and keep it hush hush, there's no reason why it shouldn't work with all future firmwares up until the update just after the exploit was released (due to nintendo patching the vulnerability)

    Why? Because there will be little chance Nintendo will find that exploit.

    The NVRAM exploit in the DS profile settings menu (the exploit Gateway uses for ROM loading) was patched long before Gateway cart was released because the same hack was plastered all over for the world (and nintendo) to see and analyse.

    I'm active In the PS Vita scene, many devs sit on user-mode and kernel exploits (inside the PSP emu) for many firmware updates and they still work because Sony simpily doesn't know they exist :yaysp:
     
  7. arasch
    OP

    arasch Member

    Newcomer
    14
    5
    Jan 22, 2008
    Gambia, The
    Ok, thank you guys for your advice.
    I think, i will sell my 3DS XL and buy the XL Mario Kart Bundle.

    One last question, is there a possibility to transfer my saves and stuff to the new 3DS without updating?
     
  8. ground

    ground GBAtemp Advanced Fan

    Member
    909
    281
    Mar 22, 2007
    Netherlands
    correct me if i am wrong, but it is more likely that the gateway team finds an working exploit for 6.1, which won't work at 6.3.
    This because the entry for the exploit still exist in 6.1(?), but it doens't work because the ROP code has to be rewrittin with different codes. As soon as gateway released their product nintendo fixed the entry for the exploit.

    (again, i can be wrong, but i thought I red thsi somewhere)
     
  9. Arras

    Arras GBAtemp Guru

    Member
    5,840
    2,659
    Sep 14, 2010
    Netherlands
    From what I know (and I could be wrong) 6.3 is just as vulnerable as 6.1, but staying on 6.1 is probably safer just in case.
     
  10. sanderdsz

    sanderdsz Advanced Member

    Newcomer
    60
    7
    Dec 9, 2006
    Brazil
    I hope so...
     
  11. DragonSky

    DragonSky GBAtemp Advanced Fan

    Member
    740
    71
    Oct 27, 2010
    Belgium
    If even the clones like R4 can't update to 5.x 6.x firmware chances are unlikely.
     
  12. lambstone

    lambstone No. Nyet. 不. Non. Nein.

    Banned
    615
    167
    Aug 14, 2011

    And where did you know they stuff from what you know?

    I mean the general consensus is that 6.3 users are doomed but where did you obtain the information regarding vulnerabilities still existing in 6.1?
     
  13. Nurio

    Nurio That Kirby fan

    Member
    842
    191
    Mar 31, 2009
    Netherlands
    The Netherlands
    He never said vulnerabilities still exist in 6.1. He says 6.3 is just as vulnerable as 6.1. That means that if there is a vulnerability in 6.1, it's most likely in 6.3 as well. But for that off chance it is not, it's better to play it safe and stay on 6.1.
     
  14. WulfyStylez

    WulfyStylez SALT/Bemani Princess

    Member
    1,149
    2,607
    Nov 3, 2013
    United States
    The actual changes between those two versions are very minimal. 6.2.0 only changed modules related to streetpass, 6.3.0 added a title to SD data backup blacklist. That's all. Updating right now wouldn't necessarily hurt (from 6.1.0 at least), but updating in the future sure could. Exploits I'm aware of that are present in 6.1.0 are present in 6.3.0.
     
  15. mysticwaterfall

    mysticwaterfall Streamforce Supreme Commander

    Member
    1,868
    294
    Aug 11, 2008
    United States
    Right behind you
    I stopped worrying about all this upgrade nonsense and if a game will play or not... I just get the games I want and play them. The end. If you want to play Ace Attorney, just play it. Who knows when/if Gateway will ever work post 4.5.
     
  16. redkeyboard

    redkeyboard GBAtemp Advanced Fan

    Member
    627
    154
    Jan 8, 2013
    United States
    It might be possible with the dual booting Nand solution Gateway has coming in the 2.0 update.
     
  17. stanleyopar2000

    stanleyopar2000 The Official GBATEMP Thread Killer. No Mercy.

    Member
    3,976
    600
    Jun 22, 2007
    United States

    if you need to use the DS Transfer tool then the answer is no. you HAVE to update. I'm in the same boat with my 4.5 3DS with all my DSiWare and 3DSware that have :(
     
  18. redkeyboard

    redkeyboard GBAtemp Advanced Fan

    Member
    627
    154
    Jan 8, 2013
    United States
    Which is why I mentioned the dual booting solution gateway calls emuNAND, which allows you to run the latest firmware on your 3ds.
     
  19. arasch
    OP

    arasch Member

    Newcomer
    14
    5
    Jan 22, 2008
    Gambia, The
    That may be true, and of cource Ace Attorney is one of those games I'd love to pay for.
    But with the 4.5 exploit, Team Gateway and Smealum can create great new features, not only loading backups like nandbackup or bypassing regionlock.
    Emunand would be great, so you could buy your favourite games, but i don't want to miss all of these possibilities.

    I will wait until Gateway 2.0 comes out and see if emunand is what i hope it is. Then I could buy a new 3DS with 4.5 and transfer my stuff on emunand.