Status on Firmware 4.5+ hacking

Discussion in '3DS - Flashcards & Custom Firmwares' started by Tiduas, Jul 28, 2014.

Thread Status:
Not open for further replies.
  1. Tiduas
    OP

    Tiduas Newbie

    Newcomer
    3
    0
    Oct 28, 2009
    Hello everyone! I recently got interested in 3DS flashcards but since I didn't know about only 4.1-4.5 was supported I have upgraded all the way up to 7.2. :hateit:

    So after trying to do some research about it, I couldn't find anything about the status on getting firmwares above 4.5 to work with flashcards. Have the developers said anything about it, maybe that it might happen in the near future or that it seems impossible or something? I really don't want to search for an older console at the moment because of economical reasons.
     
  2. justln

    justln GBAtemp Advanced Fan

    Member
    708
    276
    Aug 16, 2013
    No.
     
    Subtle Demise likes this.
  3. yusuo

    yusuo GBAtemp Addict

    Member
    2,493
    846
    Oct 19, 2006
    The only dev whose really talking is smea, have a look at his twitter. Apparently he's got some version of cfw working and is considering releasing it soon but it will be minus the piracy aspect as he doesn't believe in that sort of thing
     
  4. IronClouds

    IronClouds GBAtemp's Pokébro

    Member
    1,018
    460
    May 8, 2010
    United States
    Hi, Tiduas! I see you've been a member here for years, but this is your first post. I'd like to direct you to the stickies in this very forum. If you'd looked up prior to creating this thread, you'd have seen the thread titled: 3DS Flashcarts - News, Updates, and Support Thread. Here, I'll link it for you as well http://gbatemp.net/threads/3ds-flashcarts-news-updates-and-support-thread.357776/ . Anyway, there's an FAQ section in that first post with the answer to your question.

    Since this is your first post, I wanted to welcome you to the forum and give you some advice. Please put in effort to find your answer to any questions, especially if it's something that's easy to find with a little effort (e.g. it would've taken you 1-2 seconds to locate that sticky instead of the 1-2 minutes it took to create this thread). Creating threads such as these (i.e. threads that have information that is considered very basic and/or very easy to find with minimal effort on your part) gives off the impression that your time is more valuable than everyone else's, which just looks bad on you. This will, in turn, prompt some long-time members to become annoyed and express this annoyance in their posts. This forum is most helpful if you help yourself first, so try doing that from now on and you'd be surprised how much information you can find on your own with little effort (and yeah, the stickies are a great source of most information new and old members may ask!). Welcome to the forum, and hope you post more after this!

    :)
     
    ScarletCrystals and Vappy like this.
  5. Tiduas
    OP

    Tiduas Newbie

    Newcomer
    3
    0
    Oct 28, 2009
    Thanks for the answer everyone!

    I gave the sticky you linked to IronClouds a quick look but couldn't find any information on the current situation. That sticky was last edited on Jan 5, 2014 and thus I created this thread since a lot could have happened during half a year. On a second look though, I see that I didn't pay close attention to the part where it said that instead of creating a new thread I should have asked it directly in that thread so for that I excuse myself since it was clearly a misstake from my part.
     
  6. IronClouds

    IronClouds GBAtemp's Pokébro

    Member
    1,018
    460
    May 8, 2010
    United States
    I can see why you would've thought that, but that's exactly what the situation is currently. Even though looks like old news, it's current (i.e. there is still no flashcart support for firmwares greater than 4.5).
     
  7. carlos2013

    carlos2013 Banned

    Banned
    38
    5
    Dec 6, 2013
    United States
    There is no 3DS flashcard works on above v4.5,You can only choose to play ds games on 3DS.:rolleyes:
     
  8. cracker

    cracker Nyah!

    Member
    3,142
    410
    Aug 24, 2005
    United States
    Just try to wait until smea releases his exploit to run homebrew at least. It will undoubtedly be reverse engineered by GW and hopefully allow 5.0+ compatibility.
     
  9. ken28

    ken28 GBAtemp Advanced Fan

    Member
    694
    172
    Oct 21, 2010
    Germany
    smealum tweated some kind of Hex value today, saying its for later.
    Maybe public/priavte keys of the 3ds?
     
  10. cracker

    cracker Nyah!

    Member
    3,142
    410
    Aug 24, 2005
    United States
    It would never be a private key. That is only held by very secure locations and if it were miraculously found then it would be suicide to post on a public forum. Even a private (common) key would be illegal to post. It is more than likely a hash of a piece of code he found in the firmware that he is exploiting.
     
  11. Bond697

    Bond697 Dies, died, will die.

    Member
    353
    259
    Jun 7, 2009
    United States
    CT
    no, there's no arm9 exploit. it's arm11-only. usermode-only at that.
     
  12. Vappy

    Vappy GBAtemp Advanced Maniac

    Member
    1,507
    1,154
    May 23, 2012
    Pretty sure the 3ds doesn't use asymmetric encryption, which'd mean that there is no private key.
     
  13. ken28

    ken28 GBAtemp Advanced Fan

    Member
    694
    172
    Oct 21, 2010
    Germany
    well it was just a guess, it could be anything at that point.
     
  14. Reecey

    Reecey Mario 64 (favorite game of all time)

    Member
    4,157
    1,078
    Mar 7, 2010
    At Home :)
    You should of checked m8ty before you updated your 3DS, that was a very very costly update, especially as 3DS's up to firmware 4.5.0 are now very rare to buy nowadays unless they are wrongly advertised for sale because of there stupidity of a fatal update and a quick shut off and its stuck on the latest firmware but still says 4.5.0 in the options menu and you get ripped, which is what I have read has happened to a few on here so beware buying one on Ebay etc.. Tbh buddy I doubt you will ever see Gateway on over 4.5.0 now, the only option that might come true is a bit off homebrew only but as far as playing scene releases, its not going to happen my friend! All I can say to you is "damn"!!! :hateit:
     
Thread Status:
Not open for further replies.