Should i upgrade my firmware?

Discussion in 'Wii - Hacking' started by Yazoo1990, Jul 31, 2012.

Jul 31, 2012
  1. Yazoo1990
    OP

    Newcomer Yazoo1990 Newbie

    Joined:
    Jul 31, 2012
    Messages:
    5
    Country:
    United Kingdom
    I hacked my wii about 2/3 years ago and i haven't played it since
    Just booted it up and im running Ver. 4.1E
    Got the homebrew channel and neogamma. If i wanted to run some new games do i have to update the firmware or upgrade the channels?
    How would i do it also
    I remember i tried running NSMB and i would get a blank screen don't know why though.

    Cheers in advance
     
  2. ComeTurismO

    Member ComeTurismO CTO

    Joined:
    Sep 18, 2011
    Messages:
    2,909
    Location:
    4:54 PM
    Country:
    Canada
    Well do you know what consequencex yoj will face┬┐
     
  3. Lacius

    Member Lacius GBAtemp Psycho!

    Joined:
    May 11, 2008
    Messages:
    3,917
    Location:
    St. Louis, Missouri
    Country:
    United States
    I recommend you use ModMii to update/install the latest recommended IOS and cIOS files. System Menu 4.1 was the last one to do anything that wasn't just homebrew-prevention, so ModMii will not upgrade that since it's unnecessary and not recommended.

    The reason backups of newer games might not be working is because of outdated cIOS files or your loader. ModMii will update your cIOS files, and you should probably use the latest version of NeoGamma R9 if you're still using disc backups. It should also be noted that most people have moved on to USB loader for running Wii and GameCube backups.

    As for retail discs, you will need to install Priiloader in order to block disc updates that would stub your cIOS files. The instructions are in ModMii as well.

    It is also recommended that you update your Homebrew Channel if you haven't already done so.
     
  4. Taleweaver

    Member Taleweaver Storywriter

    Joined:
    Dec 23, 2009
    Messages:
    5,127
    Location:
    Belgium
    Country:
    Belgium
    Hi there,

    You're in luck: 4.1E was the last firmware version that actually had an actual improvement. 4.2 and 4.3 contained nothing that can't be updated otherwise.

    Upgrading the channels isn't that hard: for the homebrew channel, check out this link if you're not on version 1.1.0 already. For neogamma, this link gets you the latest stuff.

    However...just having the latest channels won't be enough. To actually run games, you need the proper IOS and cIOS. Those can be gotten with a PC program called modmii (the program can fetch pretty much anything, btw).

    It may be important to tell how you play games like NSMBW. By retail disk, backup disc or from USB drive?
     
  5. BORTZ

    Global Moderator BORTZ wtf, nintendo

    Joined:
    Dec 2, 2007
    Messages:
    10,652
    Country:
    United States
    I am still on 4.0 U from 3 years ago. Everything works fine for me.
    But then again im using CFG loader.
     
  6. Yazoo1990
    OP

    Newcomer Yazoo1990 Newbie

    Joined:
    Jul 31, 2012
    Messages:
    5
    Country:
    United Kingdom
    Thanks for the replies Lacius and Wever
    Yeah i use backup disks, but i didn't even know you could use USBs now.

    How would i upgrade I've forgotten everything, I think i used to put everything on a SD and install it. But im not sure where my Wii SD card is, i think i might of lost it. Can you do it via USB now
     
  7. Psionic Roshambo

    Member Psionic Roshambo GBAtemp Advanced Maniac

    Joined:
    Aug 12, 2011
    Messages:
    1,711
    Country:
    United States
    I often wonder what homebrew breaks when updating the Wii to 4.3, I have mine on that firmware and everything seems to work just fine.

    Edit:


    I think you can get away with no SD card but I can tell you that having even just a 1GB card can make things much more fun :) (I use a 4GB card and keep all the emulators I use on that.)
     
  8. Lacius

    Member Lacius GBAtemp Psycho!

    Joined:
    May 11, 2008
    Messages:
    3,917
    Location:
    St. Louis, Missouri
    Country:
    United States
    If you have your Homebrew Channel and whatnot up-to-date, then they will work. However, 4.2 and 4.3 do things like unnecessarily overwrite bootmii, improve region checks (which can cause bricks), etc.There is no reason to update passed 4.1.
     
  9. ddetkowski

    Member ddetkowski GBAtemp Maniac

    Joined:
    Jun 15, 2009
    Messages:
    1,141
    Location:
    United States
    Country:
    United States
    Nope, still need a SD card to update using anything, really....
     
  10. Lacius

    Member Lacius GBAtemp Psycho!

    Joined:
    May 11, 2008
    Messages:
    3,917
    Location:
    St. Louis, Missouri
    Country:
    United States
    Use ModMii.
     
  11. Yazoo1990
    OP

    Newcomer Yazoo1990 Newbie

    Joined:
    Jul 31, 2012
    Messages:
    5
    Country:
    United Kingdom
    Ok found my SD card and i've loaded up ModMii
    Just Downloading everything now and hopefully should be all gravy :D
     
  12. Yazoo1990
    OP

    Newcomer Yazoo1990 Newbie

    Joined:
    Jul 31, 2012
    Messages:
    5
    Country:
    United Kingdom
    Updated my homebrew channel but im not sure how to install the neogamma beta. Is that a drag and drop to the SD card?
    Also im clueless about the IOS and cIOS files. Don't know how to upgrade them?
     
  13. Yazoo1990
    OP

    Newcomer Yazoo1990 Newbie

    Joined:
    Jul 31, 2012
    Messages:
    5
    Country:
    United Kingdom
    Question about modwii

    I've entered all the settings and it's gave me a folder
    Do I just copy and paste everything on my SD?
    And should I delete all my old files off my SD?
     

Share This Page