SGB problem on Lameboy...

Discussion in 'CycloDS' started by Ammako, Feb 4, 2010.

Feb 4, 2010

SGB problem on Lameboy... by Ammako at 3:01 AM (1,385 Views / 0 Likes) 2 replies

  1. Ammako
    OP

    Member Ammako GBAtemp Guru

    Joined:
    Dec 22, 2009
    Messages:
    6,372
    Country:
    Canada
    You know how on Lameboy there's an option to turn on and off the SGB mode?
    Well, when I turn it off, even if I save the settings, for some reason the next time I boot a sgb-able rom, it will start in SGB mode.
    To prevent that, I have to go back and set SGB back to on, then off again.

    Is there a way around that? It bugs me pretty much, considering I prefer playing my GB games in black-and-white and not colored.
    The SGB frames are glitchy, too, the white parts appear black until I re-load the rom.
     
  2. Sir_Shaggy

    Member Sir_Shaggy GBAtemp Regular

    Joined:
    Dec 3, 2008
    Messages:
    109
    Country:
    Canada
    This thread would be best in the NDS - Emulation section but I'll try to add some troubleshooting.

    The lameboy has a cfg file, usually on the root of your microSD card which stores all the saved configuration information such as the SGB mode. I don't have my DS with me to confirm which setting it is, but there should be a value in that cfg file that sets the SGB mode. Try opening it in notepad.

    Also check to see if the cfg file is a read-only file, if so then that's why Lameboy isn't saving your changes.
     
  3. Ammako
    OP

    Member Ammako GBAtemp Guru

    Joined:
    Dec 22, 2009
    Messages:
    6,372
    Country:
    Canada
    "lbsa   " is the only thing that appears in the config file.
     

Share This Page