Seeking Assistance to Boot WADs off emuNAND using USB Loader GX

Discussion in 'Wii - Backup Loaders' started by CodeBlue, Jul 29, 2019.

  1. CodeBlue
    OP

    CodeBlue Newbie

    Newcomer
    1
    Feb 15, 2019
    United States
    Hello, I modded my Wii earlier this month and most things seems to be going swimmingly. The GameCube games I've backed up run just fine with Nintendont, and I intend to backup Wii games later once I have the storage space. However, I'm experiencing problems. I've followed Cyan's instructions in an old post about someone having problem properly utilizing emuNAND as I'm attempting to install into emuNAND and boot them that way. And while creating the emuNAND went without a hitch, utilizing it has been a different matter. GameCube games still run fine, but the installed wads do not, aside from the system wads which seem to be running off of sysNAND data despite the Loader being set to emuNAND. The others simply take me to the boot screen for the loader. I tried with both and N64 VC title and a few Wiiwares, so I assumed they were the problem given that Cyan himself said that there were compatibility issues with those types of WADs. However, I tried to test it by installing a Super Mario Kart VC WAD using the loader's emuNAND WAD Manager just to find that it doesn't load within USB Loader GX's Menu at all.

    A bit of info for clarification:

    Ver. 3.0
    Rev. 1272

    Loader's IOS: 58
    Game's IOS: 249
    Block IOS Reload: Auto
    Return To: USB Loader GX
    Nand Saves Emulation: Full
    Nand Chan. Emulation: Full
    Channel Launcher: Main DOL

    Nand Emu Path: sd:/nands/01/emuNAND Channel/
    Nand Emu Channel Path: sd:/nands/01/emuNAND Channel/

    Any assistance is appreciated.
     
  2. alexander1970

    alexander1970 GBA Fan

    Member
    10
    Nov 8, 2018
    Austria
    Austria
    Hello.:)

    Maybe this explanation from @Cyan helps you:

    https://gbatemp.net/threads/usb-loader-gx.149922/page-1294#post-8602386

    Good Luck.:)
     
  3. CodeBlue
    OP

    CodeBlue Newbie

    Newcomer
    1
    Feb 15, 2019
    United States
    I'm afraid that doesn't really help. The attempt is appreciated, but it really just tells me things I already know.
     
    alexander1970 likes this.
  4. CodeBlue
    OP

    CodeBlue Newbie

    Newcomer
    1
    Feb 15, 2019
    United States
    Solved the problem but I need to make another post to show the solution. Hold on.

    — Posts automatically merged - Please don't double post! —

    Solved the problem. It was likely a problem with the necessary cIOS being read. For future reference, if anybody has the same problem and comes upon this thread, here's how you may solve it.

    1. Make sure you still have the latest version of the d2x cIOS installer homebrew app. Can find it here: https://sites.google.com/site/compl...d2x-cIOS-Installer-Wii.zip?attredirects=0&d=1
    *redacted*
    4. Test the game to see if the error has been resolved.

    I know they are wads, but they aren't installed to your home menu. They are simply cIOS patches. Credit goes to Tech James on YouTube for the Mega link, and to wii.guide for the d2x link. People tell me all the time that video guides aren't reliable but Tech James' helped out quite a bit.

    edit by Cyan:
    Sorry, you can't share wad files of IOS or cIOS, these contains copyrighted data.
    you need to use the cIOS installer.

    wad ARE installed to system, they are not patched.
    "simply cIOS patches" is from d2x cIOS installer only, not the wads.
    NEVER EVER USE YOUTUBE TO HACK ANYTHING
     
    Last edited by Cyan, Jul 30, 2019
  5. tswntk

    tswntk GBAtemp Advanced Fan

    Member
    6
    Aug 6, 2012
    Switzerland
    Cyan has posted how to properly install cios and d2x installer packs numerous times. If you have to download wads from unkown sources, that means you are not following Cyan's instructions properly in the first place.
     
  6. Cyan

    Cyan GBATemp's lurking knight

    Global Moderator
    22
    Oct 27, 2002
    France
    Engine room, learning
    and additionnaly, you are installing WRONG cIOS, because LASTEST is NOT BEST !

    please, install only either :
    d2x cIOS v8 base 57 in slot 249
    OR
    d2x cIOS v10 (r52) base 57 in slot 249

    DO NOT INSTALL V10-ALT (r53) which is NOT compatible with emuNAND.

    I also deleted your link to wad pack, which is illegal to share, and like he said, could be dangerous (unknown sources).
    Also, you should not put a directlink to installer, but instead to the tutorial page, so people can follow the guide to update their cIOS properly (now that the guide is finally updated and almost good, still not the best)


    If you said you followed my instruction, you'd have provided the IOS version/base, and not just the "slot number" (I don't care you use 249, what's important is what you installed inside slot249).

    Second problem :
    Where in any of my guide did I tell to create a new folder named "emuNAND Channel" inside "01" ????

    Why do you create a 3rd folder hierarchy ? Only root/folder/subfolder/
    in "nands" you place all your OTHER nand dumps. not inside 01, which is your "first NAND".

    sd:/nands/01/
    sd:/nands/02/
    sd:/nands/emuNAND Channel/
    sd:/nands/PAL NAND/
    sd:/nands/NTSCJ NAND/
    etc.

    see, inside "nands" you have .... your nands ! (I thought it would be super logical enough, apparently not)

    Then another thing : why do you use SPACE ?
    having Spaces in path is the main problem for 99% of programs and application worldwide ! (not just the Wii, but also Windows !). NEVER EVER PUT A SPACE IN A PATH USED BY A PROGRAM.


    Also, the length of the emuNAND path is important and shouldn't be too long. that's why I used "01" for first NAND, instead of "nands/My_first_ever_super_great_NAND_emulation_path/"

    please, follow my guide or correct your path to :
    Nand Emu Path: sd:/nands/01/
    Nand Emu Channel Path: sd:/nands/01/


    if "01" bother you, rename it to something saying it's your own dump, or your console region.
    nands/myNand/
    or
    nands/NTSCU/

    Third:
    unless you understand that option and WANT to use it, DISABLE the option "emuNAND Save" ! this has nothing to do with WAD !
    this option is used for DISC, not channels !
    this option redirect savegames stored on the console to your "emuNAND save" path defined in custom path menu. which can be different than your "emuNAND Channel" path, if you want.
    redirecting disc savegames doesn't need a NAND dump to work, you can enable "partial" on a clean new SD card, without making NAND dump, and it'll work fine by redirecting ONLY the savegames to SD card. everything else (mii, wiimote, network, etc.) will still be loaded from System NAND.
    if you enable that option (partial or full) without knowing what it does, you'll wonder why all your existing savegames are gone.

    it helped you so much that you got random and wrong illegal files, and did exactly what we fight against : people thinking they found a solution and write/video BAD guide for other users to follow while they don't understand what they did and that it can be dangerous and wrong.
    please, NEVER FOLLOW YOUTUBE TO HACK ANYTHING, and don't try to make a guide from them, you just spread the mistakes a little more.

    the pack of wad you shared is bad, outdated, and contains useless slots (11, 16, 20, 36, 200+) and doesn't even have 58 which would be the one users need to have for homebrew.
    really, that pack is bad.

    all you need is ONE SINGLE IOS : d2x cIOS v8 final base57 in slot 249. Done !
    oh, and, it's not included in the pack you shared. so much for reliable youtube video.

    Also, the video is for Wii only, sharing WADS is VERY dangerous because people put them on their SD card and use the files to install WAD in batch to their WiiU !
    You have to think about consequences. always specify for which plateform are the files or guide you share (when legal). that's also what I fight against with youtube video : they never tell, nor care, nor in fact know that what they explain can be dangerous to do for specific users and think everybody has the same setup and what they managed to achieve without understanding what they did deserves a guide.
     
    Last edited by Cyan, Jul 30, 2019
    RunningSnakes and alexander1970 like this.
  7. CodeBlue
    OP

    CodeBlue Newbie

    Newcomer
    1
    Feb 15, 2019
    United States
    My apologies for the mistake. I admit it was likely a mistake to post that link, and I apologize for it.

    You have to understand, I'm new to this. I literally started softmodding my Wii a month ago. I mean no harm or offense, the reason I posted this thread in the first place was because I was looking for answers. I never said I was going to be perfect. Since I started, I feel like I've learned a lot about it. But that doesn't change the fact that mistakes and misunderstanding were bound to be made. Again, I apologize if I've frustrated you.

    As for the custom firmware issue, I once again followed your instructions. But nothing changed. I fail to understand what I'm doing wrong here. And I'm not saying that to blame you, just to offer an explanation of my confusion. I already followed them once before when I first modded my Wii, and I've experiencing errors I've seen nobody else reporting. It is my general assumption that, in a situation like that, I am on my own.

    Let me be more specific with what I've done.

    First, after getting the appropriate set-up ready with Homebrew Launcher, PriiLoader, BootMii, and all that I booted the d2x xIOS installer. I saw no v8, so I installed cIOS <v10 beta52 d2x-v10-beta52> using base 57 onto slot 249. cIOS revision was set by default to 21010 and I saw no instructions to change it. So I left it as it was.

    Once I downloaded USB Loader GX, I extracted a few GCN iso's and attempted to run them with Nintendont. Things went well, though I had to use WiiFlow to do the extracting because the Disks wouldn't extract properly with GX for whatever reason. I assumed it a bug.

    After that, about two weeks later, I extract my sysNAND with no hiccups. But I've had problems with WADs loading ever since. So, I look for a solution. I search on GBATemp, going so far as to go numerous pages into the appropriate forums. No answers. So I search for solution on Google for nearly two hours, inputing as many varied queries as I can. Eventually, I find Tech James video. I use the WADs he provided me, no more problems. The reboot problems I was having here over, and I now find them to be running quite well, aside from the banners not rendering on GX's channel menu. But they play perfectly fine.

    Was any of that incorrect? Because despite those actions being completely correct by my assessment, I've experienced numerous problems I could find no solution to, and am being shouted down for attempting to remedy it. As I mentioned, I felt as though it was in my own hands to solve my own problem. I see individuals saying all the time that they can't be held responsible for my Wii should I decide to mod it with their software, and I took that to heart.
     
    Last edited by CodeBlue, Aug 1, 2019
  8. CodeBlue
    OP

    CodeBlue Newbie

    Newcomer
    1
    Feb 15, 2019
    United States
    A change of plans are in order, it would seem. I found more productive information I was seeking in a far shorter time from an individual I know personally. I was intended to wait for a response, but fortunately that is no longer necessary. That, and I've found numerous videos which would seem to essentially take guides I've previously used and copy-paste them to a visual format. I still personally prefer the written guides, but I'll resort to videos from here on out as a passing reference during uncommon situations like where the written material doesn't seem to cut it. My aforementioned acquaintance also said I was wasting precious time coming to gbatemp for answers. A bit harsh, in my opinion, however I cannot fault him for coming to such a conclusion when taking this thread's waiting times into account. The man likely had a poor experience, and he's never been one for patience.

    If gbatemp's forums allow for users to close their own threads as others do, I will do so. I see no use for this thread after all, and I have no desire to see my email taken up with notifications. If any potential further responders came to view this post, I thank you for the consideration and apologize for cutting it short.

    Have a good day.
     
    Last edited by CodeBlue, Aug 1, 2019
Loading...