"SD Card has been removed" error on sysnand 11.1.0-34E but not on 9.2

Discussion in '3DS - Flashcards & Custom Firmwares' started by escherbach, Oct 13, 2016.

  1. escherbach
    OP

    escherbach GBAtemp Regular

    Member
    269
    97
    Dec 26, 2013
    I have arm9loaderhax and Luma3ds CFW, and I have transferred all my cartridges to CIAs installed on the home menu on a 32gb SD card. I have no problems playing them in 9.2.0-20E firmware, but when I upgrade to the latest 11.1.0-34E I keep getting "SD Card has been removed" errors randomly during gameplay. Which makes the games unplayable.

    Have Nintendo introduced a routine to do extra tests on the SD Card? I have downgraded back to my 9.2 NAND backup (with decrypt9) and everything works fine. (btw I reformatted the SD card with SD card formatter https://www.sdcard.org/downloads/formatter_4/ , and there is no difference)
     
    Last edited by escherbach, Oct 13, 2016
  2. gnmmarechal

    gnmmarechal Kirigiri > Naoto

    Member
    GBAtemp Patron
    gnmmarechal is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    4,533
    2,714
    Jul 13, 2014
    Portugal
    https://gs2012.xyz
    That's weird. Try a different SD card, I suppose.
     
  3. Aletron9000

    Aletron9000 3DS Master

    Member
    1,583
    428
    May 10, 2016
    United States
    3DS ARM9 CPU
    there might be something wrong with either the sd card or the sd card reader. Hopefully it is the sd card, otherwise you will have to hardmod to fix it or send it to Nintendo.
     
  4. Ominous66521

    Ominous66521 GBAtemp Maniac

    Member
    1,086
    246
    Feb 7, 2016
    United States
    That's a big issue since that prevents you from playing newer games that get released this year.Have you tried running any games on 11.1.0 a9lh with cartridges instead of installed CIA's? Mabe it has something to do with the sd card which prevents you from running the games.
     
  5. escherbach
    OP

    escherbach GBAtemp Regular

    Member
    269
    97
    Dec 26, 2013
    I ordered a new SD card but it was a dud, probably shouldn't go for the cheapest on ebay! Not sure if it's the sd card though since have have never once seen the error on 9.2 sysnand, maybe I did something weird between installing teh games on 9.2 and then upgrading. It doesn't seem to be a common problem reported by others. I don't want to use emunand if I can help it, but that might be another solution.
     
  6. escherbach
    OP

    escherbach GBAtemp Regular

    Member
    269
    97
    Dec 26, 2013
    I don't need a hardmod, since I have arm9loaderhax and a 9.2 nand.bin backup. In fact i wonder if by experimenting switching back and forth between sysnands via decrypt9's backup/restore feature caused an issue. Maybe I should have just updated once over the internet to 11.1.0.34 and left it at that. I'll probably go back to an old 9.2 clean SD card backup I have, update over the internet and reinstall the CIAs again, and then not mess about with it too much. It's kinda ridiculous how many times I've restored my sysNand considering this was impossible without a hardmod a year or so ago.
     
  7. TheVinAnator

    TheVinAnator GBATemp's Greatest Vin

    Member
    3,551
    2,555
    Jan 10, 2016
    Canada
    NO COFFEI!
    THIS SAME THING HAPPENED TO ME! It would load the cache of my home menu and theme on boot, but then immediately go to a white theme and "no micro sd card detected" with only dsiware showing. I kept playing and playing around with the SD Card to no avail, but then I thought of using godmode9 to change my default arm9loaderhax.bin to the bin.bak, so I deleted the .bin and renamed the .bak to just .bin. Then everything went back to normal! I then proceeded to update back to the latest luma using the updater :P!
     
  8. Aletron9000

    Aletron9000 3DS Master

    Member
    1,583
    428
    May 10, 2016
    United States
    3DS ARM9 CPU
    What i meant by hardmod is to repair the sd card reader yourself. If it is the sd card reader
     
  9. escherbach
    OP

    escherbach GBAtemp Regular

    Member
    269
    97
    Dec 26, 2013
    What do you mean "it is the sd card reader" - it works fine in earlier firmware (9.2)
     
  10. Aletron9000

    Aletron9000 3DS Master

    Member
    1,583
    428
    May 10, 2016
    United States
    3DS ARM9 CPU
    I said "if it was the sd card reader". it could be part of the issue.

    i don't know why it double quoted