Gaming Save game request - Jak and Daxter : The Lost Frontier

Neo Draven

End Boss of the Entire Internet
OP
Member
Joined
May 3, 2010
Messages
1,102
Trophies
0
XP
2,068
Country
United States
I have a PSP 2000 running 6.39ME-2, I believe.

I have been trying for the past couple of years to actually play Jak and Daxter - The Lost Frontier. EVERY TIME, the game refuses to start the cutscene in the very first stage when you return to Keira with the green eco crystal. The cutscene just never begins, so I am stuck.

I've tried the ISO untouched, a patched ISO, an untouched CSO, a patched CSO, I have tried every driver combination possible, all processor speeds available, I have tried disabling all of my PRX's, I have tried on a brand-new PSP, and so far, not one thing I have attempted has worked.

Can anyone either show me how to progress past that point, or would one of you awesome people be magnificent enough to get past that part, and upload a save file for me?

I would love you for at LEAST three minutes if you could do this for me.

Prease to halp.

Thanks!
 

xist

ΚΑΤΑ ΤΟΝ ΔΑΙΜΟΝΑ ΕΑΥΤΟΥ
Member
Joined
Jul 14, 2008
Messages
5,859
Trophies
0
XP
973
Country
Have you tried an alternative firmware? I finished it fine on 5.00M33-6, and PRO generally seems a lot less bug ridden than the ME line.

Also there's a hex edit for in game AP where you eliminate all occurrences of a particular string, although i believe that was only an issue in the EU release.
 

DeltaBladeX

Well-Known Member
Member
Joined
Jul 20, 2009
Messages
334
Trophies
0
Age
37
XP
181
Country
New Zealand
I saw this topic on GameFAQs. :P

Before I thought you were just running a crappy download, but not being able to use multiple different copies is a problem.
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    KenniesNewName @ KenniesNewName: Underwraps 2 is out checks all the Disney woke boxes