Right analog stick problem. Please help

Discussion in 'PS Vita - Console, Accessories and Hardware' started by keven3477, Apr 12, 2017.

  1. keven3477
    OP

    keven3477 Fresh Prince of Lemonade

    Member
    4
    Jul 12, 2012
    United States
    Somewhere i can never find.
    Earlier this year i bought a ps vita 1000 from e-bay with henkaku and some games already installed. When it arrived everything seemed fine since it turned on correctly and was responding fine for my initial notice. However since it didn't come with a charger i couldn't really test it since i couldn't charge it after battery died. I decided to order a charger from e-bay but since im a total cheapskate i decided to order what i saw was cheap and wait a month for it to arrive from china.
    After waiting and finally charging my vita i decided to try out the games it came installed. Marvel vs capcom seemed to work fine for me so i didn't seem any problem with the system. Then I decided to play persona 4 and that is were i noticed a hint of a problem. Once i started playing inside a dungeon i noticed that every time i move with the left stick the camera moves a little depending on the direction while there was no response from the right. i searched online and i heard that the game came with some camera problems so i believed this was the game's problem and i wasn't going to play persona anyways until i finish the 3rd one that i am currently playing on my computer. After a while i decided to play the other game child of light and then its when i noticed it was a problem. The cursor seemed to move by itself upwards north and was not responding unless by touchscreen. I then realized that something is wrong and decided to install a button tester on the vita. I found via vitatester that my right stick was stuck aiming top right and that the only time it moves is when the left stick gets moved.
    I figured to myself it was the right analog stick so i decided to check and replace it. After 3 weeks of waiting for the right screwdriver, 1 month waiting for and getting refunded for an out of stock analog stick, and 3 more weeks waiting for the reorder from another website, I successfully installed it on the vita. And..... nothing. It still have the same problem after replacing the analog stick. So i figure it is a software problem then. I really don't know if there is a secret menu on the vita that could help me fix this but i don't want to update/format it and lose henkaku for a potential chance of it not to be fixed. I am asking for help on fixing my situation. Any help would be appreciated.
     
    Last edited by keven3477, Apr 12, 2017
  2. keven3477
    This message by keven3477 has been removed from public view by BORTZ, May 8, 2017, Reason: Do not bump threads.
    May 8, 2017
  3. Tom Bombadildo

    Tom Bombadildo Tom BombaDadlo

    pip Contributor
    20
    GBAtemp Patron
    Tom Bombadildo is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Jul 11, 2009
    United States
    I forgot
    Try formatting. Just backup all of your homebrew and ROMs and things with VitaShells USB mode, do a format, and see if the problem persists. This won't force you to update, Henkaku will still work just fine, and you won't lose anything.
     
    keven3477 likes this.
  4. NanashiFinal13

    NanashiFinal13 GBAtemp Regular

    Member
    2
    May 1, 2017
    Argentina
    You find a way to resolve your problem? Because this happen to me to and i don't know how to fix it, i can't play any game because of the camera, i try changing the analog and even try to play with out the analog (i remove it) but the camera issue persist. I guess that the problem is softwarw related, the operative system or something
     
  5. keven3477
    OP

    keven3477 Fresh Prince of Lemonade

    Member
    4
    Jul 12, 2012
    United States
    Somewhere i can never find.
    no, unfortunately I couldn't find an answer, when I checked online on google for people with the similar problem they never posted a solution either.
     
  6. Versa

    Versa Member

    Newcomer
    1
    Nov 29, 2014
    I have the same exact problem on my slim model. Even removed the right analog stick and it still moves.

    Have you tried formatting? I'm starting to think that it's a faulty board or something.
     
  7. tech3475

    tech3475 GBAtemp Advanced Fan

    Member
    5
    Jun 12, 2009
    When I had problems with my Vita's right stick, it was because the flat flex connector wasn't inserted properly (after I performed a motherboard swap).

    Before that on my PSP, the stick needed to be disassembled and cleaned.
     
  8. aItevideos

    aItevideos Newbie

    Newcomer
    1
    Nov 28, 2017
    Germany
    I have a very similar history and my vita has exactly the same problems. The ps vita I bought came with a third party usb cable, which I was using to install henkaku and charge the device. I can't imagine how, but maybe these things could damage the motherboard? I hope I don't have to buy another one, because otherwise it works just fine and looks as good as new.
     
    Last edited by aItevideos, Nov 28, 2017
  9. keven3477
    OP

    keven3477 Fresh Prince of Lemonade

    Member
    4
    Jul 12, 2012
    United States
    Somewhere i can never find.
    Was the vita stick working fine before you were working with henkaku or was it already not working well once received.
     
  10. aItevideos

    aItevideos Newbie

    Newcomer
    1
    Nov 28, 2017
    Germany
    Unfortunately, I'm not sure. I noticed it first after having installed RetroArch.
     
  11. B4rtj4h

    B4rtj4h Gaming addict #2 and some

    Member
    5
    Apr 16, 2007
    Netherlands
    Bikini Bottom
    Isn't there a remap option on Henkaku?
     
  12. saegolpur

    saegolpur Newbie

    Newcomer
    1
    Dec 18, 2017
    United States
    Same situation here. I bought my Vita on Ebay with Henkaku already installed and with some games on it (and no charger). When I went to play some games, the right analog stick wasn't working. The camera kept moving around and then it got stuck to one position. I opened up my Vita and disconnected the right analog stick and the only difference was that in Final Fantasy X, the menu list inside the sphere grid was locked up instead of down, but all the other games had the same problem. I'm not sure if I have to just reinstall everything or what. Anyone found a solution yet?
     
  1. This site uses cookies to help personalise content, tailor your experience and to keep you logged in if you register.
    By continuing to use this site, you are consenting to our use of cookies.
    Dismiss Notice