Official Retroarch WiiU (wip.)

Discussion in 'Wii U - Homebrew' started by aliaspider, Nov 6, 2016.

  1. Lucky Dearly

    Lucky Dearly GBAtemp Regular

    Member
    142
    13
    Jul 26, 2008
    United States
    Now I can't seem to apply the cheats from the .cht files I got. I enable the cheats I want but when I click on apply cheats nothing happens, no cheats are enabled.
     


  2. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    22,048
    10,356
    Apr 29, 2011
    United States
    Dr. Wahwee's castle
    I was testing 1.5.0 vanilla from the Libretro site (from the Stable section, not nightly build, for the record); I don't use the nightly builds past 1.5.0. What my set up is, is I use Haxchi plus CFW with HBL as a channel, what's odd is when I load 1.5.0 without CFW, it runs fine, just a bit slower. But when I load it with Haxchi with CFW to HBL, I load it for the first time and it runs great, no issues, I can config it fine. It's when I load 1.5.0 for the second time is when it goes crazy, for whatever reason. I'm not trying to bash anyone's contributions to the emulator, at all, I'm just trying to figure out WTF is going on and why no one else can replicate it. It's infuriating, it's baffling, and is about to drive me to tears from pure frustration. I've since rolled back to 2/5/17, a nightly build and has been incredibly stable with CFW. Why? I don't know. I'd be willing to reopen the trouble ticket, but I don't feel any reason or compulsion to do so, I already wasted Aliaspider's time with a trivial "bug" that wasn't a bug at all. *Sigh* Sorry for the wall of text, I'm venting and partially explaining what the error is. I haven't used the app store because, well, I haven't *shrug*. I can send a PM to explain if it helps, I'm just...about to just stop trying. I can explain what I do and how to replicate the ad nauseum, but no one else can replicate it, so what good would it do to explain it again if no one else has this issue? :(

    Summary: Using 1.5.0 stable from https://buildbot.libretro.com/stable/1.5.0/nintendo/wiiu/RetroArch_rpx.7z

    Scenario A - Haxchi + CFW + loading via HBL channel = 1.5.0 loads fine first time, crashes 2nd time
    Scenario B - Haxchi + CFW + loading via HBL channel = 2/5/17 loads fine every time

    I don't know how or why, and I don't have any hope that the issue can be found, i get the damn system memory issue every time I load 1.5.0 a second time. I didn't get help on GitHub and I sure as hell don't hope on getting help here :(

    I'll record a video showing on what I do, but it'll do no good.
     
    Last edited by the_randomizer, Mar 19, 2017
  3. brienj

    brienj Trying to avoid getting cancer

    Member
    1,232
    1,705
    Jan 3, 2016
    United States
    Have you ever tried loading the old Mocha CFW (v0.2) with an old version of Haxchi (v2.2u1) that doesn't contain a CFW? That's what I run, and stuff works fine on my end.
     
  4. Lucky Dearly

    Lucky Dearly GBAtemp Regular

    Member
    142
    13
    Jul 26, 2008
    United States
    anybody else having trouble enabling cheats in retroarch? I can't enable them when running fceu, mgba, and snes9x
     
  5. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    22,048
    10,356
    Apr 29, 2011
    United States
    Dr. Wahwee's castle
    No I haven't, I'd rather not downgrade if I don't need to, as versions prior to 1.5.0 worked fine, so I don't get how a pre-1.4.0 version works flawlessly, but 1.5.0 doesn't, it's weird. I suppose I can try another nightly build.
     
  6. brienj

    brienj Trying to avoid getting cancer

    Member
    1,232
    1,705
    Jan 3, 2016
    United States
    Personally, to me, that's an upgrade, not a downgrade, that's why I still use it.
     
  7. mackem

    mackem GBAtemp Regular

    Member
    111
    3
    Mar 19, 2006
    The only cheats I've seen working are NES games, there's a youtube video showing how to.

    You're better of just installing the homebrew channel on vWii using wuphax and then using the SNES & NES emulators for the Wii.

    Google:

    Ultimate FCE Ultra GX 3.2.9 v1 Cover Mod2D, 3D, 2D Cart, & 3D Cart Collection

    and

    Ultimate Snes9xGX 4.3.1 v1 Cover Mod 2D, 3D, 2D Cart, & 3D Cart Collection

    All the roms with covers, screenshots and cheats in one download.

    Ultimate GenPlusGX 1.6 Collection on the same site for MS & MD.
     
  8. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    22,048
    10,356
    Apr 29, 2011
    United States
    Dr. Wahwee's castle
    See, that still makes no sense, like, how could one version of RA work 100% stably and a more recent one suddenly freak out on me when nothing about the setup has been changed? I access HBL the same way I always loaded HBL, so nothing should have caused this to happen. If it works for me, I see no reason to downgrade, and if it ain't broke, don't fix it, right? I can try other nightly builds, but as far as features go, I don't have any games that need a keyboard, and if/when XMB, shaders get implemented As for now, I see no real immediate need, I just use the last working version.
    Sorry for being stubborn, I just can't pinpoint the cause, or even know where to begin trying to resolve the root cause. Ugh.
     
    Last edited by the_randomizer, Mar 20, 2017
  9. brienj

    brienj Trying to avoid getting cancer

    Member
    1,232
    1,705
    Jan 3, 2016
    United States
    "I see no reason to upgrade, as if it ain't broke, don't fix it, right?" Fixed it for you.

    This is why you should go back to older versions of Haxchi and use Mocha, but it will continue to not work properly if you stay "upgraded".
     
  10. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    22,048
    10,356
    Apr 29, 2011
    United States
    Dr. Wahwee's castle
    There's no reason for Haxchi CFW to break newer versions of Haxchi *sigh* forget it. I'm just...not feeling very well right now.... I'll be back later. This is clearly annoying you :( I like being able to hold down B and going to the HBL 2.1 channel,
    I just don't see why it would break newer versions, it shouldn't. Gonna hold off till XMB is implemented, if it ever does get implemented. I'll be back, need a long break, don't feel good right now -_-

    I was following Aliaspider'ss instructions to use Haxchi CFW with HBL channel, guess that wasn't helping me much either.
     
  11. Lucky Dearly

    Lucky Dearly GBAtemp Regular

    Member
    142
    13
    Jul 26, 2008
    United States
    I may have to do this. I hope someday retroarch can fix their cheat engine but for now I'll go with the vWii emulators
     
  12. brienj

    brienj Trying to avoid getting cancer

    Member
    1,232
    1,705
    Jan 3, 2016
    United States
    It uses a completely different type of IOSU hook than Mocha. I have to program apps differently that use IOSUhax, just so it's compatible with the newer Haxchi and CBHC. They ARE different, which means that one could break, and the other won't. But continue to be stubborn, that's your prerogative.
     
  13. Pepois

    Pepois GBAtemp Fan

    Member
    339
    80
    Aug 24, 2013
    Argentina
    Thats very interesting!
     
  14. xtheman

    xtheman GBAtemp Guru

    Member
    5,847
    5,275
    Jan 28, 2016
    United States
    So I'm guessing nothing new has been added to this port in a while right? :(
    I really was hoping for XMB and a DOSBOX compile.
     
  15. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    22,048
    10,356
    Apr 29, 2011
    United States
    Dr. Wahwee's castle
    Aside from keyboard support in 1.5.0, no, not for almost a month. I doubt we'll ever see XMB or shaders. :( Lack of interest in the Wii U port, even the 3DS port has XMB, which is weird.
     
  16. xtheman

    xtheman GBAtemp Guru

    Member
    5,847
    5,275
    Jan 28, 2016
    United States
    Aren't the 1.5.0 builds broken? It doesn't seem worth updating just for keyboard support if everything breaks again
     
  17. brienj

    brienj Trying to avoid getting cancer

    Member
    1,232
    1,705
    Jan 3, 2016
    United States
    I've said it before and I'll say it again, there are cores on the appstore that HAVE keyboard support and WORK!!! I put them on there.
     
  18. the_randomizer

    the_randomizer The Temp's official fox whisperer

    Member
    22,048
    10,356
    Apr 29, 2011
    United States
    Dr. Wahwee's castle
    Curious, what makes the builds on the appstore more stable than the stable builds on the Libretro download server? I mean, stable 1.5.0 on the Libretro FTP shouldn't be that different from the appstore version no? Huh.

    If you use Mocha CFW, no, they work fine, if you use Haxchi+CFW and HBL, they freak out for some reason, can't confirm why.
     
    Last edited by the_randomizer, Mar 20, 2017
  19. pedro702

    pedro702 GBAtemp Guru

    Member
    6,580
    2,109
    Mar 3, 2014
    Portugal
    i wish someone ported sdl for the wiiu port so we could just have dosbox, not a single kind soul that can program can do dosbox?
     
    Last edited by pedro702, Mar 21, 2017
    the_randomizer likes this.
  20. eldavo2090

    eldavo2090 GBAtemp Regular

    Member
    103
    30
    Jan 21, 2014
    Mexico
    Dinosaur Land, Donut Plains
    Quick question
    What kind of controllers are compatible with retroarch...