[Release] Half-Life (Xash3DS)

Discussion in '3DS - Homebrew Development and Emulators' started by MasterFeizz, Feb 25, 2019.

  1. The_Provider

    The_Provider Advanced Member

    Newcomer
    3
    Nov 29, 2016
    United States
    There's a typo on your releases page, it says "2. Download the extras.wad" instead of "extras.pak"
     
  2. mikewii7

    mikewii7 Advanced Member

    Newcomer
    3
    Jun 1, 2017
    Russia
    no sound for me, is it suposed to be lilke that?
     
  3. Sinornithosaurus

    Sinornithosaurus Newbie

    Newcomer
    1
    Feb 8, 2019
    Australia
    *spits out coffee*
    Wowo, good job Masterfeizz!
     
  4. MrHuu

    MrHuu GBAtemp Fan

    Member
    4
    Sep 19, 2015
    Netherlands
    Sound should be enabled. Do you have your DSP dump available?
     
  5. Kallus

    Kallus Advanced Member

    Newcomer
    3
    Jun 5, 2017
    United States
    Can anybody share some screenshots and/or gameplay of this? Just curious what it looks like on 3DS, I would try it out myself but I don't have one anymore.
     
  6. mikewii7

    mikewii7 Advanced Member

    Newcomer
    3
    Jun 1, 2017
    Russia
    what dsp dump? i just did all instruction said:
    copied valve folder from installed game( i have steam version), put extras, deleted config.cfg, installed .cia
     
    Last edited by mikewii7, Feb 26, 2019
  7. fusermarucs

    fusermarucs Member

    Newcomer
    2
    Nov 5, 2009
    Make sure you have extras.pak in the valve folder, not the xash3d folder (I did that first and got a black screen)
     
  8. mikewii7

    mikewii7 Advanced Member

    Newcomer
    3
    Jun 1, 2017
    Russia
    yeah i put everything where it belongs, game working, just no sound, and loading save not working
     
  9. fusermarucs

    fusermarucs Member

    Newcomer
    2
    Nov 5, 2009
    Weird . Are u using the CIA or 3dsx to launch it?(not sure if it would make a difference but I use the CIA)
     
  10. mikewii7

    mikewii7 Advanced Member

    Newcomer
    3
    Jun 1, 2017
    Russia
    i use cia
     
  11. MasterFeizz
    OP

    MasterFeizz GBAtemp Advanced Fan

    Member
    9
    Oct 15, 2015
    United States
    You probably never dumped your dsp firmware, use DSP1 to do that.
     
  12. mikewii7

    mikewii7 Advanced Member

    Newcomer
    3
    Jun 1, 2017
    Russia
    yep, first time hearing about this as well, this must be in instructions
    did dump and now game have sound :D
     
  13. Leqz

    Leqz Newbie

    Newcomer
    1
    Apr 2, 2018
    Malaysia
    Loading times is way too long for my liking but I guess that is to be expected from the first release. I thought the game crashed at first and I reboot but I decided to wait a little longer the second time and it loaded. Once it get to the gameplay, the FPS is pretty good. It does stuttered a few times but maybe give a few more builds and I think all of my issues will be solved. Also during the resonance cascade when you're transported to Xen homeworld with the bullsquid, the skybox is totally white and the scene after that I couldn't even see those three alien.
     
    Last edited by Leqz, Feb 26, 2019
    MasterFeizz likes this.
  14. MrHuu

    MrHuu GBAtemp Fan

    Member
    4
    Sep 19, 2015
    Netherlands
    If you followed a decent tutorial to install your CFW, you should have dumped it already, or at least have DSP1 available. A lot of homebrew needs it nowadays.

    Maybe MasterFeizz could build in a warning message, if the dump is missing?
    This will probably avoid this issue being reported over and over again..
    ..or just add a reminder to the install instructions.
     
  15. mikewii7

    mikewii7 Advanced Member

    Newcomer
    3
    Jun 1, 2017
    Russia
    i CFW'ed my 3ds in 2016, i dont remeber DSP being in tutorial
     
  16. The_Provider

    The_Provider Advanced Member

    Newcomer
    3
    Nov 29, 2016
    United States
    Am brainless and didn't look at thread for which the problem was resolved already.
     
    Last edited by The_Provider, Feb 26, 2019
  17. MrHuu

    MrHuu GBAtemp Fan

    Member
    4
    Sep 19, 2015
    Netherlands
    Glad you got it working, and this was the only issue you were facing.
    Also, the guide to update a9lh to b9s does include it. I don't know when it was added, but it's a good thing its there now.
     
  18. fusermarucs

    fusermarucs Member

    Newcomer
    2
    Nov 5, 2009
    B6BB485A-8009-4D56-A1E0-7400B3152BD8. I’ve played for 20 minutes or so and there’s a weird fish-eye thing going on. The perspective seems a bit off. I’ve tried to take pics. When you talk to a scientist head on it looks normal, but when you then look down he appears to stretch!

    Also a couple of the wall decals disappear every now and then.

    Outstanding that it is running at all frankly so kudos!
     

    Attached Files:

  19. Skirlez

    Skirlez GBAtemp Regular

    Member
    4
    Dec 8, 2018
    Israel
    Just tested this with an Old 2DS. It has lag but that is to be expected. It's still playable!
     
  20. RareWare

    RareWare Member

    Newcomer
    3
    Feb 20, 2016
    United States
    I'll try to get some of this with my capture card so there's some video of it. Thank you MasterFeizz!
     
Quick Reply
Draft saved Draft deleted
Loading...