[Release] FBI - Open source CIA installer

Discussion in '3DS - Homebrew Development and Emulators' started by Steveice10, Apr 11, 2015.

  1. Zappo23

    Zappo23 Member

    Newcomer
    1
    Jan 6, 2016
    United States
    Only time that ever happened to me is if I accidentally clicked a button or touched the bottom screen while it was booting up.
     
  2. kjaved373

    kjaved373 Advanced Member

    Newcomer
    3
    Nov 3, 2008
    United States
    That doesn't seem to be the problem. I did install some .cia files before formatting and the weird thing is I get some white square icon showing on the main menu when booting up for two seconds and then disappears. I'm wondering if there's something still on the system that wasn't erased when formatting that may be causing the problem?

    EDIT: Fixed it by "downgrading" for 9.2 using sysupdater. Apparently had to install a few update files.
     
    Last edited by kjaved373, Jan 7, 2016
    Zappo23 likes this.
  3. Alpuy

    Alpuy GBAtemp Regular

    Member
    2
    Aug 12, 2015
    Uruguay
    When are you going to release a more stable version of fbi for 10.3? Any eta?
     
  4. Steveice10
    OP

    Steveice10 GBAtemp Maniac

    Member
    9
    Jul 19, 2009
    United States
    No ETA. I'll be adding 10.3 support once the exploit is actually stable.
     
    klear, sweis12 and Wolfy like this.
  5. dtwpurple

    dtwpurple Advanced Member

    Newcomer
    1
    Aug 20, 2015
    United States
    Vegas
    Are you going to use @173210 's commit?
     
  6. Quantumcat

    Quantumcat Dead and alive

    Moderator
    21
    GBAtemp Patron
    Quantumcat is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Nov 23, 2014
    Australia
    Canberra, Australia
    Who is involved in making it more stable?
     
  7. Steveice10
    OP

    Steveice10 GBAtemp Maniac

    Member
    9
    Jul 19, 2009
    United States
    I'm working on it in my libkhax fork.
     
    klear and Quantumcat like this.
  8. dtwpurple

    dtwpurple Advanced Member

    Newcomer
    1
    Aug 20, 2015
    United States
    Vegas
    173210 says he's gettting 100% success rate on his fork.....
     
  9. Steveice10
    OP

    Steveice10 GBAtemp Maniac

    Member
    9
    Jul 19, 2009
    United States
    Has he tried exiting to homebrew launcher? Running it again after doing so? Exiting again?
     
  10. Quantumcat

    Quantumcat Dead and alive

    Moderator
    21
    GBAtemp Patron
    Quantumcat is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Nov 23, 2014
    Australia
    Canberra, Australia
    If you make it so it works 20% or more of the time I'll send you a donation if you have a link up :-) I bet others will too!
     
  11. dtwpurple

    dtwpurple Advanced Member

    Newcomer
    1
    Aug 20, 2015
    United States
    Vegas
    Honestly i'm probably wrong, I just follow him on twitter and saw that he said he was getting 100% success rate. That was hours ago.
     
  12. Alpuy

    Alpuy GBAtemp Regular

    Member
    2
    Aug 12, 2015
    Uruguay
    What is his Twitter?
     
  13. dtwpurple

    dtwpurple Advanced Member

    Newcomer
    1
    Aug 20, 2015
    United States
    Vegas
    @ 173210 He has to allow you to follow him. He also posts mostly in japanese..
     
  14. Zappo23

    Zappo23 Member

    Newcomer
    1
    Jan 6, 2016
    United States
    @Steveice10 I've decided to format everything and start from scratch because the dang FBI won't install the fbi.cia BEFORE unlinking the EmuNAND and SysNAND. What is going on here?

    EDIT: Here's the error I'm getting.

    "Install failed!
    Source: SOURCE_APP_WRITE_CIA (0x6)
    Module: MODULE_NN_AM (0x22)
    Level: LEVEL_PERMANENT (0x1b)
    Summary: SUMMARY_INVALID_ARGUMENT (0x7)
    Description: DESCRIPTION_INVALID_SIGNATURE (0x6a)"

    This is using the FBI-1.4.15 on N3DS 9.2, knowing full well that you updated the FAQ.
     
    Last edited by Zappo23, Jan 7, 2016
  15. Nkrlz

    Nkrlz Member

    Newcomer
    1
    Jan 7, 2016
    Monaco
    Hello, i can't seem to be able to use the program, i had a 9.6 E N3DS, which i downgraded to a 9.2 with the new sysUpdate method, and apparently the process was succesful (NK, on the box to the right to show it's my console).

    [​IMG]

    Yet each time i try to install the fbi cia, with fbi through the hbc i keep getting the error
    "Description: DESCRIPTION_INVALID_COMMAND" (0x2f), which, according to the FAQ only happens if you have a system that's over 9.2. At this point i'm just really curious, my guess is that the downgrade is directly related to this error, or that somehow i'm doing something wrong (even though i chekced 100x times).
     
  16. dtwpurple

    dtwpurple Advanced Member

    Newcomer
    1
    Aug 20, 2015
    United States
    Vegas
    Are you using the right FBI? 1.14.17?
     
  17. Nkrlz

    Nkrlz Member

    Newcomer
    1
    Jan 7, 2016
    Monaco
    Yep, the latest aviable on github.
     
    dtwpurple likes this.
  18. MakkipMaster

    MakkipMaster Newbie

    Newcomer
    1
    Dec 27, 2015
    United States
    --
     
    Last edited by MakkipMaster, Apr 13, 2017
  19. Superbossboo

    Superbossboo The Regular

    Member
    5
    Aug 19, 2015
    United States
    Los Angeles
    For anyone having problems, try using Pasta without firm launch, It should work
     
  20. Senilix

    Senilix Member

    Newcomer
    2
    Jan 7, 2016
    Gambia, The
    HELP!!!!
    i Have RX-E 9.2.0-20E on New 3DS

    in fbi go to fbi.cia and press A?!

    then comes
    Install failed! FBI.cia Source: SOURCEAPP_BEGIN_INSTALL (0x5) Module: MODULE_NN_OS (0x6) Level: LEVEL_PERMANENT (0x1b) Summary: SUMMARY_WRONG_ARGUMENT (0x8) Description: <unknown> <0x2f>

    on pic is bigblue
    Pic: http://www.bilder-upload.eu/show.php?file=72a2ac-1452166286.jpg

    PS: FBI Mode is SD, is this correct?

    Sorry for bad english
     
    Last edited by Senilix, Jan 7, 2016
Quick Reply
Draft saved Draft deleted
Loading...