[RCM Payload] Hekate - CTCaer mod

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by CTCaer, May 1, 2018.

  1. jennice

    jennice Member

    Newcomer
    1
    Nov 1, 2018
    United Kingdom
    hi @CTCaer .
    I dont usually ask for help but this is my last resort!
    i bought i switch yesterday. its on version 6.1.0. i checked the serial number and everything checks out. i watched a tutorial on sd files and tegraRcm etc.
    everything was going smoothly. i was able to get the switch into RCM mode and load the bootloader hakate.
    now i try to launch the cfw and i and the message: error failed to init sd card. please make sure sd card is inserted properly.
    What am i going wrong? the sd card shows up on the official switch firmware.
    i am using a 32gb kingston sd card.
    any advise is appreciated

    :)
     
  2. Maupiti

    Maupiti GBAtemp Regular

    Member
    2
    Sep 16, 2018
    France
    Which CFW are you trying to launch...?
     
  3. hippy dave

    hippy dave BBMB

    Member
    12
    Apr 30, 2012
    United Kingdom
    Good job on the memory training whatnot.
     
  4. myfz
    This message by myfz has been removed from public view by Joe88, Nov 4, 2018.
    Nov 4, 2018
  5. Arkturos

    Arkturos Member

    Newcomer
    1
    Nov 5, 2018
    Canada
    Sooo i'm new here I just have a couple of question ... sooo got one problem with nand. Im on 6.0.1 and got a 128gig microsdcard on exfat. Soo the first time I boot hekate I load Atmosphere and went into the homebrew but after I was thinking damn I will do a nand before doing something stupid I hope this wont install Atmosphere in my switch since I need to go in rcm everytime with hekate ? . Sooo I reboot Hekate doing a nand and I got 56g free of space but I got the fatal error 1. Ive been searching everywhere but cant find anything sooo if someone can help me with this it will be appreciate ! Thanks
     
    Last edited by Arkturos, Nov 5, 2018
  6. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    16
    Aug 6, 2017
    United States
    New York City
     
  7. Tinybitt23

    Tinybitt23 Newbie

    Newcomer
    1
    Nov 7, 2018
    United States
    Hi everyone!

    Decided to jailbreak my switch today. I got into the RCM mode and once i hit "Launch" i got the "(FatFS error 13) Make sure that a FAT partition exists" error. I've tried to reformat and it still doesn't work even when using Fat32 or Exfat. Am I doing something wrong?

    I use a Sandisk 2gb micro SD card.

    Thanks in advance!
     
  8. lisko

    lisko Member

    Newcomer
    1
    Oct 28, 2018
    Italy
    The sx payload has the same function enabled by default, so if you are doing this chain loading only for auto power off it's not needed
     
    Maupiti likes this.
  9. Silent_Gunner

    Silent_Gunner GBAtemp Regular

    Member
    2
    Feb 16, 2017
    United States
    What is up with the new splash screen when you send the payload to the Switch sometimes? All I get afterwards is a black screen. I know it isn't sending the payload since it powers on in OFW when I push the power button!
     
  10. XaneTenshi

    XaneTenshi GBAtemp Regular

    Member
    3
    Nov 24, 2013
    Denmark
    Which version of Hekate are you running? And I just want to be sure, you are not using AutoRCM right?
     
  11. Silent_Gunner

    Silent_Gunner GBAtemp Regular

    Member
    2
    Feb 16, 2017
    United States
    Nope, turned that off after having a huge scare that thankfully turned out to be making much ado about nothing. I'm running Hekate 4.2.
     
  12. XaneTenshi

    XaneTenshi GBAtemp Regular

    Member
    3
    Nov 24, 2013
    Denmark
    If you are not using autoRCM, then this might not be your issue, but try going into Tool/options and if "HOS' auto full power of" is activated, deactivate and check again.
     
  13. CTCaer
    OP

    CTCaer GBAtemp Maniac

    Member
    10
    Mar 22, 2008
    Greece
    This normally happens when your MBR (master boot record + partition table) has inconsistency. In the past that error was fixed with 100% success ration, by initializing MBR and creating the partition from scratch. It's better for this to happen in windows.
     
  14. Maupiti

    Maupiti GBAtemp Regular

    Member
    2
    Sep 16, 2018
    France
    Shutting down from HOs ? you don’t need to go back to main SXOs menu anymore ?
     
  15. jenda201

    jenda201 Newbie

    Newcomer
    1
    Nov 8, 2018
    Czech Republic
    Hello guys im having some issues...first of all let me say that im a total newbie in this...ok so i got my hands on a 2nd hand nintendo switch with sx os on it...i downloaded Zelda but it wouldnt launch the game unless updated..but when i tried to update the game it said i need to update firmware..but that wouldnt let me because i have some ban or whatver..so i decided to update manualy using this guide

    everything went smoothly until the point when a wanted to launch my new firmware...but it said : unknown package1 failed to launch firmware....

    also i didnt backup my NAND

    so then i turned it off, injected hekate again and now when I press launch it gives me : No main configuration found...so now Im totally stuck and IDK what to do...
    PLZ HELP ME :(
     
    Last edited by jenda201, Nov 8, 2018
  16. Tinybitt23

    Tinybitt23 Newbie

    Newcomer
    1
    Nov 7, 2018
    United States
    i checked MBR with Minitool Partition Wizard, and it still shows the same error. I did everything at this point.
    I'm thinking of just buying a new SD card
     
  17. ZachyCatGames

    ZachyCatGames GBAtemp Fan

    Member
    3
    Jun 19, 2018
    United States
    What version of hekate are you using? Usually the package1 error means that the bootloader your using isn’t compatible with your firmware
     
  18. CTCaer
    OP

    CTCaer GBAtemp Maniac

    Member
    10
    Mar 22, 2008
    Greece
    No main configuration found means that hekate couldn't find any boot entry in hekate_ipl.ini.

    You should not check. You should init the sd card.
    Delete MBR. And create it again.
    https://www.disk-partition.com/diskpart/initialize-disk-4125.html
     
  19. Krude

    Krude GBAtemp Regular

    Member
    3
    May 18, 2013
    Gambia, The
    Documentation on Atmosphere is extremely sparse, apparently, so i'll ask here since hekate is my go-to bootloader.

    How do i go about using Hekate + Atmosphere? Do i start it via secondary payload, or do i chainload the primary or what? Do i need the BCT.ini if i load via Hekate? Can i use any of the Hekate patches together with Atmo?

    Would a proper boot entry look like this?

    [Atmosphere]
    payload=fusee-primary.bin
     
  20. yummycake

    yummycake GBAtemp Regular

    Member
    3
    Jan 22, 2017
    United States
    Edit:I searched through older postings for the answer.
    Yayyy
     
    Last edited by yummycake, Nov 10, 2018
    CTCaer likes this.
  21. Bushido1992

    Bushido1992 Advanced Member

    Newcomer
    2
    Apr 4, 2018
    Germany
    Any idea why custom bootlogo Not work with my setup?

    A use the Atmosphere "bootlogo.bmp" and put it on the root of my sd card...

    In /bootloader/hekate.ipl ini i add/change under Config:

    customlogo=1
    logopath=/bootlogo.bmp

    ... But on every start/Restart the hekate boot Logo pops up?
     
Loading...