R4i3D firmware? How do I get this thing to work...?

Discussion in 'Other Flashing Hardware & Software' started by kumpandjill, Dec 23, 2011.

  1. kumpandjill
    OP

    Member kumpandjill GBAtemp Regular

    Joined:
    Dec 23, 2011
    Messages:
    121
    Country:
    United States
    Alright, so I gave a couple R4i3Ds as gifts a couple months ago... tested them out on my DSi and everything. Everything worked perfectly. However, when I try to get it to work now... nothing. They're the same cartridges (the new ones, labeled "new"). I just can't get it to work at all and I don't have the folder with the firmware that I copied to the ones I used from before. So does anyone know? I can't find this cart on the RetroGameFan list either.

    Sorry if this is a stupid question but I feel like I'm missing something pretty simple. I've literally been trying for the entire day to get this thing to work. I want to get it before Christmas so I can give them out :(

    Thanks to anyone that can help out!
     


  2. Buleste

    Member Buleste Old Fart

    Joined:
    Dec 19, 2010
    Messages:
    852
    Country:
    United Kingdom
    What is the webaddress on the front of the cart (there are many, many, many r4i 3DS carts out there)?
     
  3. kumpandjill
    OP

    Member kumpandjill GBAtemp Regular

    Joined:
    Dec 23, 2011
    Messages:
    121
    Country:
    United States
    It's r4i3d.com

    I downloaded the kernel from there, but I think some stuff is missing... the only files that are in there are a folder called "_rpg" and a file called "_DS_MENU.dat". However, on the side of the page, it says to copy "files data dsxreader moonshl2 ndsmail plugins skin system r4i3ds ttmenu to your TF card."

    So idunno :(
     
  4. Buleste

    Member Buleste Old Fart

    Joined:
    Dec 19, 2010
    Messages:
    852
    Country:
    United Kingdom
    It sounds as though that cart once used a TTMenu based kernel and has since moved to a Wood based kernel. I'm trying www.r4i3d.cc to see if I can get the kernel from there to download as it's older and may contain the files you need but it's not letting me connect. If I can get hold of a copy of that then you could run a bootloader update and hopefully install the newer kernel but until I can get hold of the old kernel I can't help at the moment.
     
  5. kumpandjill
    OP

    Member kumpandjill GBAtemp Regular

    Joined:
    Dec 23, 2011
    Messages:
    121
    Country:
    United States
    Ah, yeah. That looks like what I had before (from what I can tell from the download page). It's not letting me connect either, though. Once I get it, what should I do?

    Or do you think that the download link is permanently down?
     
  6. Buleste

    Member Buleste Old Fart

    Joined:
    Dec 19, 2010
    Messages:
    852
    Country:
    United Kingdom
    I've just reread your posts and missed this bit.
    That is the instructions for the old cart and they haven't updated the webpage.

    Have you tried the new kernels in the cart yet and do they work?

    If they don't work what error message do you get?
     
  7. kumpandjill
    OP

    Member kumpandjill GBAtemp Regular

    Joined:
    Dec 23, 2011
    Messages:
    121
    Country:
    United States
    If I try the kernel that's on r4i3d.com right now, I just get "? Menu" right when I try to load up the cart (before I get to any menu or anything).
     
  8. Buleste

    Member Buleste Old Fart

    Joined:
    Dec 19, 2010
    Messages:
    852
    Country:
    United Kingdom
    That's usually a sign that the kernel is installed incorrectly or the wrong kernel on the cart. Try formatting the SD card with Panasonic SD card formatter first and then try reinstalling the kernel.
     
  9. kumpandjill
    OP

    Member kumpandjill GBAtemp Regular

    Joined:
    Dec 23, 2011
    Messages:
    121
    Country:
    United States
    It just says "Loading..." and goes to a blank white screen and gets stuck. Ugh :/
     
  10. Buleste

    Member Buleste Old Fart

    Joined:
    Dec 19, 2010
    Messages:
    852
    Country:
    United Kingdom
    Which of the kernels have you tried (we're making progress getting to loading)? Try the older one first (v1.38.2) and then try 1.41 if you get the older one to work.
     
  11. jimmyemunoz

    Member jimmyemunoz GBAtemp Advanced Maniac

    Joined:
    Feb 23, 2009
    Messages:
    1,958
    Location:
    Louisiana
    Country:
    United States
    This is from RetroGameFan's list of working carts list: "R4i3D - www.r4i3D.com (Use R4-SDHC_R4i-SDHC folder)" Take another look at Retro's working cart list and try his firmware.
     
  12. Buleste

    Member Buleste Old Fart

    Joined:
    Dec 19, 2010
    Messages:
    852
    Country:
    United Kingdom
    Unfortunately that's for the old version and will not work on this newer version of the cart (the old cart was TTMenu based and the new cart is Wood based). And whilst RGF's kernel is better than the old carts menu system (as it's up to date) it will not work on this version of the cart.
     
  13. jimmyemunoz

    Member jimmyemunoz GBAtemp Advanced Maniac

    Joined:
    Feb 23, 2009
    Messages:
    1,958
    Location:
    Louisiana
    Country:
    United States
    Buleste, what planet are you from?
     
  14. Buleste

    Member Buleste Old Fart

    Joined:
    Dec 19, 2010
    Messages:
    852
    Country:
    United Kingdom
    The website is as the OP stated is www.r4i3d.com however that website only deals with the recent carts that that company have produced which are Wood based. If you want to look at the older version of the cart which is TTMenu based you need to look at the old site which is being is at www.r4i3d.cc.

    EDIT
    Also if you look on the actual website there are listings for 2 products

    The r4i3d (New) (which is the cart the OP has) which Wood/AKAIO based
    The R4i3d which is TTMenu based and is the one that RGF MCU will work on.
     
  15. jimmyemunoz

    Member jimmyemunoz GBAtemp Advanced Maniac

    Joined:
    Feb 23, 2009
    Messages:
    1,958
    Location:
    Louisiana
    Country:
    United States
    Original poster, tell me, do you think Buleste is a flash card pimp?
     
  16. Buleste

    Member Buleste Old Fart

    Joined:
    Dec 19, 2010
    Messages:
    852
    Country:
    United Kingdom
    @kumpandjill

    After looking at the website for the instructions on the r4i3ds (new) it appears you should have a file called WoodR4.NDS in with your kernel but I know it's missing from the original downloads. I know it is simply a copy of the _DS_MENU.dat renamed to WOODR4.nds so I have uploaded the kernel with file to here so give that a try.
     
  17. jimmyemunoz

    Member jimmyemunoz GBAtemp Advanced Maniac

    Joined:
    Feb 23, 2009
    Messages:
    1,958
    Location:
    Louisiana
    Country:
    United States
    ^^ Thinks he's a flash card pimp. :lol:
     
  18. kumpandjill
    OP

    Member kumpandjill GBAtemp Regular

    Joined:
    Dec 23, 2011
    Messages:
    121
    Country:
    United States
    that was when I was using the newer one (1.41). I just tried the older one (1.38.2) and it worked and loaded the games :)

    But I'd like to get the cartridge to work with the latest DS firmware version. So what would the next step be?
     
  19. kumpandjill
    OP

    Member kumpandjill GBAtemp Regular

    Joined:
    Dec 23, 2011
    Messages:
    121
    Country:
    United States
    Wow... I didn't even see the R4i3D in the list of compatible carts. I don't think it's in the .txt file that comes with the download. Well anyway, I'll try that in a little bit. But I will still need to update the cart in order for it to work on the latest DSi firmware, right?

    To do that should I just get the cart working with retrogamefan's stuff and then copy the update.nds and run that? Then I should be good to go no matter what firmware the DS is running?
     
  20. kumpandjill
    OP

    Member kumpandjill GBAtemp Regular

    Joined:
    Dec 23, 2011
    Messages:
    121
    Country:
    United States
    I can get the games to work, I just want to make sure it will still work when I update the DSi...

    so what should I do? Do i need to update the cart first or can I go ahead and update the dsi?

    Also, are all the versions backwards-compatible? Like if it works on 1.4.3 will it surely work on 1.41 and stuff?
     

Share This Page