R4i v1.4 doesn't work on upgraded DSi v1.4.1

Discussion in 'R4 DS' started by adog, Oct 14, 2010.

  1. adog
    OP

    adog Newbie

    Newcomer
    3
    0
    Oct 14, 2010
    Netherlands
    Hey guys,

    I recently upgraded my DSi to v1.4.1 and now my R4i v 1.4 doesn't work anymore (the website for this card is www.r4igold.cn). I've tried downloading various R4 upgrades and tried upgrading it on a friends DS lite but got the message saying "card check failed. Re-insert and try again". When the card was inserted again, I got the same message. I'm really lost now as to what the next step I need to take is. What should I do?

    Thanks in advance!
     
  2. Bluelaserman

    Bluelaserman I shoot BLUE LASERS MAN!!!!

    Member
    677
    1
    Sep 13, 2009
    The Land down under.
  3. adog
    OP

    adog Newbie

    Newcomer
    3
    0
    Oct 14, 2010
    Netherlands
    Just tried it now, doesn't seem to work. I basically just extracted all that was in the zip file to the micro-SD card and then put it back in the R4. Am I doing something wrong or do I need to try it on the DS lite?
     
  4. Bluelaserman

    Bluelaserman I shoot BLUE LASERS MAN!!!!

    Member
    677
    1
    Sep 13, 2009
    The Land down under.
    I'm not exactly sure since I don't own or use a DSi. Though, I think you need to update through a DSLite.
     
  5. twiztidsinz

    twiztidsinz Taiju Yamada Fan

    Member
    4,981
    6
    Dec 23, 2008
    United States
    Your clone R4 is probably not updateable.
     
  6. however

    however Banned

    Banned
    13
    0
    Oct 14, 2010
    United States
    Are you sure you r4i can upgrade to 1.41?The only support latest 1.4.1 version software: iSmart ds , EZ-Flash Vi , DS TWO, M3i Zero , Acekard 2i , R4i Gold , R4i SDHC , R4i Dsi LL , R4iTT , I player , R4i-GOLD , R4Li , EX4.
    source:http://ndsi-game.blogspot.com/
     
  7. adog
    OP

    adog Newbie

    Newcomer
    3
    0
    Oct 14, 2010
    Netherlands
    Ok, thanks guys. So basically I need to buy a new one? Which would you suggest?
     
  8. samjef11

    samjef11 GBAtemp Fan

    Member
    450
    0
    Mar 28, 2009
    Forget the R4i or any r4s at all acekard2i or supercard dstwo or m3i zero are your best bet for furture dsi firmware update they can be flashed updated.
    Get them here http://shoptemp.com/?gbatemp
     
  9. Rydian

    Rydian Resident Furvertâ„¢

    Member
    27,883
    8,105
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
    You have two choices for carts that have proper support/updates.
    [*]Acekard 2i
    • Price: $15 from shoptemp.com
    • Advantages: Can use AKAIO, giving it compatibility with modern games. Can update itself and cheats over wifi, supports the DSi/XL, and supports memory cards up to 32GB.
    • Disadvantages: Can't do any of the special stuff the DSTwo can.
    • Rank: Mid-range card for people that want to play lots of games on a DSi/XL with some extra features.
    [*]Supercard DSTwo
    • Price: $35 from shoptemp.com
    • Advantages: Supports the DSi/XL, can update itself even if the DSi won't run it, supports memory cards up to 32GB, real-time save (save states), in-game guide (show text and images from walkthroughs without having to reset the game), "free cheat" which lets you modify memory while the game is running, GBA and SNES emulator, slow motion, and more.
    • Disadvantages: The most expensive card.
    • Rank: Pretty much the ultimate card right now.
     
  10. samjef11

    samjef11 GBAtemp Fan

    Member
    450
    0
    Mar 28, 2009
    Beat you to it.