R4i-sdhc

Discussion in 'Online Stores and Purchases' started by lukands, Oct 15, 2010.

  1. lukands
    OP

    lukands I took the little bus here

    Member
    522
    32
    Mar 27, 2009
    Your mamas house
    The picture shows the on the little yellow sticker as 1.4 but the ad says 1.4.1? The cards website shows they have come out with a 1.4.1 card (5th generation) but I have not found any retailers selling them.
     
  2. trumpet-205

    trumpet-205 Embrace the darkness within

    Member
    4,363
    542
    Jan 14, 2009
    United States
  3. RupeeClock

    RupeeClock Colors 3D Snivy!

    Member
    6,389
    861
    May 15, 2008
    The R4i SDHC Red is clearly labelled 1.4.1 on the product page, if you have any doubt.

    But lukands, I wouldn't suggest getting one of those, instead I suggest getting an Acekard 2i.
    It will cost an extra $7 ($2 used for flashing the Acekard to be 1.4.1 compatible), but with AKAIO 1.8.0 firmware, the flashcart will be absolutely amazing, far better than what the R4i SDHC Red could do.
     
  4. samjef11

    samjef11 GBAtemp Fan

    Member
    450
    0
    Mar 28, 2009
    R4i SDHC Red 1.4.1 is not updatebale is the dsi has a new firmware update the r4i sdhc team will make a new card meaning you have to pay out more to get a new R4i SDHC card again.
     
  5. lukands
    OP

    lukands I took the little bus here

    Member
    522
    32
    Mar 27, 2009
    Your mamas house
    You must be looking at a different picture then I am, the one I see shows 1.4 on the card and the box??
    I just wanted to confirm if it was just a mistake in the picture.
     
  6. trumpet-205

    trumpet-205 Embrace the darkness within

    Member
    4,363
    542
    Jan 14, 2009
    United States
    RupeeClock means that the TITLE is labeled as 1.4.1.

    Like I said, ShopTemp IS selling 1.4.1 version. They are just being lazy of not updating the picture.

    http://shoptemp.com/news/53/R4i-SDHC-Red-i...compatible.html
     
  7. Costello

    Costello Headmaster

    Administrator
    12,446
    5,800
    Oct 24, 2002
    it is definitely 1.4.1 compatible and they will be updating the pics yeah.
    though you're better off buying anoher cart like the supercard dstwo...