R4 Pocket 3DS firmware...HELP!

Discussion in 'R4 DS' started by DannyAwesome1104, Dec 9, 2012.

Dec 9, 2012
  1. DannyAwesome1104
    OP

    Newcomer DannyAwesome1104 Member

    Joined:
    Nov 6, 2012
    Messages:
    33
    Country:
    Mexico
    If any one is looking at this thread, PLEASE HELP ME!
    I have an R4 3DS POCKET w/the firmware from www.r4issdhc.com. I also have the RGF (RetroGameFan Update) 6.94 w/the DAT_s_v6038. I had a DSi w/the version 1.4.3, & it was working perfectly, but as soon as I updated it to the v1.4.4; it stopped working. How can I update my firmware, or which firmware should I use? I know this is a clone, but I still want to play on it like before.
    Please answer!
    Thanks!
     
  2. Rydian

    Member Rydian Resident Furvert™

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    http://gbatemp.net/topic/315784-flash-carts-and-dsi3ds-updates/
    RGF and such aren't firmware, the firmware is inside the cart, and firmwares for carts are not interchangeable.

    You WILL need to go to the site printed on your cart and get the DSi 1.4.4 firmware update file from there and run it. Let me run over that in order.

    1 - You will need to get the update from your cart's site. If there is no update on the site, then there is no update, and your cart can't be updated and will not work on your DSi ever again.
    2 - You will need to run the update as if it was a game. This means you need to be able to start the cart up, which means that you need to do this on some type of DS that still runs the cart, since yours won't (until it's been updated).

    No there is not another way to do it, before you ask. You shouldn't have updated.
     
  3. DannyAwesome1104
    OP

    Newcomer DannyAwesome1104 Member

    Joined:
    Nov 6, 2012
    Messages:
    33
    Country:
    Mexico
    Oops, sorry. I'll say kernels instead of firmwares from now on.
    When I look at the site, it says exactly this: "Support 3DS v4.301, NDSi v1.44, 1.45c". I kinda took the risk of updating, & IT WAS MOT WORTH IT!!! (you're right; shouldn't have updated it :(). It's supposed to work since it says v1.44 (& 1.45c), shouldn't it? I ran the update file on my bro's DSi (thankfully he hasn't updated it), but it didn't work on mine after that! Am I doing it wrong, or it was just a lie about the v1.44?
    If this doesn't work, I have heard that the kernel from www.r4ids.cn works on this flashcart. Do you know if this true? If it does work, that might solve my problems...
    Thanks 4 answering back, & hopefully you'll answer back again!!!
     
  4. Rydian

    Member Rydian Resident Furvert™

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    Kernels don't determine compatibility with the DSi and 3DS, it's the firmware that does.

    Make sure you're running the update for the right cart. Come sites have multiple cart versions that use different update files.
     
  5. DannyAwesome1104
    OP

    Newcomer DannyAwesome1104 Member

    Joined:
    Nov 6, 2012
    Messages:
    33
    Country:
    Mexico
    I actually kinda know that already (in fact I haven't really used this on my 3DS). I can still run this on my DS Lite, right?
     
  6. Rydian

    Member Rydian Resident Furvert™

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    The DS Lite doesn't do the type of flash cart blocking that the DSi and 3DS do, so as long as the cart works at all (i.e. the firmware is functional) it should work on the DS Lite.
     
  7. DannyAwesome1104
    OP

    Newcomer DannyAwesome1104 Member

    Joined:
    Nov 6, 2012
    Messages:
    33
    Country:
    Mexico
    OK. Just one more question... (sorry...)
    Do you know for sure that the kernel from www.r4ids.cn works on the R4 3DS POCKET?
     
  8. Rydian

    Member Rydian Resident Furvert™

    Joined:
    Feb 4, 2010
    Messages:
    27,883
    Location:
    Cave Entrance, Watching Cyan Write Letters
    Country:
    United States
    The "kernel" there is Wood, which is only supported on the r4ids.cn, the Acekard R.P.G., The M3 Simply, and the original R4.

    If it works on any others, I don't know. If you're looking for game compatibility, this is a good bet.
    http://gbatemp.net/t267243-retrogamefan-updates-releases
     
  9. DannyAwesome1104
    OP

    Newcomer DannyAwesome1104 Member

    Joined:
    Nov 6, 2012
    Messages:
    33
    Country:
    Mexico
    Thanks. I'll hope this will work since it someone says this might work.
    Thanks 4 your help.
    God bless ya ;)
     

Share This Page