[Question] Should I update to 10.5

Discussion in '3DS - Homebrew Development and Emulators' started by JoelRL11, Feb 13, 2016.

?

should i update to 10.5?

  1. yah

    7 vote(s)
    41.2%
  2. nah

    10 vote(s)
    58.8%
  1. JoelRL11
    OP

    JoelRL11 Member

    Newcomer
    38
    6
    Sep 16, 2015
    United States
    If I update to 10.5 will I be able to acces my homebrew exploits. Im currently in 10.4 and have menuhax, ironhax and oothax. What should I do? Thanks in advance!
     
  2. mashers

    mashers Stubborn ape

    Member
    3,837
    5,155
    Jun 10, 2015
    Kongo Jungle
    Homebrew? Yes, if you're careful about ensuring you have a 10.5-capable entrypoint setup before updating to 10.5. For example, use menuhax to boot HBL, install the 10.5 payload for ironhax, and then update.

    Everything else including kernel access and CFW is currently off-limits in 10.5, so I would suggest not updating but downgrading instead and then installing 10.5 in emunand.
     
  3. Lacius

    Lacius GBAtemp Guru

    Member
    6,104
    2,436
    May 11, 2008
    United States
    I recommend using a hardmod to downgrade to 10.3. After that, you can downgrade to 9.2 and use emuNAND.
    If you don't plan on downgrading to 9.2, then I see no reason not to update to 10.5. Menuhax and the others work on 10.5.
     
  4. Luglige

    Luglige hiatus

    Member
    1,411
    1,545
    Jan 24, 2016
    Antarctica
    under your bed
    I have a question if I format my 3ds will it go to the newest version?
     
  5. Lacius

    Lacius GBAtemp Guru

    Member
    6,104
    2,436
    May 11, 2008
    United States
    No, it will not update your 3DS when you format it. It will, however, request to connect to the internet. This is normal. Formatting the 3DS will not change the system version.
     
  6. Luglige

    Luglige hiatus

    Member
    1,411
    1,545
    Jan 24, 2016
    Antarctica
    under your bed
    Ok so if I'm on 9.2 it will stay on 9.2?
     
  7. Lacius

    Lacius GBAtemp Guru

    Member
    6,104
    2,436
    May 11, 2008
    United States
    This is correct.
     
  8. MsMidnight

    MsMidnight part time fe modder

    Member
    1,753
    1,308
    Oct 12, 2015
    kys
    Ironfall won't launch without updating due to the new whitelist thing in the homemenu
     
    Games&Stuff likes this.
  9. JoelRL11
    OP

    JoelRL11 Member

    Newcomer
    38
    6
    Sep 16, 2015
    United States
    Thanks! Im not really interested in downgrading anytime soon, so Ill probably update. Can I find the new payloads in the starter kit in the homebrew loader website?

    — Posts automatically merged - Please don't double post! —

    Oh, so that would mean ironhax would be out of the question then? :/
     
  10. joesteve1914

    joesteve1914 GBAtemp Fan

    Member
    336
    134
    Jul 31, 2012
    United States
    10.4 has a bug that corrupts your SD, so I would update to 10.5 asap. Both 10.4 and 10.5 have the same hacking capabilites anyways.
     
  11. mashers

    mashers Stubborn ape

    Member
    3,837
    5,155
    Jun 10, 2015
    Kongo Jungle
    Good point. Thanks for clarifying :)
     
    MsMidnight likes this.
  12. JoelRL11
    OP

    JoelRL11 Member

    Newcomer
    38
    6
    Sep 16, 2015
    United States
    Really?? Well I guess I guess I can update then! Thanks to everyone!
     
  13. Giodude

    Giodude Ruler of Italy

    Member
    GBAtemp Patron
    Giodude is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    3,935
    1,169
    May 17, 2015
    United States
    New York
    Bye bye 9.2 n3ds master race...