1. Altanzik

    OP Altanzik Member
    Newcomer

    Joined:
    Nov 22, 2017
    Messages:
    10
    Country:
    United States
    Hey guys! Sorry very new to the ps4 scene and trying my hardest to get this darn PSVR working, had it working just fine earlier, but after I updated the firmware to 4.10 on the headset, it now forces me to update. Found another fix on another forum to "spoof" the PSVR to thinking it's on a higher firmware, But now I'm getting the (CE=40170-2) error every time I try to turn the thing on. But I do get picture through the lenses, so that's a start. Anyway you guys can help me figure out how to get past this error screen so I can enjoy some VR goodness again?

    Thanks In advance!

    -Altan
     
  2. jammybudga777

    jammybudga777 GBAtemp Addict
    Member

    Joined:
    Aug 23, 2013
    Messages:
    2,236
    Country:
    Last edited by jammybudga777, Oct 7, 2018
  3. KiiWii

    KiiWii Reporter
    Reviewer

    Joined:
    Nov 17, 2008
    Messages:
    12,561
    Country:
    United Kingdom
    Last edited by KiiWii, Oct 7, 2018
    Altanzik likes this.
  4. Altanzik

    OP Altanzik Member
    Newcomer

    Joined:
    Nov 22, 2017
    Messages:
    10
    Country:
    United States
    So whenever I do try to turn it on before running the payload, I again get prompted with the "update ps4 to use vr" update nag, Running the vr payload literally just gives me the error instead of the update nag, and allows me to actually see the error through the lenses, but after that It kicks me back whenever I press accept or cancel
     
  5. Altanzik

    OP Altanzik Member
    Newcomer

    Joined:
    Nov 22, 2017
    Messages:
    10
    Country:
    United States
    Just tried that payload (ps4 hen vtx? said welcome to ps4hen 1.8) And that one just gave me the "update to use ps4" nag :( I feel like it's totally on me if it works for everyone else

    — Posts automatically merged - Please don't double post! —

    NEVERMIND I'M DUMB!!! I kept sending the freaking "mira hen" from my server AND NOT the new updated 1.7 with vr firmware. My bad! Please don't hurt me too much gbatemp mods.
     
    KiiWii and jammybudga777 like this.
  6. KiiWii

    KiiWii Reporter
    Reviewer

    Joined:
    Nov 17, 2008
    Messages:
    12,561
    Country:
    United Kingdom
  7. Ceuse

    Ceuse GBAtemp Regular
    Member

    Joined:
    Jul 23, 2017
    Messages:
    134
    Country:
    Germany
    Short question in general : what benefits does it have to update the psvr headset anyway? Mine is on 3.1 i think and wondering why i should bother with updating at all
     
  8. Touftaf

    Touftaf Newbie
    Newcomer

    Joined:
    Oct 10, 2018
    Messages:
    1
    Country:
    France
    To be able to use it on a 6.00 PS4 and profit of the last VR content. If you only own a jailbreaked PS4 then you don't care about the 4.10 PSVR update and should stay on 3.10
     
    Leeful likes this.
  9. astrojs

    astrojs Member
    Newcomer

    Joined:
    Jun 22, 2018
    Messages:
    11
    Country:
    Poland
    Just wanted to tell you guys you're awesome. I thought I'd have to buy new PSVR. Now I'm back in the game :)
     
    KiiWii likes this.
  10. vivekanand

    vivekanand Member
    Newcomer

    Joined:
    Nov 4, 2020
    Messages:
    35
    Country:
    India
    help me out everyone..
    i have just got myself a psvr, unfortunately the guy i bought from had updated his system to 8.0. as a result the firmware for the psvr is also in accordance 8.0. so whenever i try to start my vr it gives me a message to update the system which i dont want to. i have tried the leeful v10 and spoofing the system to 9.00. after exiting the browser and starting my psvr it gives me a message to update my psvr firmware saying it has found the latest firmware as 4.10. but as i go through the steps it gives me an error also showing that the firmware for psvr already installed is 255.255. how should i get about that and have my psvr working. please help.

    my ps4 is on 6.72 and i used to run al azifs exploit page to run mira and ToDex before getting the psvr.
     
    Last edited by vivekanand, Nov 8, 2020
    Leeful likes this.
  11. Leeful

    Leeful GBAtemp Member
    Developer

    Joined:
    Sep 4, 2015
    Messages:
    1,579
    Country:
    United Kingdom
    255.255, Never heard of that.
    If the PSVR was updated on a v8.00 PS4 it should be v5.00 not v4.10. I hope you have not been sold a faulty PSVR.
    What firmware version does the PS4 say the PSVR is on in system settings > devices?

    If you run my v10 menu with Hen2.1.3 and then turn on your PSVR it should work.
    Btw you cant use ToDEX or Hen2.1.3b with PSVR.
     
    Last edited by Leeful, Nov 8, 2020
    vivekanand likes this.
  12. vivekanand

    vivekanand Member
    Newcomer

    Joined:
    Nov 4, 2020
    Messages:
    35
    Country:
    India
    yeah. you are right. the actual version on the psvr is 5.0 as instucted to check in you previous post. i do run the v10 menu with HEN2.1.3 and then run the spoof payload to spoof it to 9.00. after this i put my ps4 to rest mode and i restart it again where in the system information it shows now as fw version 9.00. after checking this i run my psvr and once it starts there is a prompt on the ps4 screen to update my psvr version. further to this prompt it also says that a new version 4.10 is found and later on when i go on with the update it gives an error and shuts off my psvr. i am sure that there is something that i am missing but i dont know what. please guide me.
     
    Leeful likes this.
  13. Leeful

    Leeful GBAtemp Member
    Developer

    Joined:
    Sep 4, 2015
    Messages:
    1,579
    Country:
    United Kingdom
    You dont need to run the spoofer payload. Just run Hen 2.1.3. (that spoofs to v9.00 on its own).
    You also dont need to enter and resume from rest mode. The spoof in HEN works straight away. You can see the spoofed version at the bottom of the menu.
    Even thought it does not show it in system settings yet, it still spoofed.

    Regarding your PSVR, try to update it via system settings > devices Without exploiting the PS4 first and see if the update error still happens.
     
    Last edited by Leeful, Nov 8, 2020
    vivekanand likes this.
  14. godreborn

    godreborn GBAtemp Legend
    Member

    Joined:
    Oct 10, 2009
    Messages:
    18,766
    Country:
    United States
    I'm trying to help someone with psvr, but one question, if you're going to update it, does that mean being on later firmware first?
     
  15. vivekanand

    vivekanand Member
    Newcomer

    Joined:
    Nov 4, 2020
    Messages:
    35
    Country:
    India
    ok. so this is what i have done as per your instructions. i reset my internet connection to flash the dns settings. my ps4 is now on fw 6.72. i went into settings=>devices=>psvr=>psvr device software=>update psvr device software and pressed X. i got a message " the latest playstation vr device software is installed. version 5.00"
    i later ran the v10 and loaded the exploit+HEN2.1.3 and did not load any of the payloads. yes... at the bottom it does says "the ps4 firmware currently spoofed to v9.00"
    now i exited the page using the ps button`
    turned on my psvr. now getting a prompt on my screen saying "you must update the psvr device software" gone ahead with the update and it installed version 5.00 and psvr is now working.
    but when i switched it off and again turned it on it didnt turn on giving me an error CE-40170-2

    also earlier i used the al azif exploit resetting my dns to load the mira exploit to run the games. later i started getting error where no game would load and the system used to log me off. after some googling i found the solution being to launch the ToDex exploit after mira. which runs my games fine. how can i use mira and todex on v10? as i dont want to swap between exploit pages.
     
    Last edited by vivekanand, Nov 8, 2020
  16. Penata81

    Penata81 Newbie
    Newcomer

    Joined:
    Nov 16, 2020
    Messages:
    1
    Country:
    Bulgaria
    Just use leeful v6 i have the same problem but solved it with v6
     
  17. KiiWii

    KiiWii Reporter
    Reviewer

    Joined:
    Nov 17, 2008
    Messages:
    12,561
    Country:
    United Kingdom
    If in 6.72 use leefuls V10, run hen 2.1.3+exploit, then as soon as the notification pops turn on the headset.

    ..don’t use the 2.1.3b..

    Confirmed working by Leeful and I recently used this myself.
     
  18. weatMod

    weatMod GBAtemp Psycho!
    Member

    Joined:
    Aug 24, 2013
    Messages:
    3,163
    Country:
    United States
    if the PSVR FW has not been updated is there way to block it from updating or from DL-ing the update in the 1st place to avoid the nag?
    if we are on 5.05 and have an old virgin PSVR on low FW is it best to just not update it and is it even possible to block the update ,update DL ,will DNS solve all this?
     
    Last edited by weatMod, Nov 16, 2020
  19. godreborn

    godreborn GBAtemp Legend
    Member

    Joined:
    Oct 10, 2009
    Messages:
    18,766
    Country:
    United States
    afaik, @Leeful has a payload that spoofs it to 9.00, but it may only be 6.72 (not sure). you'd probably have to spoof the psvr to avoid the update nag.
     
  20. Leeful

    Leeful GBAtemp Member
    Developer

    Joined:
    Sep 4, 2015
    Messages:
    1,579
    Country:
    United Kingdom
    I've never had the PSVR ask me to update the PSVR firmware.
    On 5.05 my PSVR was on 3.10 and it never asked me to update it even though a later PSVR firmware version was available.

    — Posts automatically merged - Please don't double post! —

    The firmware spoofer is only needed if your PS4 in on an incompatable FW version for your PSVR.

    If your PSVR FW is 3.10 your PS4 FW needs to be 5.00 or higher:
    so no spoof is needed on 5.05 or 6.72.

    If your PSVR FW is 4.10 your PS4 FW needs to be 6.00 or higher:
    so you need to spoof your FW on 5.05 to 6.00 or higher but you do not need to spoof if you are on 6.72.

    If your PSVR FW is 5.00 your PS4 FW needs to be 8.00 or higher:
    so you need to spoof your FW on 5.05 and on 6.72 to 8.00 or higher.
     
    Last edited by Leeful, Nov 16, 2020
Draft saved Draft deleted