Problem with the charge and dock!

Discussion in 'Switch - Console, Accessories & Hardware' started by rosendohl13, Oct 16, 2019.

  1. rosendohl13
    OP

    rosendohl13 Newbie

    Newcomer
    1
    Oct 16, 2019
    United States
    Hello guys, I recently fixed a Nintendo Switch that had a lot of bad components, including the charging port, the M92T36 and the PI3USB. After that it charges fine but only from one side of the cable, not both. I checked all the pins of the charging port and they all seemed fine to me. I even replaced the charge port again but still doing the same. My question is, what component should be causing the board to do that? I'd really appreciate any help! Thanks:)
     
  2. SolidSnakeUk89

    SolidSnakeUk89 Advanced Member

    Newcomer
    2
    Jul 20, 2019
    United Kingdom
    Around the world
    the only component I can think of would be the pads of the charging port.

    I would check on both sides, if 5v does gets through the main VBUS and I believe CC1 and CC2 pings are the ones that detect the plug so I would check if those pads have continuity into the board and together.

    upload_2019-10-16_19-47-27.
     
    rosendohl13 and FXDX like this.
  3. rosendohl13
    OP

    rosendohl13 Newbie

    Newcomer
    1
    Oct 16, 2019
    United States
    Hello man, thanks for replying back. That's very interesting, based on that pinout I can try to jumper CC1 with CC2 and see what happens. I'll let you know!
     
Quick Reply
Draft saved Draft deleted
Loading...