Problem with Retroarch gpsp...

Discussion in '3DS - Homebrew Development and Emulators' started by Piorjade, Sep 4, 2016.

  1. Piorjade
    OP

    Piorjade Member

    Newcomer
    17
    5
    Nov 8, 2015
    Gambia, The
    So I got the emulator working on my n3ds xl (with EPX filter enabled) and ran Harvest Moon and Golden Sun... on both games the screen had a weird "cut" on the left side of the screen which looked incredibly weird when walking in-game as the picture was moving

    I saw some youtube videos where none of them had this cut and I don't really know how to fix this...

    I would appreciate help cuz I don't really want to inject every game because I'm lazy and I like my savestates :)

    (going to add pictures l8er)
     
  2. Piorjade
    OP

    Piorjade Member

    Newcomer
    17
    5
    Nov 8, 2015
    Gambia, The
    Ok so it looks like with the filter enabled, the system crashes often.

    If I use the standard config, it doesn't crash and doesn't have the cut BUT instead has weird flickering lines on top of the screen when the picture updates

    image.jpeg
    image.jpeg
     
  3. Giodude

    Giodude Ruler of Italy

    Member
    GBAtemp Patron
    Giodude is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    3,594
    1,003
    May 17, 2015
    United States
    New York
    What version of gpsp?
     
  4. Piorjade
    OP

    Piorjade Member

    Newcomer
    17
    5
    Nov 8, 2015
    Gambia, The
    RetroArch 1.3.6 - gpSP v0.91
     
  5. SLiV3R

    SLiV3R 3DS Friend Code: 0473-9069-2206

    Member
    2,162
    1,026
    Jan 9, 2006
    Use 1.3.3. Latest stable release
     
  6. Piorjade
    OP

    Piorjade Member

    Newcomer
    17
    5
    Nov 8, 2015
    Gambia, The
    OMG thank you :D

    (oh and using the 2xSaI filter fixes the graphical glitches at the top and doesn't have the cut anymore :) )

    EDIT: the whole system froze after I opened the toolbox, going to test a bit more..

    EDIT 2: 15 minutes passed, using the Scale2x filter and no freezes/crashes until now.. Looks good I think

    Well thank you SLiV3R for helping me out :)
     
    Last edited by Piorjade, Sep 4, 2016
    SLiV3R likes this.