Problem with R4i

Discussion in 'NDS - Flashcarts and Accessories' started by Lunitari, Aug 11, 2016.

  1. Lunitari
    OP

    Lunitari Member

    Newcomer
    14
    0
    Sep 14, 2009
    Spain
    Hi! I bought a R4i Gold 3DS (r4ids.cn). This one exactly: http://www.digibay.es/nintendo-3ds-flashcard-/79-r4i-gold-3ds-flashcard-para-nintendo-3ds.html
    It arrived today and I'm trying it on my 3DS (11.0.0-33)
    I downloaded "WOOD R4 V1.64" from r4ids.cn and placed it on my microSD, and some DS games.
    Problem: It's like it gets corrupted each time I run it, and I have to format my microSD. And when a game wants to write data or save on the "cartridge" it shows an error, "Unable to write data". But I can start a game in "Pokemon Mystery Dungeon" because it doesn't write data at the beginning. Also most games stuck on "Loading" screen.

    This is how my microSD looks:
    root: http://i.imgur.com/bTmRh7O.jpg
    _rpg folder: http://i.imgur.com/XoqWiko.jpg

    Now, this is how the "program" looks the first time I go into it in my 3ds: http://i.imgur.com/tvJb85C.jpg
    It looks fine. But if I run any game, it can't write data, or won't load at all.
    Now I turn it off, and go into it again: http://i.imgur.com/bYsUxKm.jpg
    It's already corrupted, Interface doesn't show properly.
    Some games load but won't start because they can't write data:
    http://i.imgur.com/j7UFe1f.jpg
    http://i.imgur.com/RotI51i.jpg

    And this is how the _rpg folder looks: http://i.imgur.com/UtTQOpq.jpg
    See the "ui" folder? now its called "ui `" and I can't open it: http://i.imgur.com/s2gbt3E.jpg "Access denied"
    Sometimes every folder and file gets corrupted, file names and extensions changes to weird ones, and sometimes I can't even go into my SD and I have to format it directly.

    I tried 2 different microSD, so that's not the problem. And they work well for other purposes (one of them I used it to boot Windows, and the other one it's on my phone)

    Am I doing something wrong, or is my flashcard broken?? Hope anyone can help :\
    Thanks!
     
  2. Technicmaster0

    Technicmaster0 GBAtemp Psycho!

    Member
    3,143
    648
    Oct 22, 2011
    Gambia, The
    Sounds like a broken flashcard.