1. ploggy

    ploggy WAKA! WAKA!
    Member

    Joined:
    Aug 29, 2007
    Messages:
    3,694
    Country:
    United Kingdom
    Just tried Pacman World 3. It does get in game but there are no character or level graphics, just a greenish screen.. but you can see the pills :P it sounds abit slow too.

    — Posts automatically merged - Please don't double post! —

    Yep it plays really well :) only played for 5 mins though (WiiU could explode after 10 mins for all I know) XD
     
    uyjulian, DarthDub, Sinon and 2 others like this.
  2. the_randomizer

    the_randomizer The Temp's official fox whisperer
    Member

    Joined:
    Apr 29, 2011
    Messages:
    30,196
    Country:
    United States
    Wait what, are you serious?? :blink:
     
  3. wolf-snake

    wolf-snake GBAtemp Maniac
    Member

    Joined:
    Feb 5, 2009
    Messages:
    1,300
    Country:
    Mexico
    Played it more than 5 minutes, to the boss of the second stage where i encountered an infinite loading loop, still what i played was quite nice.
     
    ploggy likes this.
  4. ploggy

    ploggy WAKA! WAKA!
    Member

    Joined:
    Aug 29, 2007
    Messages:
    3,694
    Country:
    United Kingdom
    Well shit. I guess I jinxed it for us. :P
     
  5. wolf-snake

    wolf-snake GBAtemp Maniac
    Member

    Joined:
    Feb 5, 2009
    Messages:
    1,300
    Country:
    Mexico
    TBH it felt like a random loading loop, might had something to do because i saved Maria before reaching the boss.
     
    ploggy likes this.
  6. ploggy

    ploggy WAKA! WAKA!
    Member

    Joined:
    Aug 29, 2007
    Messages:
    3,694
    Country:
    United Kingdom
    I hope so. It's one of the games I'm planning on playing through when I get time :)
     
    ShadowOne333 likes this.
  7. Osakasan

    OP Osakasan GBAtemp Maniac
    Member

    Joined:
    Sep 19, 2015
    Messages:
    1,045
    Country:
    New version? w00t

    I'm still in bed, but will update the OP as soon as i get my breakfast

    Yesterday i had a random loading loop in Drácula X Chronicles too, right before the 2nd boss after rescuing Maria. Maybe there's a pattern here, who knows.

    EDIT: Reaching 2x resolution is a bliss for TV play. Need to test if any other game can reach it too without issues. Thank @aliaspider for your hard work ^^
     
    Last edited by Osakasan, May 31, 2018
    DarthDub likes this.
  8. Osakasan

    OP Osakasan GBAtemp Maniac
    Member

    Joined:
    Sep 19, 2015
    Messages:
    1,045
    Country:
    Ok, added the following to the OP:

    • Link to the new version
    • Link to the former version made easier to see
    • Gave a version number to each build. Taging @aliaspider to ask if he's ok with the v0.X numeration
    • Added a new parameter to the report form: Emulator version
    • Added (Almost?) all tests made since last time i visited the thread
    I'll add my own new tests later.
     
    uyjulian, DarthDub and the_randomizer like this.
  9. Maxbeta

    Maxbeta GBAtemp Fan
    Member

    Joined:
    Jul 20, 2014
    Messages:
    328
    Country:
    United States
    Some notable updates....

    - USB support with very few issues on v.0.2!!
    - I had 5 isos in a folder at once and happy to report the emulator browser menu did not lock up!!
    - I tested about 6 games on v0.2 back to back with NO CRASHES!!


    UPDATING THIS POST AS I AM Testing more games!!

    Firmware: 5.5.1
    SD type and Class: USB HDD
    Launcher version: Haxchi w/HBL 1.4
    Emulator version: v0.2
    Game: Dante's Inferno
    Non default settings: Frameskip set to 1 with Auto frameskip
    Issues observed: Messed up fonts and a lot of flickering graphics. Game runs at 16/40 50% FPS during cinematics and 8/41 35% during gameplay. VERY SLUGGISH AND CRASHES RANDOMLY DURING PLAY.

    Firmware: 5.5.1
    SD type and Class: USB HDD
    Launcher version: Haxchi w/HBL 1.4
    Emulator version: v0.2
    Game: Resistance Retribution
    Non default settings: Frameskip set to 1 with Auto frameskip
    Issues observed: Slow main menu with messed up flashing graphics. Starts game with story at 30/30 fps but crashes real quick.

    Firmware: 5.5.1
    SD type and Class: USB HDD
    Launcher version: Haxchi w/HBL 1.4
    Emulator version: v0.2
    Game: The 3rd Birthday
    Non default settings: Frameskip set to 1 with Auto frameskip
    Issues observed: Intro cinematics run smooth with minimal screen line tearing. Game is VERY MUCH PLAYABLE!!!

    Firmware: 5.5.1
    SD type and Class: USB HDD
    Launcher version: Haxchi w/HBL 1.4
    Emulator version: v0.2
    Game: CODED ARMS
    Non default settings: Frameskip set to 1 with Auto frameskip
    Issues observed: Runs like a dream during demo.
    Skip the story after selecting "NEW GAME" by hitting start multiple times or game will crash. MESSED UP TEXTURES/NOT PLAYABLE AT ALL AT 1/20 FPS

    Firmware: 5.5.1
    SD type and Class: USB HDD
    Launcher version: Haxchi w/HBL 1.4
    Emulator version: v0.2
    Game: God of War: Chains of Olympus
    Non default settings: Frameskip set to 1
    Issues observed: Slow main menu with messed up graphics and no audio/Starts game with story at 60/60 fps but crashes midway through.

    Firmware: 5.5.1
    SD type and Class: USB HDD
    Launcher version: Haxchi w/HBL 1.4
    Emulator version: v0.2
    Game: OBSCURE: The Aftermath
    Non default settings: Frameskip set to 1
    Issues observed: Very playable with almost steady 22/30 fps. minimal audio stuttering.
     
    Last edited by Maxbeta, May 31, 2018
    Osakasan likes this.
  10. aliaspider

    aliaspider GBAtemp Fan
    Member

    Joined:
    Apr 14, 2015
    Messages:
    344
    Country:
    Tunisia
    there is a big git version in front of your when you open the program, yet for some reason you decide to add your own versioning ?
     
    A Plus Ric likes this.
  11. Osakasan

    OP Osakasan GBAtemp Maniac
    Member

    Joined:
    Sep 19, 2015
    Messages:
    1,045
    Country:
    Yes, i know. v0.X applies only to the port version. Still, if you want me to change it, then it's my pleasure, just give me a few minutes.

    EDIT: Added the git version as the real version number. Sorry.
     
    Last edited by Osakasan, May 31, 2018
  12. AmandaRose

    AmandaRose Do what I do. Hold tight and pretend it’s a plan
    Member

    Joined:
    Aug 19, 2015
    Messages:
    8,015
    Country:
    United Kingdom
    I think we are missing two very important parameters for games tested the first is found in Tools/Developer Tools/CPU Core it has 3 options

    1. Dynarec
    2. Interpreter
    3. IR Interpreter

    I have seen a few games that will load using Interpreter but not using the default setting of Dynarec (side note the games that ran usning Interpreter where very very slow)

    The other parameter that is missing is found in System/PSP settings/PSP model.

    This is important to also know as i have already found out the game Sega Megadrive collection will run perfectly if the model is set to PSP-1000 but if you set it to PSP 2000-3000 the game will crash at loading. So i guess other games will suffer from the exact same issue. Anyway i will be listing some games i have tested in a few mins.
     
  13. Osakasan

    OP Osakasan GBAtemp Maniac
    Member

    Joined:
    Sep 19, 2015
    Messages:
    1,045
    Country:
    Given how weak the Wii U CPU is, i doubt any game would be playable in any option other than Dynarec, that's why i didn't put a parameter related to that.

    In any case, feel free to use the Non default settings parameter for that.
     
  14. AmandaRose

    AmandaRose Do what I do. Hold tight and pretend it’s a plan
    Member

    Joined:
    Aug 19, 2015
    Messages:
    8,015
    Country:
    United Kingdom
    Firmware: 5.5.2
    SD type and Class: SDHC Class 10
    Homebrew launcher version: 1.4
    Emulator version: v0.2
    Game: Lumines 1
    Non default settings: Frameskip set to 1, controls set to match Playstation layout
    Issues observed: No Issues

    Firmware: 5.5.2
    SD type and Class: SDHC Class 10
    Homebrew launcher version: 1.4
    Emulator version: v0.2
    Game: Lumines 2
    Non default settings: Frameskip set to 1, controls set to match Playstation layout
    Issues observed: Slight slowdown during game play

    Firmware: 5.5.2
    SD type and Class: SDHC Class 10
    Homebrew launcher version: 1.4
    Emulator version: v0.2
    Game: Lunar Silver Star Harmony
    Non default settings: Frameskip set to 1, controls set to match Playstation layout
    Issues observed: Seems to play perfectly

    Firmware: 5.5.2
    SD type and Class: SDHC Class 10
    Homebrew launcher version: 1.4
    Emulator version: v0.2
    Game: Disgaea: Hour of Darkness
    Non default settings:
    Frameskip set to 1, controls set to match Playstation layout
    Issues observed: Seems to play perfectly

    Firmware: 5.5.2
    SD type and Class: SDHC Class 10
    Homebrew launcher version: 1.4
    Emulator version: v0.2
    Game: Sega Megadrive Collection
    Non default settings:
    Frameskip set to 1, controls set to match Playstation layout, will only load if model is set to PSP-1000
    Issues observed: Slightly choppy in sonic games other games seem ok
     
    Last edited by AmandaRose, May 31, 2018
  15. AmandaRose

    AmandaRose Do what I do. Hold tight and pretend it’s a plan
    Member

    Joined:
    Aug 19, 2015
    Messages:
    8,015
    Country:
    United Kingdom
    Firmware: 5.5.2
    SD type and Class: SDHC Class 10
    Homebrew launcher version: 1.4
    Emulator version: v0.1
    Game: Capcom Clasic Collection Reloaded
    Non default settings:
    Frameskip set to 1, controls set to match Playstation layout
    Issues observed: crashes to a dsi error when loading
     
  16. skarmachild

    skarmachild GBAtemp Regular
    Member

    Joined:
    Jun 21, 2007
    Messages:
    145
    Country:
    United States
    Okay got this on, gunna work through some today - sent request access to edit the PPSSPP compatbility sheet on google docs.

    Should we have something like this:
    https://wiki.gbatemp.net/wiki/WiiSXR

    But for PPSSPP on Wii U?


    Firmware: 5.5.2
    SD type and Class: SDHC Class 10
    Homebrew launcher version: 1.4
    Emulator version: v1.54 (in OP - is this v.02?)
    Game: N+
    Non default settings: FrameSkip On 1
    Issues observed: Glitchy sound/music, very laggy.


    Firmware: 5.5.2
    SD type and Class: SDHC Class 10
    Homebrew launcher version: 1.4
    Emulator version: v1.54 (in OP - is this v.02?)
    Game: Puzzle Quest: CotW
    Non default settings: Rendering Resolution 2X , FrameSkip On 1
    Issues observed: Rarely stutters, mainly outside of actual gameplay - super playable! Save encyrption failed(?)

    Firmware: 5.5.2
    SD type and Class: SDHC Class 10
    Homebrew launcher version: 1.4
    Emulator version: v1.54 (in OP - is this v.02?)
    Game: Exit
    Non default settings: FrameSkip On 1
    Issues observed: Minor graphical glitches, very playable! Completed level 1.


    Firmware: 5.5.2
    SD type and Class: SDHC Class 10
    Homebrew launcher version: 1.4
    Emulator version: v1.54 (in OP - is this v.02?)
    Game: Gripshift
    Non default settings: FrameSkip On 1
    Issues observed: Laggy menus and SFX/music, got 5.83 seconds into a race before it locked up. Textures are messed up on track.
     
    Last edited by skarmachild, May 31, 2018
  17. AmandaRose

    AmandaRose Do what I do. Hold tight and pretend it’s a plan
    Member

    Joined:
    Aug 19, 2015
    Messages:
    8,015
    Country:
    United Kingdom
    Firmware: 5.5.2
    SD type and Class: SDHC Class 10
    Homebrew launcher version: 1.4
    Emulator version: v0.2
    Game: Chucky Egg
    Non default settings:
    Frameskip set to 1, controls set to match Playstation layout
    Issues observed: Plays perfectly

    Firmware: 5.5.2
    SD type and Class: SDHC Class 10
    Homebrew launcher version: 1.4
    Emulator version: v0.2
    Game: Cave Story
    Non default settings:
    Frameskip set to 1, controls set to match Playstation layout
    Issues observed: Dsi error when launched

    Both games can be downloaded using the PPSSPP emulator just click the home and demos tab then select download from the PPSSPP store.

    Firmware:
    5.5.2
    SD type and Class: SDHC Class 10
    Homebrew launcher version: 1.4
    Emulator version: v0.2
    Game: Final Fantasy Type 0
    Non default settings:
    Frameskip set to 1, controls set to match Playstation layout
    Issues observed: major slowdown in game


     
    Sinon likes this.
  18. Lia

    Lia C Dev and Guide Writer
    Member

    Joined:
    Jan 29, 2016
    Messages:
    2,022
    Country:
    United Kingdom
    what do you mean by "none started"
     
  19. skarmachild

    skarmachild GBAtemp Regular
    Member

    Joined:
    Jun 21, 2007
    Messages:
    145
    Country:
    United States
    Hmm, I have an issue when I run PPSSPP a second time after initially transferring files.

    E.g I installed PPSSPP for the first time, ran a few games and then restarted console. Upon booting PPSSPP again it gives a black error screen and closes.

    I removed the PPSSPP files from my SD Card, and put them back on.

    I then turned on my Wii U and opened PPSSPP, it works fine and I play a few games. I reset the console and load up PPSSPP again, and again I get a black error screen.

    I will remove the files and re-install the PPSSPP files another time and post back what happens. Not sure if other people get this? Am using the latest version of PPSSPP in OP.
     
    DarthDub likes this.
  20. DarthDub

    DarthDub Amateur Hacker
    Member

    Joined:
    Jan 26, 2016
    Messages:
    2,779
    Country:
    United States
    That happened to me on the initial release version.
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - discussion, testing, PPSSPP