Pokemon Platinum WiFi Problem

Discussion in 'NDS - Nintendo Wi-Fi Connection' started by soulbad, Mar 29, 2009.

Mar 29, 2009

Pokemon Platinum WiFi Problem by soulbad at 8:38 AM (3,897 Views / 0 Likes) 1 replies

  1. soulbad
    OP

    Newcomer soulbad Member

    Joined:
    Dec 11, 2008
    Messages:
    37
    Country:
    United States
    I'm using an M3 DS Real with the latest version of the Sakura firmware, 1.35, and a 8 GB Class 4 Kingston SDHC Card made in Japan. I just got my M3(one of the side loading ones) a few weeks ago and haven't experienced any other problems with it. I just a few days ago got a new DS Lite and this same problem occurred on my old one.

    Alright so on my Pokemon Platinum ROM whenever I try to connect to WiFi to battle someone with friend codes, when I try to accept an invite or somebody accepts mine the game freezes. I also can't search for Pokemon on the GTS, it simply says "searching blah blah blah" forever.

    Now, I later figured out that if I change the Play Mode from Standard to Download Play, battling works perfectly but the Global Trade station still doesn't work.

    This would be perfectly fine if codes actually worked in Download Play mode, but they don't.(I don't know if they're supposed to) I want to use the "Allow New Forms in WiFi" code when battling my friends.

    WiFi works perfectly fine on Mario Kart DS and Bleach:Dark Souls in Standard mode, but why is Platinum any different?

    I've tried three different clean dumps, and I've tried formatting my SD Card. Nothing works.

    I would dump my brother's Platinum cartridge and try it if I could get the FTP Server to connect, but I can't. So I can't be completely sure whether it's the dump or not.

    My real question is, am I supposed to have the game in Download Play mode for WiFi to work or not, and then why only with this game? If not, how can I fix this?
     
  2. Wehttam

    Newcomer Wehttam Advanced Member

    Joined:
    Jul 14, 2008
    Messages:
    74
    Location:
    Sioux Falls, SD
    Country:
    United States
    Platinum randomly doesn't work in sakura. I just discovered this. Just use the 3-in-1 package that sakura comes in and switch to m3dsreal when playing platinum. Works like a charm.
     

Share This Page