Nintendo DSI R4I Card update

Discussion in 'NDS - Flashcarts and Accessories' started by MrFixer, Jun 25, 2010.

Jun 25, 2010
  1. MrFixer
    OP

    Newcomer MrFixer Member

    Joined:
    Jun 24, 2010
    Messages:
    10
    Country:
    United Kingdom
    I got myself an R4i card work perfect no problems but if their is a update for the DSI from Nintendo should i update ?

    and if i did need to update is their a program i can use to update the DSI instead of updating from nintendo to make it safer ?

    like for example with the Wii you shouldnt update from Nintendo so is it the same for DSI ?
     
  2. DeltaBurnt

    Member DeltaBurnt I'm bored

    Joined:
    Feb 21, 2009
    Messages:
    3,353
    Location:
    Where intellect matters
    Country:
    United States
    No R4 clones (all R4i flashcarts are clones of the original R4) to my knowledge can update themselves, you must buy another flashcart if Nintendo updates the DSi. That being said you don't have to update. You can also just buy one of the more recommended flashcarts that get more updates and can update themselves to get around flashcart blocks.

    Please visit this thread for more info: http://gbatemp.net/t217593-the-which-flash...get-info-thread
     
  3. tk_saturn

    Member tk_saturn GBAtemp Psycho!

    Joined:
    Jan 26, 2010
    Messages:
    3,327
    Country:
    United Kingdom
    At the moment there's nothing to suggest Nintendo are going to release another update. If they were going to release an update to block flashcarts, they probably would have by now. The last update was released July 30, 2009.

    If they were going to release an update, logic says they would have released it with the DSi XL. If they release an update now, all it will do is stop people buying DSiWare as the update will be optional unless you want to but DSiWare or use the browser.
     
  4. DeltaBurnt

    Member DeltaBurnt I'm bored

    Joined:
    Feb 21, 2009
    Messages:
    3,353
    Location:
    Where intellect matters
    Country:
    United States
    Well a lot of people update without knowing that it blocks flashcarts or because they want a DSiWare like flipnote studio.
     

Share This Page