New 3DS XL, do I update?

Discussion in '3DS - Flashcards & Custom Firmwares' started by Proxin, Mar 13, 2013.

  1. Proxin
    OP

    Proxin Newbie

    Newcomer
    3
    0
    Mar 13, 2013
    United States
    Hi,
    I got a 3DS XL for my birthday. It has version 4.4.0-10U on it. I'd like to go browse the Nintendo store with it and whatnot, but I get a prompt asking me to update it.

    I'm interested in future homebrew capability. If I update now, will I lose this ability once an exploit comes out (if it does), or ability to run flash carts which can run DS homebrew?

    Regards,
    -Proxin
     
  2. DoctorSmash

    DoctorSmash GBAtemp Regular

    Member
    109
    9
    Feb 15, 2013
    United States
    You can update There are flash cards that work on v4.5.0-10u
     
  3. Rydian

    Rydian Resident Furvertâ„¢

    Member
    27,883
    8,108
    Feb 4, 2010
    United States
    Cave Entrance, Watching Cyan Write Letters
  4. jomaper

    jomaper Some random argie lost in the Internet.

    Member
    328
    135
    Dec 17, 2012
    Argentina
    Buenos Aires
    Unless you want to play online or something, I wouldnt update it just to be sure. (Much like PS3 firmware)
     
  5. Proxin
    OP

    Proxin Newbie

    Newcomer
    3
    0
    Mar 13, 2013
    United States
    Thanks for the quick responses. Out of curiosity, I'm not missing out on any free games for 3DS by not going online, am I? A while back I heard there was a free Zelda game available, but I think that deal has passed.
    I don't have any 3DS games yet, so I'm curious if I can grab any good [hopefully free] ones from the Nintendo store if I go online - or if updating to go online would just be a waste as of now.
     
  6. jomaper

    jomaper Some random argie lost in the Internet.

    Member
    328
    135
    Dec 17, 2012
    Argentina
    Buenos Aires
    I'm quite sure there isn't any free game out there right now... but I might be wrong. You can, tho, download free demos.
     
  7. Pong20302000

    Pong20302000 making notes on everything

    Member
    8,076
    1,932
    Sep 8, 2009
    One's inner self
    3DS 4.5.0-10
    doesn't block the save exploit Neimod has
    so you can update to the latest and not worry about that

    as for DS Flashcards
    well there blocked every update and the good ones get around it
    if you dont have a flashcard yet you dont have much to worry about as you can buy one when you want and they will be compatible with the version at the time
     
    Proxin and RodrigoDavy like this.
  8. Proxin
    OP

    Proxin Newbie

    Newcomer
    3
    0
    Mar 13, 2013
    United States
    Awesome! I went ahead and updated so I could grab some demos from the Nintendo store. Thanks for the information.
     
  9. BlackHolySlam

    BlackHolySlam Member

    Newcomer
    20
    0
    Jan 25, 2011
    United States
    the thing i would update for since i got my 3ds xl today is for the pokemon mystery dungeon demo.