New 1.20 Kernel for old R4, Fixed Game 3369.

Discussion in 'R4 DS' started by niu, Jun 18, 2009.

Jun 18, 2009
  1. niu
    OP

    Member niu GBAtemp Fan

    Joined:
    Dec 23, 2008
    Messages:
    305
    Country:
    United States
     


  2. Depravo

    Global Moderator Depravo Jaded curmudgeon

    Joined:
    Oct 13, 2008
    Messages:
    5,074
    Location:
    Purgatory
    Country:
    United Kingdom
    I just tried this on my genuine R4. It works so I tested a few recent problematic games -

    The Good
    Enchanted Folk and the School of Wizardry works without ARM7 patch
    Cheats show up for Yu Gi Oh meaning the R4 cheat limit is fixed

    The Bad
    GTA:CW - double white screen on loading
    FFCCEoT - Freezes on title screen

    Although it's nice to see a working R4 firmware update I think I'll be sticking to YSMenu for the foreseeable future.
     
  3. James_Wulfe

    Member James_Wulfe GBAtemp Regular

    Joined:
    Jun 4, 2009
    Messages:
    116
    Location:
    Kansas City
    Country:
    United States
    I agree, outdated is still outdated, i will stick with the continued updates of YSmenu.
     
  4. niu
    OP

    Member niu GBAtemp Fan

    Joined:
    Dec 23, 2008
    Messages:
    305
    Country:
    United States
    I will use both, YSMenu & new 1.20.

    YSMenu just a custom gui, if DSTT no update rom loader, YSMenu will not update rom loader.
     
  5. aNILEator

    Newcomer aNILEator Member

    Joined:
    Jun 17, 2009
    Messages:
    19
    Country:
    United Kingdom
    Well the cheat limit bug 'appears to be fixed'

    However

    • Won't pick up my skin (unless they've changed locations/names something)
    • Says Revolution for i.L.S and R4i Version
    • Locks up upon entering and confirming some cheats
    • Doesn't like Moonshell 2 as middle button loading
    • Seems buggy

    I'd recommend people to stay away for a while to be honest...

    Can't someone fix the cheat code limit for 1.18 firmware?
     
  6. zeromac

    Member zeromac Finally reached 1000 posts EXACTLY

    Joined:
    Mar 7, 2009
    Messages:
    2,194
    Location:
    Earth
    Country:
    Australia
    Wait so this is a official r4 firmware update? i thought the r4 team was dead?
     
  7. shakirmoledina

    Member shakirmoledina Legend

    Joined:
    Oct 23, 2004
    Messages:
    6,611
    Location:
    Dar es Salaam
    Country:
    Tanzania
    is this official... doesn't look like so
    i would really stick with yesu as it's so fantastic... never use anything else other than it
     
  8. zeromac

    Member zeromac Finally reached 1000 posts EXACTLY

    Joined:
    Mar 7, 2009
    Messages:
    2,194
    Location:
    Earth
    Country:
    Australia
    Nah i don't use YSmenu cos it dosent support homebrew
     
  9. warior

    Newcomer warior Member

    Joined:
    Mar 14, 2009
    Messages:
    14
    Country:
    Bulgaria
    wonder, can Star wars jedi alliance run now ?
     
  10. zeromac

    Member zeromac Finally reached 1000 posts EXACTLY

    Joined:
    Mar 7, 2009
    Messages:
    2,194
    Location:
    Earth
    Country:
    Australia
    Ahh FFS! i tried to install the 1.20 firmware and then i uninstalled it now i can't reinstall my 1.18 firmware.. it comes up with the error "system files currupt please reinstall system files"...

    EDIT: oh fuck me... i can't reinstall my 1.18 firmware and whats WORSE 1.20 DOSENT I REPEAT DOSEN'T HAVE DLDI PATCHING SO IT DOSENT DLDI AUTO PATCH FFS
     
  11. Depravo

    Global Moderator Depravo Jaded curmudgeon

    Joined:
    Oct 13, 2008
    Messages:
    5,074
    Location:
    Purgatory
    Country:
    United Kingdom
    I seem to have no trouble running ScummVMDS, Lameboy, NesDS, jEnesisDS, ApprenticeMinusDS, , ComicbookDS, Moonshell 2 and Triple Triad.

    EDIT: Good Lord! SWCW: Jedi Alliance DOES work with this. I wasn't expecting that! And so does that Tropix game. So it seems that using v1.20 with YSMenu as a secondary loader will give nigh-on 100% compatibility for genuine R4 users. Result!

    EDIT2: After a while, SWCW: Jedi Alliance stopped loading until I deleted the _DS_MENU system file and skins/themes always reset to the default. The text on the game selection screen sometime flickers and Pokemon Platinum only generates a 512kb save file. v1.20 is looking less and less stable/functional all the time.
     
  12. Chris_Skylock

    Member Chris_Skylock GBAtemp Advanced Maniac

    Joined:
    Dec 26, 2008
    Messages:
    1,501
    Location:
    Philippines
    Country:
    Philippines
    IS this official R4 firmware? I dont have my R4 with me as I gave it away to my cousin together with my DS Lite but I'll test it out if others will. lol
     
  13. Depravo

    Global Moderator Depravo Jaded curmudgeon

    Joined:
    Oct 13, 2008
    Messages:
    5,074
    Location:
    Purgatory
    Country:
    United Kingdom
    To get Moonshell 2 to work from the middle button you have to use moonshl2_DirectBoot.nds. Rename it to _DS_MSHL.NDS and DLDI patch it. As pointed out earlier, this new v1.20 does not support auto-DLDI patching.
     
  14. zeromac

    Member zeromac Finally reached 1000 posts EXACTLY

    Joined:
    Mar 7, 2009
    Messages:
    2,194
    Location:
    Earth
    Country:
    Australia
    Thanks man it worked im back to 1.18 but i do actually miss the cheat limit removal thing which was awesome.
    But in exchange for the cheat limit removal thing we lose auto DLDI patching D:
     
  15. Depravo

    Global Moderator Depravo Jaded curmudgeon

    Joined:
    Oct 13, 2008
    Messages:
    5,074
    Location:
    Purgatory
    Country:
    United Kingdom
    Just use v1.18/v1.20 as your main firmware and have YSMenu load as a normal NDS ROM. You get the best of both worlds. [​IMG]
     
  16. zeromac

    Member zeromac Finally reached 1000 posts EXACTLY

    Joined:
    Mar 7, 2009
    Messages:
    2,194
    Location:
    Earth
    Country:
    Australia
    wait... i always thought ysmenu was used as a main firmware? and ur saying that i can use my 1.18 firmware and run ysmenu as a .nds file and use both? COOL well ill think about it cos i need to think about the cheats and stuff and i also need instructions on how to use it as a .nds file thanks [​IMG]
     
  17. Chris_Skylock

    Member Chris_Skylock GBAtemp Advanced Maniac

    Joined:
    Dec 26, 2008
    Messages:
    1,501
    Location:
    Philippines
    Country:
    Philippines
    it seems the problem is the auto-DLDI.
     
  18. Depravo

    Global Moderator Depravo Jaded curmudgeon

    Joined:
    Oct 13, 2008
    Messages:
    5,074
    Location:
    Purgatory
    Country:
    United Kingdom
    Use R4YSauto and pick #4 (Like any NDS file) at the last option. Then download USRCHEAT.DAT and put it in the TTMENU folder.
     
  19. elixirdream

    Member elixirdream GBAtemp Legend

    Joined:
    May 27, 2008
    Messages:
    10,007
    Location:
    6th Dimention
    Country:
    Malaysia
    i just hope they can fix some of the bugs and improve the compatibilty of the firmware
    at least is a GOOD START~!
     
  20. Lacius

    Member Lacius GBAtemp Psycho!

    Joined:
    May 11, 2008
    Messages:
    3,895
    Location:
    St. Louis, Missouri
    Country:
    United States
    Interesting. When trying to connect Pokémon Platinum to the Wii using firmware 1.20, it hangs at the "Wii Found. Communicating with Wii..." screen instead of the dual white screens.
     

Share This Page