MK11 + update, which firmware?

Discussion in 'Switch - Games & Content' started by Bluer, Apr 21, 2019.

  1. Bluer
    OP

    Bluer Member

    Newcomer
    1
    Jan 4, 2019
    Poland
    Hello,
    My switch is on 6.2.0 + newest ReiNX.
    Is there any way to install MK11 + update on my fw? Goldleaf maybe?
    Or the fw update is mandatory?

    Thanks in advance!
     
  2. Clapmaster

    Clapmaster GBAtemp Regular

    Member
    3
    Dec 3, 2009
    United States
    I went to 7.0.1 to play because that's what everyone was saying that the update requires. Can't confirm that 100% sure though because I've only tried 7.0.1. Gotta be honest I'm kinda let down by this game. You can't unlock anything or save anything you've earned in the game without being online connected to Nintendo and Netherrealm servers. Story progress is pretty much the only thing that saves offline. Also the Switch version appears to be running at a very low blurry resolution but it does run fairly fluidly so I guess that's a plus.
     
    Last edited by Clapmaster, Apr 21, 2019
  3. Bluer
    OP

    Bluer Member

    Newcomer
    1
    Jan 4, 2019
    Poland
    I heard that game relies mostly on internet connection and most game modes and The Crypt are locked behind it.
    It would be great if someone managed to patch these online functions and make every option work without internet connection. Making an online-only game on a handheld console is a very bad move.
    I think I will pass on this game, for now.
     
    Clapmaster likes this.
  4. Dave_Chad

    Dave_Chad GBAtemp Advanced Fan

    Member
    6
    Jun 29, 2016
    Yup even during the tutorial the game repeatedly tried to connect me to the internet i was like wtf.
     
    Rizzorules likes this.
  5. toto621

    toto621 GBAtemp Regular

    Member
    4
    Jan 19, 2015
    Belgium
    Forget this game if you're not a legit owner, all unlockable content is gated behing online wall...So ridiculous it almost sound like a joke...nothing saved on the console, no online mean basic game ONLY...
     
    bomigoton likes this.
  6. Rune

    Rune GBAtemp Advanced Fan

    Member
    6
    Feb 15, 2017
    I'm on 6.2.0 and can play the game. You need to use NSC Builder to rebuild the xci or nsp with the 6.2.0 keys.
     
  7. fermin3344

    fermin3344 Newbie

    Newcomer
    1
    Apr 22, 2019
    United States
    Can you please help me on with my problem. I have been successful with nsc builder up until the recent releases such as Hellblade and MK11. Pretty much anything that runs on 7.0.1. I Updated my keys and use the latest version v.82b and everything goes accordingly, the script doesn't report any errors but when I finally try launching a game no luck. I've tried repacking with the game updates or simply converting nsp to xci and neither have work.
     
  8. Sunnyboy

    Sunnyboy GBAtemp Regular

    Member
    4
    Mar 22, 2008
    United States
    Works fine
     

    Attached Files:

  9. emuman100

    emuman100 GBAtemp Regular

    Member
    3
    May 12, 2006
    United States
    So you can run both the game and the update on 6.2.0 by rebuilding with the 6.2.0 keys?
     
  10. darkseekerliu

    darkseekerliu Advanced Player

    Member
    4
    Jun 13, 2013
    Brazil
    Drakonia
    Senuas sacrifice and new games have some new details that old custom firmwares don't support Update to sx os 2.6.2 or atmosphere 0.8.8 and you should be good
     
  11. emuman100

    emuman100 GBAtemp Regular

    Member
    3
    May 12, 2006
    United States
    I tried NSC Builder. It isn't documented properly and doesn't say what release file to use or of python is needed. I did fill out the keys file, but the nsp files it creates are bad files. What is needed for NSC Builder?
     
  12. Rune

    Rune GBAtemp Advanced Fan

    Member
    6
    Feb 15, 2017
    You need a keys.txt file with at least the 7.0 keys in there. You cant ask for that here so google that.
    Then you need to take both the game and the update, use "MULTI-PACK mode", and make a new nsp or xci with it, and when it asks, you need to change the required firmware on it to the one you want to use it on. I changed it to 6.2.0, then I was able to use the game perfectly fine.
     
    Bluer likes this.
  13. emuman100

    emuman100 GBAtemp Regular

    Member
    3
    May 12, 2006
    United States
    Did you need to install python too? Did you use the beta or stable? My keys.txt was dumped from my NAND when it was at 6.0.0. Was that the reason why it wouldn't generate files?
     
  14. Rune

    Rune GBAtemp Advanced Fan

    Member
    6
    Feb 15, 2017
    Yeah, you need the 7.0 keys too. Naturally you're going to have to download them yourself from somewhere since you're not on that firmware yourself.
    I havent really played the game properly (I just checked to see if it worked and then played practice mode). But apparently you cant save the game because it requires an internet connection. So keep that in mind before bothering to do this.
     
  15. emuman100

    emuman100 GBAtemp Regular

    Member
    3
    May 12, 2006
    United States
    Do I need to install python too? NSC Builder documentation doesn't say.
     
  16. blahblah

    blahblah GBAtemp Maniac

    Member
    8
    May 16, 2018
    United States
    Update to 7.0.1. It's easier than rebuilding games manually.
     
  17. Rune

    Rune GBAtemp Advanced Fan

    Member
    6
    Feb 15, 2017
    Its not even that bad rebuilding games. Takes literally less than 5 mins to do.

    Not sure about python. It just works for me. I dont remember having to install anything else.
     
    emuman100 likes this.
  18. blahblah

    blahblah GBAtemp Maniac

    Member
    8
    May 16, 2018
    United States
    And it takes less than 5 minutes to update, and everything works. Not just some games. Can't rebuild Smash 3.0, can't rebuild Hellblade. I mean, you can, but they still won't work. Better to have people just update.
     
  19. tigersaman

    tigersaman Member

    Newcomer
    3
    Jul 10, 2018
    Iran
    Just Updated to 7.0.1 last night for this game. the visuals are way too awful. way too awful for even 3ds !
     
    toto621 likes this.
  20. fst312

    fst312 GBAtemp Advanced Fan

    Member
    5
    Nov 4, 2008
    United States
    New York
    Just curious, I’m banned so obviously I can’t complete this game but if I wasn’t banned would this game need the $20 Nintendo online service to be able to complete it.
     
Loading...