Misc MikroTik/RouterOS StreetPass Relay

mooseable

New Member
OP
Newbie
Joined
May 30, 2014
Messages
2
Trophies
0
Age
40
XP
51
Country
Hi Guys. I just set up my MikroTik router (RB591Ui-2HnD) as a StreetPass Relay but it should work with any wireless MikroTik/RouterOS device. I've also configured it to auto-rotate ~190 MAC addresses every 24 hours (~1 pass every 8 minutes).

If you're interested in doing this yourself AND you want to keep your WiFi connection secure, you can do the following;

Set wlan1's SSID to "attwifi"
Enable WPA2 aes encryption and give it a key of your choice.
On your DS, set up "attwifi" as a connection profile using the WPA2 key you used on the Router.

Now the fun part, the auto-rotation.
Go into SYSTEM, then into SCRIPTS.
Create a new script and call it "rotate-streetpass-mac"
Grant the script full policy rights for simplicity's sake.
In the source section, enter the following;

Code:
:global matchingmac "false"
:global newmac 4E:53:50:4F:4F:00
:global currentmac [/interface wireless get wlan1 mac-address]
:global maclist [:toarray COMMA-SEPARATED-MAC-ADDRESSES-GO-HERE]
:foreach macaddress in=$maclist do={
:if ($macaddress = $currentmac) do={
  :global matchingmac "true"
} else={
  :if ($matchingmac = "true") do={
  :global newmac $macaddress
  }
:global matchingmac "false"
}
}
/interface wireless set wlan1 mac-address=$newmac
/interface wireless disable wlan1
/interface wireless enable wlan1
:log info "Wifi old mac is $currentmac has been changed to $newmac"

Replace the "COMMA-SEPARATED-MAC-ADDRESSES-GO-HERE" with your list of mac addresses. I got my list from this awesomely maintained spreadsheet

Also, the line ":global newmac 4E:53:50:4F:4F:00" should have the mac address of the FIRST mac address in your list of comma separated mac addresses. I hope that makes sense.

Now save the script


Lastly, go to SYSTEM, then SCHEDULER

Create a new schedule and call it whatever you want
Set the start time to now
Set the Interval to (8 hours / The number of MAC addresses) with a minimum of ~8 minutes. Feel free to experiment, but I've had great success with ~8 minute rotations.
Set the "On Event" to "rotate-streetpass-mac" or whatever you called the script earlier.
Set the policy to Read/Write
Save the schedule


And you're done! The only issue I had was to do with the streetpasses not registering in some games, even though the pass registered in the mii-plaza. I fixed this by (on the 3DS) going in to settings, data management, streetpass management then disabling streetpass on the mii-plaza.

At the time of this post, the mac address list I'm using is below, but I recommend using the spreadsheet mentioned above for the most up-to-date addresses.


Code:
4E:53:50:4F:4F:00,4E:53:50:4F:4F:01,4E:53:50:4F:4F:02,4E:53:50:4F:4F:03,4E:53:50:4F:4F:04,4E:53:50:4F:4F:05,4E:53:50:4F:4F:06,4E:53:50:4F:4F:07,4E:53:50:4F:4F:08,4E:53:50:4F:4F:09,4E:53:50:4F:4F:0A,4E:53:50:4F:4F:0B,4E:53:50:4F:4F:0C,4E:53:50:4F:4F:0D,4E:53:50:4F:4F:0E,4E:53:50:4F:4F:0F,4E:53:50:4F:4F:10,4E:53:50:4F:4F:11,4E:53:50:4F:4F:12,4E:53:50:4F:4F:13,4E:53:50:4F:4F:14,4E:53:50:4F:4F:15,4E:53:50:4F:4F:16,4E:53:50:4F:4F:17,4E:53:50:4F:4F:18,4E:53:50:4F:4F:19,4E:53:50:4F:4F:1A,4E:53:50:4F:4F:1B,4E:53:50:4F:4F:1C,4E:53:50:4F:4F:1D,4E:53:50:4F:4F:1E,4E:53:50:4F:4F:1F,4E:53:50:4F:4F:20,4E:53:50:4F:4F:21,4E:53:50:4F:4F:21,4E:53:50:4F:4F:23,4E:53:50:4F:4F:24,4E:53:50:4F:4F:25,4E:53:50:4F:4F:26,4E:53:50:4F:4F:27,4E:53:50:4F:4F:28,4E:53:50:4F:4F:29,4E:53:50:4F:4F:2A,4E:53:50:4F:4F:2B,4E:53:50:4F:4F:2C,4E:53:50:4F:4F:2D,4E:53:50:4F:4F:2E,4E:53:50:4F:4F:2F,4E:53:50:4F:4F:30,4E:53:50:4F:4F:31,4E:53:50:4F:4F:32,4E:53:50:4F:4F:33,4E:53:50:4F:4F:34,4E:53:50:4F:4F:35,4E:53:50:4F:4F:36,4E:53:50:4F:4F:37,4E:53:50:4F:4F:38,4E:53:50:4F:4F:39,4E:53:50:4F:4F:3A,4E:53:50:4F:4F:3B,4E:53:50:4F:4F:3C,4E:53:50:4F:4F:3D,4E:53:50:4F:4F:3E,4E:53:50:4F:4F:3F,4E:53:50:4F:4F:40,4E:53:50:4F:4F:41,4E:53:50:4F:4F:42,4E:53:50:4F:4F:43,4E:53:50:4F:4F:44,4E:53:50:4F:4F:45,4E:53:50:4F:4F:46,4E:53:50:4F:4F:47,4E:53:50:4F:4F:48,4E:53:50:4F:4F:49,4E:53:50:4F:4F:4A,4E:53:50:4F:4F:4B,4E:53:50:4F:4F:4C,4E:53:50:4F:4F:4D,4E:53:50:4F:4F:4E,4E:53:50:4F:4F:4F,4E:53:50:4F:4F:50,4E:53:50:4F:4F:51,4E:53:50:4F:4F:52,4E:53:50:4F:4F:53,4E:53:50:4F:4F:54,4E:53:50:4F:4F:55,4E:53:50:4F:4F:56,4E:53:50:4F:4F:57,4E:53:50:4F:4F:58,4E:53:50:4F:4F:59,4E:53:50:4F:4F:5A,4E:53:50:4F:4F:5B,4E:53:50:4F:4F:5C,4E:53:50:4F:4F:5D,4E:53:50:4F:4F:5E,4E:53:50:4F:4F:5F,4E:53:50:4F:4F:60,4E:53:50:4F:4F:61,4E:53:50:4F:4F:62,4E:53:50:4F:4F:63,4E:53:50:4F:4F:64,4E:53:50:4F:4F:65,4E:53:50:4F:4F:66,4E:53:50:4F:4F:67,4E:53:50:4F:4F:68,4E:53:50:4F:4F:69,4E:53:50:4F:4F:6A,4E:53:50:4F:4F:6B,4E:53:50:4F:4F:6C,4E:53:50:4F:4F:6D,4E:53:50:4F:4F:6E,4E:53:50:4F:4F:6F,4E:53:50:4F:4F:70,4E:53:50:4F:4F:71,4E:53:50:4F:4F:72,4E:53:50:4F:4F:73,4E:53:50:4F:4F:73,4E:53:50:4F:4F:75,4E:53:50:4F:4F:76,4E:53:50:4F:4F:77,4E:53:50:4F:4F:78,4E:53:50:4F:4F:79,4E:53:50:4F:4F:7A,4E:53:50:4F:4F:7B,4E:53:50:4F:4F:7C,4E:53:50:4F:4F:7D,4E:53:50:4F:4F:7E,4E:53:50:4F:4F:7F,4E:53:50:4F:4F:80,4E:53:50:4F:4F:81,4E:53:50:4F:4F:82,4E:53:50:4F:4F:83,4E:53:50:4F:4F:84,4E:53:50:4F:4F:85,4E:53:50:4F:4F:86,4E:53:50:4F:4F:87,4E:53:50:4F:4F:88,4E:53:50:4F:4F:89,4E:53:50:4F:4F:8A,4E:53:50:4F:4F:8B,4E:53:50:4F:4F:8C,4E:53:50:4F:4F:8D,4E:53:50:4F:4F:8E,4E:53:50:4F:4F:8F,4E:53:50:4F:4F:90,4E:53:50:4F:4F:91,4E:53:50:4F:4F:92,4E:53:50:4F:4F:93,4E:53:50:4F:4F:94,4E:53:50:4F:4F:95,4E:53:50:4F:4F:96,4E:53:50:4F:4F:97,4E:53:50:4F:4F:98,4E:53:50:4F:4F:99,4E:53:50:4F:4F:9A,4E:53:50:4F:4F:9B,4E:53:50:4F:4F:9C,4E:53:50:4F:4F:9D,4E:53:50:4F:4F:9E,4E:53:50:4F:4F:9F,00:0D:67:15:2D:82,00:0D:67:15:D7:21,00:0D:67:15:D5:44,00:0D:67:15:D2:59,00:0D:67:15:D6:FD,00:0F:F7:00:2D:82,50:3D:E5:75:50:62,00:1A:A2:A2:17:23,00:1F:CA:60:42:80,00:0D:67:1A:46:E7,00:3A:99:5B:D0:82,00:1F:9E:D3:84:60,00:0D:BD:AF:DA:4A,00:1F:CA:60:3E:20,00:90:FB:32:8C:A4,00:21:D8:DE:AB:C0,00:24:14:10:df:12,00:14:6a:c5:69:52,5c:0a:5b:2f:3e:61,00:22:55:C3:9E:A0,00:15:c6:29:5f:92,00:11:92:8D:A3:80,00:26:99:4E:B2:30,00:13:1A:13:06:42,00:11:93:05:CE:F0,58:6d:8f:0f:ad:7b,e8:40:40:cd:ed:21,c4:71:fe:5b:de:f2,C4:71:FE:5C:2D:F2,00:21:D8:34:41:70,00:1D:70:9B:08:62,00:21:55:B4:E4:00,F0:7D:68:16:B7:2D,48:5A:B6:C0:35:27,00:12:00:CD:0F:72
 

Site & Scene News

Popular threads in this forum

General chit-chat
Help Users
    K3Nv2 @ K3Nv2: So negative