microsdXC not working Switch 2.0.0

Discussion in 'Switch - Hacking & Homebrew' started by panther666, Apr 4, 2017.

  1. panther666
    OP

    panther666 GBAtemp Regular

    Member
    140
    28
    Nov 29, 2015
    Serbia, Republic of
    When i insert microsdXC 128gb in my switch with system software 2.0.0, it said that i need to update system for use microsdXC card.
    How can i use it with microsd without updating to 2.1.0?
     
    Last edited by panther666, Apr 4, 2017
  2. OfficialFBomb

    OfficialFBomb GBAtemp Advanced Fan

    Member
    530
    145
    Aug 24, 2015
    United States
    Your not updating to 2.1.0 its a micro non system update for sdxc, although it might auto update to 2.1.0, but just update anyways, stop worrying about homebrew and shit and just update.. Jeeze..
     
    jpx86 and Sonic Angel Knight like this.
  3. xtheman

    xtheman GBAtemp Guru

    Member
    5,847
    5,279
    Jan 28, 2016
    United States
    I've asked this before. I got 3 pages of shitposting before I got a legit answer. You just need to format the SDXC card to fat32. The update just adds exFat support.
     
  4. Risingdawn

    Risingdawn Tempallica

    Member
    681
    461
    May 22, 2010
    United Kingdom
    That is good to know, thanks for taking one for the team ;)
     
    xtheman likes this.
  5. panther666
    OP

    panther666 GBAtemp Regular

    Member
    140
    28
    Nov 29, 2015
    Serbia, Republic of
    You right, thank you, it's helped me!
    What do you think, how this will affect on the future work (speed)?
     
  6. linuxares

    linuxares GBAtemp Psycho!

    Member
    3,249
    1,386
    Aug 5, 2007
    It will make a minor difference in the speed between in fat32 and exfat. You will be fine.
     
  7. xtheman

    xtheman GBAtemp Guru

    Member
    5,847
    5,279
    Jan 28, 2016
    United States
    Not sure really, only problem I can see is the 4GB file limitation of fat32 (but it shouldn't be an issue)
     
  8. panther666
    OP

    panther666 GBAtemp Regular

    Member
    140
    28
    Nov 29, 2015
    Serbia, Republic of
    I hope for it! )
     
  9. DocAmes1980

    DocAmes1980 GBAtemp Advanced Fan

    Member
    540
    338
    Oct 31, 2016
    United States
    SDXC cards were working in 2.0.0. Block updates, power off the console (not sleep), and try again.
     
  10. panther666
    OP

    panther666 GBAtemp Regular

    Member
    140
    28
    Nov 29, 2015
    Serbia, Republic of
    I think limitation will not be a problem because switch format smaller cards (tested on 16gb) into fat32, not exfat...

    — Posts automatically merged - Please don't double post! —

    No, i've tried to full wipe, it's not helped...
    Problem was in format exfat/fat32.
     
  11. DocAmes1980

    DocAmes1980 GBAtemp Advanced Fan

    Member
    540
    338
    Oct 31, 2016
    United States
    Oh, that's why the SDXC card I tried worked. I'll just stick to FAT32 until there's a system update worth taking.
     
  12. Pippin666

    Pippin666 SSF43DE Master

    Member
    1,828
    248
    Mar 30, 2009
    Canada
    Montreal, Qc
    Haha, poor kid and their race to stay on the lowest firmware version as possible.

    Pip'
     
    Shadowfied and Felek666 like this.
  13. DocAmes1980

    DocAmes1980 GBAtemp Advanced Fan

    Member
    540
    338
    Oct 31, 2016
    United States
    I'll update when there's an advantage to doing so. 2.1.0 adds exFAT support, fixes a Webkit exploit, and probably does fuck else. Go piss up a rope.
     
    Risingdawn likes this.
  14. Sonic Angel Knight

    Sonic Angel Knight GBAtemp Legend

    Member
    10,334
    5,246
    May 27, 2016
    United States
    New York
    I doubt the requirement for update using a sdxc is going to update to 2.1.0. If the system was on the latest version firm ware already a month ago (2.0.0) and adding a exfat sd card required a update.... what exactly is there to up date? That should have been there in the 2.0.0 update from day one, not only ask after inserting a sd card, it wouldn't make sense.

    Is probably just their way of asking for permission to unlock the feature. Much like for example how you can enable wma playback on psp by connecting to the internet, it probably just change a value in the system regristy to enable the exfat format.

    Though you could always just disable the internet on the switch and then pop in a sd card to see what will happen if anything, still i don't believe the "Update" is actually a update to new firmware :blink:
     
    chartube12 likes this.
  15. panther666
    OP

    panther666 GBAtemp Regular

    Member
    140
    28
    Nov 29, 2015
    Serbia, Republic of
    Why do you teach others?
    Everyone does what he thinks is right for himself.

    I want to see a retroarch on switch, i understand that it can be 1-2 years later, but at that moment there are no restrictions:
    - online works
    - eshop shop too
    - game updates are downloading

    For what should I update the firmware?

    — Posts automatically merged - Please don't double post! —

    As i said, i try to wipe system and then insert sd card without internet connection, same shit...
    FAT32 helped!
     
  16. ddrrmm

    ddrrmm GBAtemp Regular

    Member
    165
    78
    Feb 11, 2007
    United States
    if you're not doing RE, there is not much reason for you to be on 2.0..

    If you're a "hacker" and want to stay on 2.0 for RE'ing,..understandably.
    But if you're not doing that or have no tech knowledge, then there is no real reason to stay on 2.0.

    Reswitch team will not even release any "real" exploits if it doesn't work on the "latest" fw.
     
  17. panther666
    OP

    panther666 GBAtemp Regular

    Member
    140
    28
    Nov 29, 2015
    Serbia, Republic of
    Maybe yes, maybe not, who knows? This are only assumptions without proofs...
    Knowing the history of hacking various consoles, it can be in different ways...
     
  18. ddrrmm

    ddrrmm GBAtemp Regular

    Member
    165
    78
    Feb 11, 2007
    United States
    Who knows? Well apparently not you..no offense

    Look at the update changes, go talk to people actually working on this or maybe even put some work in yourself. Gather some good information.
    In my opinion you haven't done so as u seem to think the webkit exploit is like some holy grail.

    Be my guest by staying on 2.0, but anyone with a little knowledge can tell you you can update.
    FYI, I don't really give a shit what fw you're on, but don't act like 2.0 is where you NEED to be.
     
  19. Risingdawn

    Risingdawn Tempallica

    Member
    681
    461
    May 22, 2010
    United Kingdom
    We all know we can update, the point is there is no reason to 'yet'. Nothing has been added, nothing. 2.1.0 is exactly the same as 2.0.0. Everything works exactly the same, eshop, online, functionality, everything.

    We can update any time we want, when eshop doesn't work=update. When features are added=update. When a game requires it=update. We can happily skip 2..1.0 completely when updates actually start adding to the experience.

    Somebody give me one good reason to update right now and I would but "May as well" is not a good reason to update.
     
  20. Jiehfeng

    Jiehfeng Wu-Wei

    Member
    4,256
    2,008
    Aug 15, 2012
    United States
    Finding that out myself.
    I got a 128GB microSD so it's surely exFAT, is exFAT faster than FAT32? If so what's the speed difference? I left it as it is and updated, hopefully I'm not missing out (but by the looks of it exFAT is better cause it sounds cooler :creep:).