Homebrew Lovebrew building project

nfoert

Member
OP
Newcomer
Joined
Apr 5, 2023
Messages
10
Trophies
0
Age
16
XP
55
Country
United States
I'm learning how to make my own homebrew with LoveBrew. I'm following the 'LÖVE Potion Tutorial' from lovebrew.org. I'm new to 3DS homebrew and Lua but not new to programming. I've made it to the point in the guide where I run lovebrew build. I get an error Build for Nintendo 3DS failed. Check log for details. I've already enabled logging in lovebrew.toml. Inside the log file is:
Code:
INFO [13:19:06] -- lovebrew: Initialize..
INFO [13:19:06] -- lovebrew: -- Nintendo 3DS --
INFO [13:19:06] -- lovebrew: Packing game content...
INFO [13:19:06] -- lovebrew: Zipping build\game to nfoert.love
ERROR [13:19:06] -- lovebrew: Error packing game content: Zip archive has no contents
My directory structure is:
Code:
/Test
     - /build
     - /SuperGame
          - main.lua
     - icon.png
     - lovebrew.toml
I've also modified lovebrew.toml changing targets = ["3ds", "switch"] to targets = ["3ds"] (Including "switch" causes ERROR [18:27:58] -- lovebrew: Binary `C:\Users\xxxxx\AppData\Roaming\lovebrew\LOVEPotion.nro` was not found. Aborting. to appear in the log file as well, but I'm not developing for switch, so I'm not sure this applies to me.)

main.lua contains
Code:
function love.draw()
    love.graphics.print('Hello World!', 200, 120)
end
-- we need to quit the app when a button is pressed
function love.gamepadpressed(joystick, button)
    love.event.quit()
end
This is the code at the bottom of the home page of lovebrew,org

I'm unsure what zip archive the error ERROR [13:19:06] -- lovebrew: Error packing game content: Zip archive has no contents refers to.
I have devkitpro installed.
What am I doing wrong?

(Apologies if this is the wrong place to ask something like this.)
Post automatically merged:

-----------------------------------------------------------------------------------------------------------------------------------------------------------------------------------


Ok I found the solution. If anyone comes across this issue in the future, here's what worked for me.

First, I installed an older version of lovebrew (LÖVEBrew 0.5.5) from the lovebrew GitHub. Put the windows executable lovebrew.exe in C:\Users\yourname\AppData\Roaming\lovebrew (If you were following the 'LÖVEBrew tutorial' I mentioned in my original post you should already have hbupdater.exe and lovepotion.3dsx in this location. You can remove lovepotion.3dsx, then download the 3DS folder from the lovepotion GitHub. Take the LovePotion.elf file, rename it to 3DS.elf and drop it in your C:\Users\yourname\AppData\Roaming\lovebrew folder. Now, navigate to your project folder (where you have your .lua files and lovepotion.toml) Right-click and select Open in Terminal and then type lovebrew build. (If you get a message saying something about the config file not being supported, run the command lovebrew init and then y to generate a new one, then try lovebrew build again.)

If everything went as planned, navigate to your build folder, copy it to the 3ds folder on your SD card for your 3DS and rename it to something else. (I just chose lovebrew you probably don't have to rename it but I feel like leaving directories called build might cause problems. :P)

It seems like using the newest version of lovebrew (0.6.0) does matter because I'm getting the same error as before. (Error packing game content: Zip archive has no contents)

I hope this helps someone, since it was very hard for me to find much documentation or people having problems with lovebrew.
 
Last edited by nfoert,
  • Like
Reactions: CooingMaxito

Site & Scene News

Popular threads in this forum

General chit-chat
Help Users
    SylverReZ @ SylverReZ: https://www.youtube.com/watch?v=nReknkEB5qo