[List] Games required Firmware version

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by B4rtj4h, Oct 5, 2017.

  1. Priyansh

    Priyansh Newbie

    Newcomer
    2
    Dec 22, 2010
    India
    It means that the base game will work on 4.1.0 , but if you install an update it will need 5.0.0
     
  2. Chrushev

    Chrushev GBAtemp Advanced Fan

    Member
    5
    Jul 23, 2013
    Serbia, Republic of
    Can OP be updated please?
     
  3. bomigoton

    bomigoton GBAtemp Regular

    Member
    4
    Mar 8, 2009
    Gambia, The
    What does New Super Mario Bros U Deluxe need? 5.1.0 like Pokemon/Smash or anything higher?

    Edit:
    New SMB U deluxe does not work on 5.1.0. So I assume 6.1 or 6.2 is needed.
     
    Last edited by bomigoton, Jan 10, 2019
  4. Zeriel

    Zeriel Squid Kid

    Member
    3
    Jul 10, 2015
    Anyone knows what I need for Civilization VI? Dragon Quest Builders 2?
    I got an error installing Civ VI and now have a permanent game loading on my Game menu that won't go away :(
    Updating DQB2 and Vesperia also failed in 6.1
     
  5. tpax

    tpax GBAtemp Regular

    Member
    5
    Nov 16, 2014
    Gambia, The
    NSMBUD works fine here on 5.1.0. Latest SX OS, XCI.
     
    bomigoton likes this.
  6. bomigoton

    bomigoton GBAtemp Regular

    Member
    4
    Mar 8, 2009
    Gambia, The
    It seems I was using a bad *.nsp file. USB Install on 4.1 threw a "corrupt data" error. Then ChoiDujourNX to 5.1 and fresh install from sd, but still corrupt data. First I thought this error meant "firmware too low"
    I will convert the data again from a fresh *.xci. Some people on reddit stated they had the same issue with a bad *.nsp

    I am using latest KosmosV1171/Hekate4.6/atmosphere downloaded january 8th.

    Edit:
    What error would you get trying starting this game on switch firmware 4.1?
    Accoring to XCI Explorer this game 4.0/4.1 encryption wise.
     
    Last edited by bomigoton, Jan 11, 2019
  7. Mackwa

    Mackwa Member

    Newcomer
    1
    Jan 26, 2016
    Gambia, The
    New Super Mario Bros U Deluxe works fine on original (not patched) console on Firmware 4.1.0
     
    bomigoton likes this.
  8. bomigoton

    bomigoton GBAtemp Regular

    Member
    4
    Mar 8, 2009
    Gambia, The
    NSMB U deluxe works when I use the xci installer. 5.1 Kosmos
     
  9. WiseFool

    WiseFool Advanced Member

    Newcomer
    2
    Sep 3, 2018
    India
    Which version does Onimusha need?
     
  10. fourminute

    fourminute GBAtemp Regular

    Member
    3
    Jan 15, 2019
    United States
    Thank you! I've been looking all over for this list. Found it here first.
     
  11. Jellykrop

    Jellykrop Member

    Newcomer
    1
    Dec 28, 2015
    United States
    Hi, I'm currently on firmware 2.1, can I update using an XCI file (with the update packed inside) to 5.0.1 for instance, in order to bypass updating through the system settings ? I would like to avoid updating to 6.2, at least for now.
     
  12. Draxzelex

    Draxzelex GBAtemp Guru

    Member
    17
    Aug 6, 2017
    United States
    New York City
    No.
     
  13. Jellykrop

    Jellykrop Member

    Newcomer
    1
    Dec 28, 2015
    United States
    Oh okay, sad!
     
  14. slicer2k

    slicer2k Member

    Newcomer
    1
    Aug 9, 2017
    Brazil
    so the majority of games that come out of the box doesn't require nothing newer then 5.1 so there is no need for update, if i don't want to play a specific game, since it's kinda risky?
     
  15. simba115

    simba115 Advanced Member

    Newcomer
    2
    Dec 23, 2010
    United States
    I am on 6.1 and tried to install nsp of feudal alloy even with ignore firmware version it doesn’t load. Is this the first game that requires 6.2? Or maybe there are others but I haven’t encountered them yet?
     
  16. masagrator

    masagrator GBAtemp Regular

    Member
    3
    Oct 14, 2018
    Poland
    Every nsp game downloaded from when 6.2.0 came out needs 6.2.0.
    This thread is for XCI games.
    You can always use for example NSC Builder to rebuild nsp with ignoring 6.2.0 firmware.
     
  17. simba115

    simba115 Advanced Member

    Newcomer
    2
    Dec 23, 2010
    United States
    This will actually work?? I thought if ignore firmware version doesn’t work when you install with tinfoil for example it means the game is encrypted with higher keys or something and you can’t get around needing the higher firmware to run the game.
     
  18. pLaYeR^^

    pLaYeR^^ GBAtemp Maniac

    Member
    6
    GBAtemp Patron
    pLaYeR^^ is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    Sep 18, 2014
    Austria
    Austria
    NSC Builder let's you erase the titlerights encryption from nsp files.
     
  19. bytar

    bytar Holy Knight

    Member
    3
    Jan 5, 2016
    Japan
    is there a full list including all the new games?
     
  20. sergux

    sergux Advanced Member

    Newcomer
    2
    Jul 14, 2018
    Afghanistan
    update the fisrt post pls!
     
Loading...