[List] Games required Firmware version

Discussion in 'Switch - Exploits, Custom Firmwares & Soft Mods' started by B4rtj4h, Oct 5, 2017.

  1. nash13

    nash13 Newbie

    Newcomer
    1
    Jun 24, 2014
    Indonesia
    If i want to play original game cart octopath traveler which is only playable on fw 5.0.2 (I'm on fw 3.0.2 now) Can i update fw from the game cart itself without update fw online?

    And after that if i have finish the game, if i want to play game with cfw, i still can hack my switch or not?
     
  2. Lacius

    Lacius GBAtemp Guru

    Member
    16
    May 11, 2008
    United States
    Yes, you can update with the game cartridge without connecting to the internet. You can also use ChoiDujourNX to update to any system version offline. If you use ChoiDujourNX to upgrade and install AutoRCM, you can also keep your fuses from being burnt, allowing you a downgrade path. However, this method requires you to keep AutoRCM installed indefinitely.

    Since your Switch is vulnerable to the RCM exploit, you will forever be able to launch RCM payloads, no matter the system version. As of this post, CFW is compatible with every system version except 7.0.0.
     
  3. Eds89

    Eds89 Member

    Newcomer
    1
    Sep 6, 2018
    United Kingdom
    I see Rocket League needs 4.0, but wondering if anyone can confirm if this is also true for the collectors edition?
     
  4. Staark

    Staark Newbie

    Newcomer
    2
    Sep 8, 2018
    United Kingdom
    Does anyone know what version Trials Rising requires?
     
  5. mikeniccy
    This message by mikeniccy has been removed from public view by porkiewpyne, Mar 2, 2019.
    Mar 2, 2019
  6. rommy667

    rommy667 GBAtemp Advanced Fan

    Member
    4
    Mar 21, 2008
    Down the road around the corner
    Trials Rising base works on 6.20 for sure idk about after any update.........
     
  7. j0hnnyj0hns

    j0hnnyj0hns GBAtemp Regular

    Member
    3
    Jun 3, 2016
    United States
    Super Mario Deluxe U 4.1.0 or no?? My switch hasn't been modded or updated since i got it and i'm wanting to buy that game if it works on 4.1.0

    — Posts automatically merged - Please don't double post! —

    Can you post a pic showing installed on 4.1.0 please :)
     
  8. michaelpatko

    michaelpatko Member

    Newcomer
    1
    Dec 25, 2018
    United States
    I am on OFW 4.1.0
    I am using SX OS 2.5.3
    I used XCI cutter to split Civilization 6 into 4GB pieces.
    I installed it via SX OS, and it said successful.
    Won't launch.
    Does it require a FW higher than 4.1.0?
    Thanks y'all
     
  9. XaneTenshi

    XaneTenshi GBAtemp Fan

    Member
    4
    Nov 24, 2013
    Denmark
    I don't know for sure what the required FW is, but comparing the release date for the Switch version with the Nintendo FW update history, it's pretty safe to assume that the game requires atleast 5.1, and possibly 6.0.
     
  10. RampageZA

    RampageZA Newbie

    Newcomer
    1
    Jan 9, 2019
    South Africa
    — Posts automatically merged - Please don't double post! —
     
  11. CrisFTW

    CrisFTW Your Excellency

    Member
    5
    Jan 10, 2016
    United States
    Why is this thread alive? The OP doesn't even care to update the list
     
  12. XTRIPLEX_EOL

    XTRIPLEX_EOL Newbie

    Newcomer
    1
    Sunday
    Spain
    In nswdb dot com you can check the required firmware version for each game.

    This thread is useless and out of date.
     
    nutsack likes this.
  13. XaneTenshi

    XaneTenshi GBAtemp Fan

    Member
    4
    Nov 24, 2013
    Denmark
    Yep, you are totally right!!!! That site is awesome!!! First game I check with the site and it doesn't tell me **** about the FW requirement...

    Yes, brilliant indeed...

    .

    ..

    ...

    Alright, just needed to get that out there. I've checked a few other titles for the heck of it, and FW requirement shows up just fine for those.
     
Loading...