1. Romreactor

    Romreactor Member
    Newcomer

    Joined:
    Feb 7, 2019
    Messages:
    23
    Country:
    United States
    Hold up, you're telling me I can download a pirated copy of Astrol Chains now and then without even having a cartridge side load it to a micro sd card and play it on a Switch with an upgraded version to the games required version using ChoiDojourNX?
     
  2. Draxzelex

    Draxzelex GBAtemp Legend
    Member

    Joined:
    Aug 6, 2017
    Messages:
    11,068
    Country:
    United States
    Well...yes. Piracy has been possible on the Switch for over a year, for both paid-for and free CFW.
     
  3. Romreactor

    Romreactor Member
    Newcomer

    Joined:
    Feb 7, 2019
    Messages:
    23
    Country:
    United States
    A little confused now since I read a thread where people were able tp use goldlief to run Astral Chains which requires version 8.0.1 but they ran it on Goldlied 7.0 with the option to ignore required firmware turned on. Do I basically just need to install Goldlief or is it best to use ChoiDojourNX update from 4.1.0 to 8.1.0 and just buy the game and play it with its updated patch?
     
  4. Draxzelex

    Draxzelex GBAtemp Legend
    Member

    Joined:
    Aug 6, 2017
    Messages:
    11,068
    Country:
    United States
    What I'm saying is I have no idea what firmware Astral Chain requires but you can use NSC_Builder to check since there is no list that is up-to-date anymore for these types of questions.
     
    Romreactor likes this.
  5. Romreactor

    Romreactor Member
    Newcomer

    Joined:
    Feb 7, 2019
    Messages:
    23
    Country:
    United States
    The users in the thread about Astral Chains firmware confirmed it came with firmware update 8.0.1 in the box and then once connected online it requested to update to 8.1.0 including patching the game. But once my PC is operational next month I will download this desktop tool as I doubt its availble for mac.
     
  6. chippy

    chippy GBAtemp Fan
    Member

    Joined:
    Dec 21, 2017
    Messages:
    306
    Country:
    Australia
    @Romreactor there are 2 things about running games on lower firmware
    1 the value set in the game
    2 the sdk version to compile it

    You can I stall a game saying it needs 8.10 by using the ignore firmware version that's the first point above. But if the sdk used has components from 7.0you can't run it on anything below 7 as it will error out

    Now if you use the windows app switch backup manager it will tell you the sdk version (and lowest system version that can play) and the files listed system version needed (which can be ignored)
     
    Romreactor likes this.
  7. PitPitPit

    PitPitPit GBAtemp Regular
    Member

    Joined:
    Jan 18, 2017
    Messages:
    117
    Country:
    Gambia, The
    Do you guys think that Link's Awakening will require FW 9.0.0?
     
  8. KnightRiderX420

    KnightRiderX420 The Anigmatic Anomoly
    Member

    Joined:
    Nov 24, 2018
    Messages:
    149
    Country:
    United States
    not sure if this should go here but i have a game that on atmo9.4 firm9.0 loads gets to startup screen and then says press a to start. the buttons do nothing, almost as if the issue mentioned in the announcement also affects some games as well as homebrew apps. my question is if that's the case what firmware does run this game? "the lost child"
     
  9. hippy dave

    hippy dave BBMB
    Member

    Joined:
    Apr 30, 2012
    Messages:
    5,650
    Country:
    United Kingdom
    In case you didn't see it yet, there's an updated build of atmosphere 0.9.4 that sounds like it should fix this issue, redownload it from the releases page.
     
  10. Draxzelex

    Draxzelex GBAtemp Legend
    Member

    Joined:
    Aug 6, 2017
    Messages:
    11,068
    Country:
    United States
    Games are not going to require firmware 9.0 until the next firmware update or after a few months have passed, whichever comes first.
     
    PitPitPit likes this.
  11. tempestry

    tempestry Newbie
    Newcomer

    Joined:
    Sep 20, 2019
    Messages:
    2
    Country:
    India
    I can confirm New Super Mario Bros. U Deluxe requires 4.1.0 and comes with an update for that version. I had 3.0.2 stock and never connected my Switch to the Internet and it updated to that version automatically.
     
  12. tempestry

    tempestry Newbie
    Newcomer

    Joined:
    Sep 20, 2019
    Messages:
    2
    Country:
    India
    Can also confirm Link's Awakening requires 8.0.1 and comes with an update for it.
     
    Last edited by tempestry, Sep 27, 2019
  13. FanNintendo

    FanNintendo GBAtemp Advanced Fan
    Member

    Joined:
    Apr 16, 2018
    Messages:
    689
    Country:
    United States
    Please update the List Games required firmware looks like it hasnt been update in year
     
  14. Resaec

    Resaec GBAtemp Fan
    Member

    Joined:
    Dec 19, 2017
    Messages:
    399
    Country:
    Germany
    There is no way anyone could keep the list up to date now.
    There are too many games and the reason for the existence of this list also does not exits anymore.

    Please stop asking for it.
     
    hippy dave and FunThomas like this.
  15. Draxzelex

    Draxzelex GBAtemp Legend
    Member

    Joined:
    Aug 6, 2017
    Messages:
    11,068
    Country:
    United States
    To add onto what Resaec said, there are multiple tools that allow you to check the game's required firmware version (as well as patch it to that firmware) making lists like these pointless.
     
  16. lexluth0r

    lexluth0r GBAtemp Regular
    Member

    Joined:
    Aug 5, 2011
    Messages:
    236
    Country:
    United States
    Ghostbusters with update requires 9.0 idk about without update
     
  17. JFizDaWiz

    JFizDaWiz GBAtemp Regular
    Member

    Joined:
    Jun 6, 2014
    Messages:
    128
    Country:
    United States
    according to my NSP, the base game requires 8.0.0
     
  18. lexluth0r

    lexluth0r GBAtemp Regular
    Member

    Joined:
    Aug 5, 2011
    Messages:
    236
    Country:
    United States
    Ok awesome so I’ll just delete the update
     
  19. dxxshore

    dxxshore Advanced Member
    Newcomer

    Joined:
    Oct 4, 2019
    Messages:
    55
    Country:
    United States
    Seems groove coaster wai wai party!!! Requires 9.0.1, I just patched it for 8.1.0.
     
Draft saved Draft deleted
Loading...

Hide similar threads Similar threads with keywords - required, Firmware, version