JenesisDS & nesDS Not Working [AK2]

Discussion in 'Acekard' started by [M]artin, Jul 27, 2008.

Jul 27, 2008
  1. [M]artin
    OP

    Member [M]artin .

    Joined:
    Nov 7, 2006
    Messages:
    3,658
    Country:
    United States
    Hey gang, I've been having trouble with two fine pieces of homebrew, JenesisDS and nesDS, on my Acekard 2.

    JenesisDS starts up fine, I enter the applications rom select menu, and select a rom. The rom loads up but hangs a black top screen. Everything freezes from this point, with every rom tried, even ones that have been confirmed to work. It should also be noted that the touch screen functions don't work, either.

    nesDS starts up normally, but once I reach the point in which I have to locate a rom (directory browser) it's already frozen. I can't even move up or down to select the directory.

    I thought the AK2 was supposed to auto-DLDI patch homebrew on-the-fly, since I couldn't find a DLDI manual patch file for the AK2 anywhere.

    I tried several things, such as moving the roms from the root to their own separate folder and even disabling all AK2 OS patches, but neither made a difference.

    Any possible solutions? (I'm on AKAIO v1.1)
     
  2. Raki

    Member Raki GBAtemp Advanced Fan

    Joined:
    Jul 16, 2008
    Messages:
    554
    Country:
    Germany
    just for your information: The DLDI patch is located in the __aio folder and is called something like ak2_sd.dldi
     
  3. golden

    Member golden What a Digital Dummy!!!

    Joined:
    Dec 1, 2007
    Messages:
    1,453
    Country:
    United States
    Try AKAIO 1.0 to see if it's the firmware. I have 1.0 on RPG and nesDS works fine. If not then maybe you should reformat your SD? Sorry, I haven't had any problems at all. It might be the firmware.
     
  4. Smiths

    Member Smiths AKAIO Person of Interest

    Joined:
    Feb 24, 2003
    Messages:
    1,318
    Location:
    The land of Dairy Queen
    Country:
    United States
    just tested NESDS here on my AK2. Almost concurred in a freeze. Launched it normally without any nes games on my card, just put nesds.nds on card. it launched fine and i could browse.

    Put a .nes game on my card, launched newDS again.. froze immediately. went "wtf?"... i put the rom on the card again, overwriting the old one, booted nesDS again and it was fine.

    So I had a lockup.. but once. No idea why but it did work.
     
  5. [M]artin
    OP

    Member [M]artin .

    Joined:
    Nov 7, 2006
    Messages:
    3,658
    Country:
    United States
    Okay, this is reaaaaaaly weird...

    First I formatted my card and tried again, still nothing.

    I eventually got nesDS working on AKAIO v1.1, but only through trial and error. First, I patched both nesDS and JenesisDS manually on my PC and then copied them over. I discovered that nesDS would only let me browse and run roms without instant freeze by having really specific settings...

    I kept all files from original AKAIO v1.1 download intact (didn't delete any skin folders). nesDS would only run IF all Patch settings were "Disabled" and my skin was the original download default skin (Adv. Evo). If I enabled any patches while keeping Adv. Evo, nesDS froze. If I kept all patches disabled but changed the skin (I changed to "Black"), nesDS froze. I even tried editing the globalini to have the default set to "Black" but it still wouldn't work. JenesisDS just flat out froze, the same way as before, even with the settings that made nesDS work... [​IMG]

    Testing now with AKAIO v1.0 to see if it makes a difference... [​IMG]

    EDIT: AWESOME! WHAT A BREAKTHROUGH!!!

    So, I deleted the AKAIO v1.1 files from my MicroSD and replaced them with the AKAIO v1.0 files (thx golden!) and booted up my AK2. Upon booting up, I tried both nesDS AND JenesisDS right away. BOTH WORKED, NO FREEZES OR SLOWDOWNS! I also went back to the AK2 OS menu's and played around with both patching AND different skin combinations. Both apps worked with EVERY combination I tried! I even went back afterwords and deleted every other skin folder other than "Black" and made it my default. Both apps still worked!

    This seems very odd, since it worked for Smiths but not me... [​IMG]

    Anyway, hopefully this can be noted and taken into consideration for the next release of AKAIO. I think I'm gonna have to stay with 1.0 right now until these apps can work for me in a future release (I really love the additions to 1.1 [​IMG]).

    And one question I just wanna throw out there, why was "In-Game Slow Motion" removed from 1.1?
     
  6. Smiths

    Member Smiths AKAIO Person of Interest

    Joined:
    Feb 24, 2003
    Messages:
    1,318
    Location:
    The land of Dairy Queen
    Country:
    United States
    i don't like including it in the zip but some people wanted it, but i seriously don't approve of copying a pre-built globalsettings.ini to the card esp with new releases.

    not saying this will in any way fix these weird bugs... just saying in general.
    does simply replacing the akmenu4.nds and not the entire dir structure fix anything?
     
  7. [M]artin
    OP

    Member [M]artin .

    Joined:
    Nov 7, 2006
    Messages:
    3,658
    Country:
    United States
    Ah, it's cool, never actually tried the SloMo, was just curious why it went missing...

    You're saying for me to try an _AIO folder from v1.1 and a akmenu4.nds file from v1.0?

    EDIT: Tried it...
    And everything works fine and normally. I am missing all of the features that were added in 1.1, though, it stays with the 1.0 settings.

    DOUBLE EDIT:
    Also tried using a _aio folder from 1.1 BUT deleted the globalsettings.ini and used a akmenu4.nds from 1.1 too. I just got the same results as before, however, nesDS ran, but JenesisDS froze.

    TRIPLE EDIT:
    Phew! Smiths and I finally got to the bottom of the problem after a good while. It turns out the problem isn't AKAIO v1.1, but rather the JenesisDS 0.74 release. However, if you use the release that came out right before that (v 0.7) it works fine on AKAIO v1.1

    nesDS works fine on all [​IMG]
     

Share This Page