Is it worth upgrading my DSi?

Discussion in 'NDS - Flashcarts and Accessories' started by TomB.Zmbie, Jun 28, 2012.

  1. TomB.Zmbie
    OP

    TomB.Zmbie Newbie

    Newcomer
    1
    0
    Jun 28, 2012
    I have had my DSi for a couple of years. According to system settings it's 1.4E. I've never updated it since I bought it.

    All I use my DSi for is games, and 99% of the time they're played from my DSTWO (I also own an Acekard2i but never really use it, the DSTWO is just better.). Is there any reason I should ever need to upgrade it?

    As far as I can tell, it'd offer me nothing and potentially cause my DSTWO to stop working? I just can't see any reason I'd ever need to. I guess I can't understand: why do people care about flashcarts working on the latest version so much?
     
  2. EyeZ

    EyeZ GBAtemp Addict

    Member
    2,496
    523
    Dec 4, 2009
    It's only worth updating your DSi if you intend using the eshop.

    If that's the case then wait until your flashcart gets an update file before you update your DSi.
     
  3. VMM

    VMM Hamon > Stand

    Member
    GBAtemp Patron
    VMM is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    3,107
    1,003
    Jul 1, 2010
    Brazil
    You can find the latest DSi update for DSTwo here:
    http://down.supercard.sc/download/dstwo/Firmware/Firmware_v1.15_eng.zip
    Just copy the files inside the zip and paste into the root of your MicroSD
    After updating, your DStwo will work on the latest version of DSi, 1.4.4,
    but I'd wait untill they release the next update, wich should occur in the next days