How to update boot9strap v1.0→v1.1

Discussion in '3DS - Flashcards & Custom Firmwares' started by Peter_JKC, Jun 4, 2017.

  1. Peter_JKC
    OP

    Peter_JKC Member

    Newcomer
    22
    9
    Jan 21, 2017
    China
    l have updated from A9LH to B9S by using boot9starap v1.0 and now the boot9strap v1.1 have been released. However how could l update to boot9strap v1.1
     
  2. lone_wolf323

    lone_wolf323 GBAtemp Advanced Fan

    Member
    825
    275
    May 27, 2011
    Canada
    It states that we should wait for a bit before updating our systems to v1.1. At this time I wouldnt worry about the update until everythings been ironed out with it
     
    Pyra likes this.
  3. JerryShaw

    JerryShaw GBAtemp Regular

    Member
    113
    9
    Feb 7, 2017
    Switzerland
    Someone met an error when using 1.1. I am still waiting for guide.
     
  4. Ryumaru

    Ryumaru Creator of themes for 3DS

    Member
    2,431
    1,062
    Feb 1, 2015
    Brazil
    The installer has update function ?
     
  5. Lilith Valentine

    Lilith Valentine GBATemp's Wolfdog™ ☠️Grunt☠️

    Member
    20,197
    21,576
    Sep 13, 2009
    Antarctica
    Between insane and insecure
    Literally the same way you installed it is how you upgrade.
     
  6. Ryumaru

    Ryumaru Creator of themes for 3DS

    Member
    2,431
    1,062
    Feb 1, 2015
    Brazil
    It's safe to update it now ?
     
  7. Lilith Valentine

    Lilith Valentine GBATemp's Wolfdog™ ☠️Grunt☠️

    Member
    20,197
    21,576
    Sep 13, 2009
    Antarctica
    Between insane and insecure
    I won't suggest it if you don't know what you are doing or have doubt.
     
  8. Ryumaru

    Ryumaru Creator of themes for 3DS

    Member
    2,431
    1,062
    Feb 1, 2015
    Brazil
    I'll wait for some tutorial done by @Plailect.
     
  9. izeelil

    izeelil Newbie

    Newcomer
    6
    0
    Sep 14, 2009
    I have succesufully updated with already existing safe installer. Everytime it boots, it shows An error occured: unsupported launcher (argc =8), maybe it luma fails...
     
  10. Ryumaru

    Ryumaru Creator of themes for 3DS

    Member
    2,431
    1,062
    Feb 1, 2015
    Brazil
    You already have boot9strap 1.0 or are trying to pass from A9LH to boot9strap.
     
  11. phalk

    phalk Handheld Maniac

    Member
    433
    266
    Apr 23, 2009
    Brazil
    I've already updated mine. You'll need an updated build of Luma (nighly) too or otherwise it wouldn't work.
    Just update it with SafeB9SInstaller and the latest build of B9S.
     
  12. OperationNT

    OperationNT GBAtemp Regular

    Member
    128
    136
    May 1, 2016
    France
    Yes, Luma3DS waits for a maximum of 2 start arguments (to detect if it is loaded from SysNAND or SD card). By reading the B9S v1.1 description, it seems that new arguments has been added (for framebuffers) so this is why Luma3DS loading fails.
     
  13. izeelil

    izeelil Newbie

    Newcomer
    6
    0
    Sep 14, 2009
    I've updated from 1.0 to 1.1, and then i've occured an error, latest luma hourly build had fixed that
     
  14. fille

    fille GBAtemp Regular

    Member
    195
    47
    Mar 28, 2014
    Belgium
    somewhere
    yep,it worked fine.
     
  15. izeelil

    izeelil Newbie

    Newcomer
    6
    0
    Sep 14, 2009
    Godmode and decrypt app is also not working
     
  16. Ryumaru

    Ryumaru Creator of themes for 3DS

    Member
    2,431
    1,062
    Feb 1, 2015
    Brazil
    I believe these applications will be updated to support version 1.1.
     
  17. zaqqaz00

    zaqqaz00 Advanced Member

    Newcomer
    75
    23
    Jul 17, 2010
    United States
    Dallas
    GodMode9 v1.2.1 will work, the rest are broken with B9S 1.1
     
  18. RosaliinaDaHacker64

    RosaliinaDaHacker64 3DS font intermediate/expert

    Member
    621
    322
    Oct 7, 2015
    Ireland
    F:\gm9\out
    I ain't updating to b9s 1.1 yet