[Help] Recompiled AS ROM stuck on loading screen

Discussion in '3DS - ROM Hacking, Translations and Utilities' started by Antechinus, Mar 20, 2015.

  1. Antechinus
    OP

    Antechinus Newbie

    Newcomer
    3
    0
    Mar 20, 2015
    I've been trying to decrypt, extract and recompile Pokémon Alpha Sapphire so that I can randomise the encounters. Without editing any files at all, however, my recompiled ROM just hangs on the loading screen with the 3DS logo and the red waves on a black screen. The untouched ROM, freshly dumped with Gateway, loads just fine.

    I have tried
    • deleting the save game on the cartridge (down + B + X).
    • dumping the ROM again.
    • decrypting with XORpads, as per this guide.
    • decrypting with rxTools and extracting.
    • using ExInjector.
    I've got sysnand 9.2 and emunand 9.5. As far as I can tell, the game has no updates or patches, at least according to the Data Management section of the settings. I figure there has to be some blindingly obvious thing I'm missing here. Unfortunately, I have no other cartridges at hand to test. Does anyone have any ideas?
     
  2. Crowhogan33

    Crowhogan33 Member

    Newcomer
    14
    1
    Aug 23, 2014
    United States
    Dumped my OR and edited it and I recompiled it and I'm also stuck on the 3ds loading screen, and I've gone through the process like 5 times and I can't figure out what's causing it. I thought it might've been my emunand but I updated that and it still wasn't working. I've also tried everything you've tried, minus wiping my save game.

    I'm on 9.0 with 9.5 emunand n3ds.
     
  3. Crowhogan33

    Crowhogan33 Member

    Newcomer
    14
    1
    Aug 23, 2014
    United States
    I was able to get it to run after updating the rom to 1.2. Hope it helps!
     
  4. Apache Thunder

    Apache Thunder I have cameras in your head!

    Member
    4,122
    4,074
    Oct 7, 2007
    United States
    Levelland, Texas
    Did you try using ExInjector to reinject the exheader.bin file into the new rom? You should be able to run it without the patch. The patch overwrites certain things like game text. ;)
     
  5. Crowhogan33

    Crowhogan33 Member

    Newcomer
    14
    1
    Aug 23, 2014
    United States
    That was one of the things I tried yesterday. I didn't try it with the one that runs currently, I'm just glad its running. I didn't edit the game text, so it's not a big deal.
     
  6. Antechinus
    OP

    Antechinus Newbie

    Newcomer
    3
    0
    Mar 20, 2015
    I'm afraid using ExInjector doesn't change anything. To be certain I tried again with a fresh exheader.bin extracted using the nifty tool in this thread. Fortunately, patching the game did make it load, thank you! All I wanted was to randomise encounters, so I think that won't cause any problems. I suspect the issue is related to the rsf file.
     
  7. OmegaPikachu

    OmegaPikachu GBAtemp Regular

    Member
    273
    56
    Mar 9, 2015
    United States
    I'm having this same issue!

    Anyone wanna shed some light on it?

    Except when i update i get blackscreened after the logo
     
  8. Asia81

    Asia81 In my Ecchi World <3

    Member
    5,147
    2,565
    Nov 15, 2014
    France
    Albi
  9. OmegaPikachu

    OmegaPikachu GBAtemp Regular

    Member
    273
    56
    Mar 9, 2015
    United States
  10. Asia81

    Asia81 In my Ecchi World <3

    Member
    5,147
    2,565
    Nov 15, 2014
    France
    Albi
    I can make the video now, bot not upload it before Monday or Monday+1
     
  11. OmegaPikachu

    OmegaPikachu GBAtemp Regular

    Member
    273
    56
    Mar 9, 2015
    United States

    Im sure alot of people will appreciate it!

    thank you
     
  12. laramie

    laramie GBAtemp Advanced Fan

    Member
    502
    162
    Dec 15, 2014
    United States
    I fixed this, All I did was inject the decrypted ex"Header.bin into the rom, no updates, and everything worked. I'll try and redo the whole process later and see if it works, if so I would most likely assume that would be the fix.
     
  13. OmegaPikachu

    OmegaPikachu GBAtemp Regular

    Member
    273
    56
    Mar 9, 2015
    United States
    I got mine to work last night as well.
     
  14. laramie

    laramie GBAtemp Advanced Fan

    Member
    502
    162
    Dec 15, 2014
    United States
    Using the same way as me?
     
  15. OmegaPikachu

    OmegaPikachu GBAtemp Regular

    Member
    273
    56
    Mar 9, 2015
    United States

    nope. someone gave me the tip to use the updated nnchinfo_gen.py with rxTools, I did that and everything else just went smoothly after that
     
  16. laramie

    laramie GBAtemp Advanced Fan

    Member
    502
    162
    Dec 15, 2014
    United States

    Hmmm Nice! I used "rom editing made easy over 7.x" from rom editing made easy.
     
  17. laramie

    laramie GBAtemp Advanced Fan

    Member
    502
    162
    Dec 15, 2014
    United States
  18. Mike Tukes

    Mike Tukes Newbie

    Newcomer
    1
    0
    Nov 14, 2015
    United States
    You are the man! Thanks!