Question GoldLeaf Errors

Discussion in 'Switch - Emulation, Homebrew & Software Projects' started by jellybeangreen2, Mar 30, 2019.

  1. jellybeangreen2
    OP

    jellybeangreen2 GBAtemp Advanced Fan

    Member
    6
    Dec 9, 2015
    United States
    I have two NSP's which both give me error:0x236e02

    Module: FS (2)

    Description: invalid PFS0 (NSP) (4535)



    Any ideas what the problem could be? - Switch firmware is 5.1.0.
     
  2. hippy dave

    hippy dave BBMB

    Member
    15
    Apr 30, 2012
    United Kingdom
    Bad NSP? If you've verified that they're good, maybe they're too new & 5.1.0 doesn't have the necessary masterkey for them? Did you look in the goldleaf thread for that error number?
     
  3. XorTroll

    XorTroll Tired of classic HOME menu

    pip Developer
    12
    Dec 28, 2017
    Spain
    Nowhere
    I get the same error for one or two specific NSPs. Probably the NSPs have something which makes them invalid for the console, but what the error says, invalid NSPs.
     
  4. Elalexyzoner

    Elalexyzoner Alex95

    Member
    4
    Jun 5, 2016
    Mexico
    Near Texas
    Hi, i was installing some NSP's yesterday through 0.5 GoldLeaf, everything went fine but only 1 issue, the DLC's NSP's where not installed at all, don't know if it only happens to me, (that NSP's sizes were small, like 128 kb)
     
  5. toxic9

    toxic9 GBAtemp Advanced Fan

    Member
    4
    Dec 13, 2016
    You have to exit the application and start it again. Then you can install. It's an issue I found some time ago. It happens with tiny dlc's
     
  6. jellybeangreen2
    OP

    jellybeangreen2 GBAtemp Advanced Fan

    Member
    6
    Dec 9, 2015
    United States
    Thanks for replying to my thread @XorTroll - The NSP's are both valid. - obtained from two different sources and the MD5 checks out. - I wonder if it is because I am on 5.1.0? they are genuine and not converted.

    Thanks for the other comments guys
     
  7. XorTroll

    XorTroll Tired of classic HOME menu

    pip Developer
    12
    Dec 28, 2017
    Spain
    Nowhere
    I am on 5.1.0 too :P

    — Posts automatically merged - Please don't double post! —

    Small DLC like Rocket League's one usually is a few KBs FYI
     
  8. hippy dave

    hippy dave BBMB

    Member
    15
    Apr 30, 2012
    United Kingdom
    Do you get a different error if the nsp needs a higher masterkey than your current fw?
     
  9. jellybeangreen2
    OP

    jellybeangreen2 GBAtemp Advanced Fan

    Member
    6
    Dec 9, 2015
    United States
    This is what I'm wondering. - Currently backing up my Micro SD (256GB) so its going to take an hour! - I will set up EmuNAND and test again.. - I did convert NSP to XCI and change the keygen to 5.x but still didn't work. I do have a feeling it is related to 7.x. Once set up I will reply back.
     
  10. XorTroll

    XorTroll Tired of classic HOME menu

    pip Developer
    12
    Dec 28, 2017
    Spain
    Nowhere
    The nsp doesn't store the keygen...? That is what happens with ncas
     
    hippy dave likes this.
  11. hippy dave

    hippy dave BBMB

    Member
    15
    Apr 30, 2012
    United Kingdom
    Ok makes sense.
     
  12. jellybeangreen2
    OP

    jellybeangreen2 GBAtemp Advanced Fan

    Member
    6
    Dec 9, 2015
    United States
    I understand the decryption of the NCA with X key. However, when you can change the minimum system version on a certain NSP; why does it ask for the master key? This would give the impression that not all modules are decrypted?
     
  13. Sumandora

    Sumandora Im using Parental Controls. Change my Mind!

    Member
    4
    Nov 13, 2018
    Germany
    enough space?
     
  14. jellybeangreen2
    OP

    jellybeangreen2 GBAtemp Advanced Fan

    Member
    6
    Dec 9, 2015
    United States
    Yep

    — Posts automatically merged - Please don't double post! —

    To update everyone, I set up emunand. Then updated emunand to 7.0.1. The two NSP installed fine. Goldleaf reports it to be keygen8. Which explains maybe why it couldn’t boot on 5.1.0. - I also tested my converted XCI for 5.1.0, doesn’t work on 5.1.0 but works on 7.0.1. There must be dependancies for 7.x
     
    gizmomelb likes this.
  15. TerminatR

    TerminatR Advanced Member

    Newcomer
    5
    Nov 21, 2006
    Canada
    Did this ever get resolved?

    I have the same issue.
     
  16. jellybeangreen2
    OP

    jellybeangreen2 GBAtemp Advanced Fan

    Member
    6
    Dec 9, 2015
    United States
    goldleaf is the problem unfortunately. A new tool reNXpack is a solution. Or use SXOS emuNAND and install the latest firmware on the emuNAND so you don’t have to patch a game each time
     
    Last edited by jellybeangreen2, Apr 14, 2019
    jug5 likes this.
  17. jug5

    jug5 Newbie

    Newcomer
    1
    Apr 29, 2019
    United States
    Thanks for two working solutions @jellybeangreen2, reNXpack was new to me and solved the problem. Also tried the emunand with $latest and that worked as well.
     
    jellybeangreen2 likes this.
  18. jellybeangreen2
    OP

    jellybeangreen2 GBAtemp Advanced Fan

    Member
    6
    Dec 9, 2015
    United States
    Glad both solutions worked for you.
     
Quick Reply
Draft saved Draft deleted
Loading...