Getting "an error has occurred, forcing the software to close" - how to fix?

Discussion in '3DS - Flashcards & Custom Firmwares' started by Berabouman, Nov 11, 2014.

  1. Berabouman
    OP

    Berabouman Advanced Member

    Newcomer
    61
    3
    Jun 4, 2013
    United States
    Before you ask, yes I have Googled this and searched the forums, but there is so much information that I found it bewildering, so I have decided to ask this here again for clarification. Sorry if it clutters up the forums. [/COLOR][/FONT][/SIZE]
    [SIZE=2][FONT=Verdana][COLOR=#ffffff][/COLOR][/FONT][/SIZE]
    [SIZE=2][FONT=Verdana][COLOR=#ffffff]This morning I decided to change my birthday on the 3DS to benefit from some items in Super Mario Dream Team Brothers, but after that I got the error when I tried to start the game. I tried changing the birthday back and the system date as well, but no matter what I do the error appears after I select Nintendo DS Profile.[/COLOR][/FONT][/SIZE]
    [SIZE=2][FONT=Verdana][COLOR=#ffffff][/COLOR][/FONT][/SIZE]
    [SIZE=2][FONT=Verdana][COLOR=#ffffff]What can I do to solve the problem? I do not have the blue or red card with me now as I am on holiday. Can I simply replace the launcher.dat with a new one from the Gateway homepage? I don't know which Gateway firmware I am currently using since I can't access it right now. Unless I can access Gateway mode to discover - but I don't know how to do that either.[/COLOR][/FONT][/SIZE]
    [SIZE=2][FONT=Verdana][COLOR=#ffffff][/COLOR][/FONT][/SIZE]
    [SIZE=2][FONT=Verdana][COLOR=#ffffff]Would I need to use the blue/red cards to update my firmware entirely/format the SD card? Or can I just replace the launcher.dat with a new one or one that is the same firmware as my current Gateway installation?[/COLOR][/FONT][/SIZE]
    [SIZE=2][FONT=Verdana][COLOR=#ffffff][/COLOR][/FONT][/SIZE]
    [SIZE=2][FONT=Verdana][COLOR=#ffffff]Also, is there any way to change the time and date/birthday on the 3DS without running into this problem again?[/COLOR][/FONT][/SIZE]
    [SIZE=2][FONT=Verdana][COLOR=#ffffff][/COLOR][/FONT][/SIZE]
    [SIZE=2][FONT=Verdana][COLOR=#ffffff]Thanks in advance![/COLOR][/FONT][/SIZE]
     


  2. Oishikatta

    Oishikatta GBAtemp Advanced Fan

    Member
    971
    545
    Oct 30, 2014
    United States
    You need to re-install the exploit using the blue card or any DS flash card that works in your sysnand version. You can't use emunand again until you have access to a ds flash card to install the exploit.
     
  3. Berabouman
    OP

    Berabouman Advanced Member

    Newcomer
    61
    3
    Jun 4, 2013
    United States
    Thanks for the quick response! The exploit isn't tough to install is it? Is there any chance of bricking? (I had a friend do it for me the last time so I can't remember how it went)
     
  4. Oishikatta

    Oishikatta GBAtemp Advanced Fan

    Member
    971
    545
    Oct 30, 2014
    United States
  5. piratesephiroth

    piratesephiroth I wish I could read

    Member
    3,002
    1,619
    Sep 5, 2013
    Brazil
    It's more likely that you deleted Launcher.dat from your SD card
     
  6. piratesephiroth

    piratesephiroth I wish I could read

    Member
    3,002
    1,619
    Sep 5, 2013
    Brazil
    If you see the error message then the exploit is still installed but it couldn't find Gateway's launcher
     
  7. Sorox

    Sorox Master Firo Soul

    Member
    828
    75
    Jul 8, 2008
    United States
    Im just gonna get this outta the way;

    There's a chance your GW card is faulty.
    I had the same error about 6 months back with my first GW card. Could get it to work more consistently by applying minimal pressure between the MicroSD card and the contacts on the card, but only a little more consistently.

    In the end, though, I just ended up buying a new card. Having a card that actually worked 95% of the time was better than a card that worked 15% of the time.

    EDIT: also, for whatever reason, original post is all white on my screen. Had to highlight to even read the original post. Reloaded the page, but its the same.
     
  8. tbb043

    tbb043 Member

    Member
    1,044
    460
    Jan 30, 2008
    United States
    Yeah, don't write in all white text. Also don't write in a dark text or people will bitch endlessly about the dark theme not being able to read it. Basically don't change the font color from default unless you REALLY need to.


    As for this error, try removing and inserting the Gateway a few times. I've had this error once in a great while and that can help it to get running. You shouldn't need to rerun the exploit though, unless you've done something in DS mode.
     
  9. piratesephiroth

    piratesephiroth I wish I could read

    Member
    3,002
    1,619
    Sep 5, 2013
    Brazil
    With me, when there's a problem with Gateway's contacts it simply crashes when entering emunand.
     
  10. Berabouman
    OP

    Berabouman Advanced Member

    Newcomer
    61
    3
    Jun 4, 2013
    United States
    I have no idea why my original post is all in white text either, I copy-pasted it from Notepad if that makes a difference. I went into edit and did it again but it still comes out all white for some reason. Sorry if it caused anyone any trouble. :(

    Well my card was working fine until I changed the date and time, so I doubt it is a problem with the GW card itself. I changed it twice just to be sure (took it out and put it in) My launcher.dat is also still on the microSD.

    I've read the tutorial and it says that I have to reformat the microSD card? So I just take out my games and saves and put them back in later right?

    Also, do I have to change the time and date to anything to get it to work? I set everything back (birthday and date) to 1/1/2013.
     
  11. AlbertoSONIC

    AlbertoSONIC Pasta Team Member

    Member
    929
    1,223
    Jun 27, 2014
    Italy
    Man you have to install Gateway Exploit again. No, i'm not talking about the Launcher.dat. You have to use Gateway Installer.nds on a DS flashcart (like Gateway Blue) and it will get to work again.

    Remember that once you change some profile settings, you have to reinstall gateway exploit again.
     
  12. piratesephiroth

    piratesephiroth I wish I could read

    Member
    3,002
    1,619
    Sep 5, 2013
    Brazil
    I think it's a hardware issue. You can't have a partial exploit installed. You either go to the NDS profile settings (because you did something that caused the settings to be corrected, like running a DS game or editing the NDS wireless connections) or you launch Gateway.
     
  13. AlbertoSONIC

    AlbertoSONIC Pasta Team Member

    Member
    929
    1,223
    Jun 27, 2014
    Italy
    That's not true. You can corrupt your Gateway Profile Exploit by changing a profile setting (name, birthday, city). Almost everything you can set from 3DS Profile Settings. (Not DS Profile settings!)

    If it was a Gateway Cartridge hardware issue, you would still be able to run Launcher.dat (by pressing L + DS Profile)
    If it was a Launcher.dat issue, it should hang just as it is. No errors. If it gives you an error then this means that the 3ds is able to handle it.... So it isn't an exploit!
     
  14. gamesquest1

    gamesquest1 Nabnut

    Member
    14,120
    9,456
    Sep 23, 2013
    well in actual fact if you mess up the exploit(including installing the wrong rop loader, or as you said changing settings on the 3ds like DOB etc), a missing launcher.dat, faulty SD card all give the exact same error when you try to launch the exploit

    a faulty gateway card would just take you to the gateway menu and say card not detected and not let you enter gateway mode or just not work properly once in gateway mode

    so its going to be one of the first things most likely
     
  15. AlbertoSONIC

    AlbertoSONIC Pasta Team Member

    Member
    929
    1,223
    Jun 27, 2014
    Italy
    ... I'll try to corrupt it once i get home and i'll report back ;)
     
  16. gamesquest1

    gamesquest1 Nabnut

    Member
    14,120
    9,456
    Sep 23, 2013
    it does all just lead to "an error has occured forcing the software to close, The system will now restart" just doubled checked it by changing the DOB, exact same error as if you try running the gateway launcher on the homebrew rop loader or if you have no launcher.dat on the SD card
     
    AlbertoSONIC likes this.
  17. AlbertoSONIC

    AlbertoSONIC Pasta Team Member

    Member
    929
    1,223
    Jun 27, 2014
    Italy
    Alright, so now it's time to find the issue between:
    1)Corrupted Exploit
    2)No Launcher.dat into SDCard root
    3)Fault SDCARD.

    I think @OP should begin with checking Launcher.dat, then install Gateway Exploit again and finally, doing a disk check to that SDCard.

    EDIT: Just tested to load exploit without Launcher.dat... That's what i got:

    Warning: Spoilers inside!

    So you were right! ;)
     
  18. Berabouman
    OP

    Berabouman Advanced Member

    Newcomer
    61
    3
    Jun 4, 2013
    United States
    I'm pretty sure it's a problem with me having changed the DOB, because I had not changed anything at all before it happened.

    In terms of getting the exploit to work, all I have to do is run it from the blue card right? Do I need to reformat the microSD card?
     
  19. gamesquest1

    gamesquest1 Nabnut

    Member
    14,120
    9,456
    Sep 23, 2013
    nope, just re-install the exploit and everything will be exactly how you left it with emunand etc set up still
     
  20. Berabouman
    OP

    Berabouman Advanced Member

    Newcomer
    61
    3
    Jun 4, 2013
    United States
    Sorry to necro this thread but I didn't want to make a new one. I finally got the my blue card in the mail, but I have a few questions before I begin :

    1. The version of the launcher I used to have was 2.2, which I can't find on the Gateway website anymore. According to the instructions here (http://www.modchipfactory.com/blog/...teway-3ds-to-play-3ds-games-on-n3ds-v4-1-4-5/)

    "Once opened, navigate to the “Blue Card (R4i)” folder, and extract all the folders/files in it to the root of your microSD card. Insert the microSD card into the blue labeled Flash Kit, and then insert the blue labeled Flash Kit into your 3DS. "

    Will this cause any incompatibilities with the launcher.dat which is 2.2 still on my SD card? (saves etc) Should I just re-format everything and start from scratch? I would really like to keep my saves if possible. Or do I not even need to touch the SD card?

    2. After that I should eventually get to this step :

    "After it launches you will see an icon with the GW3DS logo called “GW Install”, highlight it and press A. You will now boot into a screen that says “Press A to Install”, and “Press B to Exit”. Press A, and the GW Install homebrew application will begin exploiting your 3DS system."

    I've watched some Youtube videos of this step and there is an option to select which version of 3DS I have...how do I know which version I have? I checked System Settings but there is no way to tell there.

    I'm probably making this whole process a lot harder than it really is (I've never done it before) but it seems terribly confusing to me right now and I don't want to start anything yet for fear of bricking the system.