Gateway read error?

Discussion in '3DS - Flashcards & Custom Firmwares' started by CIAwesome526, Mar 20, 2015.

  1. CIAwesome526
    OP

    CIAwesome526 Im ugly and im proud

    Member
    1,242
    2,254
    Mar 25, 2014
    United States
    The Lake, Kalos Region
    half the time when i try to open up the multirom menu to get a new game (maybe even 2 thirds of the time), it says read error and nothing shows up, so i just close and reopen the menu a few times and then the games show up. sometimes the games show up on 1st or 2nd try, but when i click on the game i want it shows the loading bar, then closes and loads no games, making me need to reopen the menu. but when it loads all my rom's are there, and they seem to work. whats wrong? the diagnostic test says all is working. is it some problem with n3DS support yet to be fixed? Does my SD card have a problem and need to be reformatted? or does my gateway card just have problems?
    Oh and, i don't have emuNAND yet, because i'm still waiting for the 32GB card to come in the mail, and am on 9.0, is it because i haven't updated yet, like with the Japanese 8.1 n3DS's?
     
  2. VinsCool

    VinsCool Comfortably Numb

    Member
    GBAtemp Patron
    VinsCool is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,854
    28,348
    Jan 7, 2014
    Canada
    Another World
    Micro SD card Issues here. Be sure it is formated correctly, not fragmented. Re move and reinsert the micro sd on the gateway and try again.
     
  3. CIAwesome526
    OP

    CIAwesome526 Im ugly and im proud

    Member
    1,242
    2,254
    Mar 25, 2014
    United States
    The Lake, Kalos Region
    for removing the sd card, i do that sometimes, but the problem comes back. for fragments, its not fragmented. and for reformatting, i dont think i have formatted it in a while... so ill try that, but the roms arent corrupt are they? if i just pull them off, format the SD card, and put them back on it should work right? its not some cheap $5 SD card either. its a $15 or so 32GB class 4 SD card (yes i know thats slow now, but its not the newest card, and its fast enough, the games i play still have like no loading time, on my new3DS :))

    Oh and what format is best, im guessing its fat32, because i think thats standard on SDHC cards, like this one, and i think i heard of people having problems with exFAT.
     
  4. VinsCool

    VinsCool Comfortably Numb

    Member
    GBAtemp Patron
    VinsCool is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,854
    28,348
    Jan 7, 2014
    Canada
    Another World
    Yeah, reformat and put your roms in again.
     
  5. CIAwesome526
    OP

    CIAwesome526 Im ugly and im proud

    Member
    1,242
    2,254
    Mar 25, 2014
    United States
    The Lake, Kalos Region
    ok, i edited the above post, but i guess you didnt see it so:
     
  6. VinsCool

    VinsCool Comfortably Numb

    Member
    GBAtemp Patron
    VinsCool is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,854
    28,348
    Jan 7, 2014
    Canada
    Another World
    Exfat is fine for me. Try both formats, but I suggest exfat. You won't have to split roms.
     
  7. CIAwesome526
    OP

    CIAwesome526 Im ugly and im proud

    Member
    1,242
    2,254
    Mar 25, 2014
    United States
    The Lake, Kalos Region
    split roms?
     
  8. VinsCool

    VinsCool Comfortably Numb

    Member
    GBAtemp Patron
    VinsCool is a Patron of GBAtemp and is helping us stay independent!

    Our Patreon
    11,854
    28,348
    Jan 7, 2014
    Canada
    Another World
    Fat32 limits file size, so you have to split roms in parts of 2gb.
     
  9. CIAwesome526
    OP

    CIAwesome526 Im ugly and im proud

    Member
    1,242
    2,254
    Mar 25, 2014
    United States
    The Lake, Kalos Region
    oh, i didnt know that
     
  10. milerwan

    milerwan Seasoned technician

    Member
    403
    93
    Dec 21, 2013
    France
  11. CIAwesome526
    OP

    CIAwesome526 Im ugly and im proud

    Member
    1,242
    2,254
    Mar 25, 2014
    United States
    The Lake, Kalos Region
  12. milerwan

    milerwan Seasoned technician

    Member
    403
    93
    Dec 21, 2013
    France
    Ok I see what is your problem.

    Try to reflash the red card by pressing "R" trigger when you boot on Gateway menu.
    This will fix this kind of issue.
     
  13. CIAwesome526
    OP

    CIAwesome526 Im ugly and im proud

    Member
    1,242
    2,254
    Mar 25, 2014
    United States
    The Lake, Kalos Region
    reflash? kind of like reformat? does this get rid of my roms?
     
  14. milerwan

    milerwan Seasoned technician

    Member
    403
    93
    Dec 21, 2013
    France
    This trick reprograms the red card and not the microSD.
     
    ravihpa likes this.
  15. CIAwesome526
    OP

    CIAwesome526 Im ugly and im proud

    Member
    1,242
    2,254
    Mar 25, 2014
    United States
    The Lake, Kalos Region
    I tried that, it didn't work. I still have to try formatting it though.
     
  16. milerwan

    milerwan Seasoned technician

    Member
    403
    93
    Dec 21, 2013
    France
  17. CIAwesome526
    OP

    CIAwesome526 Im ugly and im proud

    Member
    1,242
    2,254
    Mar 25, 2014
    United States
    The Lake, Kalos Region
    i fixed it formatting it into exFAT with the windows format tool did it. but i got a new SD card anyway :). so anyway, it works now.