G6 Lite (4Gbit) support

Discussion in 'Other Flashing Hardware & Software' started by Spandi, Jan 8, 2009.

  1. Spandi
    OP

    Spandi Member

    Newcomer
    16
    0
    Oct 28, 2006
    Belgium
    Hello,

    I was wondering how the firmware support for the G6 is nowadays. I haven't been following 'the scene' for a while and now I'm wondering about maybe buying a new card, or just using my old, expensive, G6 one.
    I remember it being a card with a few problems and not being that userfriendly, but my main concern is, does it still play the latest games? I'm very interested in the new Metal Slug and the upcoming GTA game.

    So, can I still play them easily?
     


  2. knl

    knl I can change this?

    Member
    658
    0
    Jun 2, 2003
    Brazil
    From what I can tell, some new games haven't worked on my G6 Lite, and it's likely more games won't work. since the team stopped updating the loader since july, there's really nothing that can be done about this.

    get a different flash cart. :\
     
  3. Maikel Steneker

    Maikel Steneker M3 Fanboy

    Member
    3,396
    34
    May 16, 2007
    Netherlands
    You're naming pretty new games, so there's a good chance that they won't work. Just get a cheap cart like the AceKard 2 and you'll most likely be able to play them very early. You could also buy the more expensive M3 Real, which can link with your G6 to provide GBA compatibility.
     
  4. Spandi
    OP

    Spandi Member

    Newcomer
    16
    0
    Oct 28, 2006
    Belgium
    Thank you for the replies. I'll just keep the old G6 for GBA games and get me a new one for newer games.
    Looking at my local flashcart retailers website i'm having trouble picking one. The DSTT, the EDGE and the Acecard 2 are all in my pricerange.

    Any suggestions to which one is the best? I read the reviews here and they all look pretty equal. I'm sorry, I know this is not the right place to ask this, an answer would be nonetheless very much appreciated [​IMG]
     
  5. Velveteer

    Velveteer GBAtemp Regular

    Member
    129
    0
    Sep 16, 2008
    Any new games that seem incompatible often only need the settings changed.

    Disable Soft Reset
    Enable Rom Trim
    Force R+W

    That's your best bet. I only upgraded due to the limited space and battery life reduction.

    As for a new card, the EDGE is out of production as far as I know and hard to track down.

    I went with the Acekard 2.1, as the DSTT seemed to have small issues that I didn't want to deal with.
     
  6. Canonbeat234

    Canonbeat234 Redeemed Temper

    Member
    2,278
    28
    Sep 24, 2008
    G6 Lite is dead to me, I don't even want to use that BS flashcard ever again.
     
  7. Spandi
    OP

    Spandi Member

    Newcomer
    16
    0
    Oct 28, 2006
    Belgium
    I remember that from when I still used the G6, Velveteer. It was always quite a hassle to find the right settings for each game.

    I've been reading some of the boards here and I think I'll be going with the Acekard 2.1.

    Thank you all very much.
     
  8. knl

    knl I can change this?

    Member
    658
    0
    Jun 2, 2003
    Brazil
    I always try these exact settings with games, and the new ones still didn't work. The G6 lite is simply dead at this point, there's no helping it :\
     
  9. tatumanu

    tatumanu GBAtemp Fan

    Member
    446
    123
    Nov 1, 2004
    Portugal
    Enable Rom Trim doesn´t always work so i wouldnt recomend it.
    Anyway, yes the g6 lite is dead on updates but i wonder why there arent even patches for games that currently dont work? Something that will patch the .nds file to work on a g6 lite.
     
  10. stormwolf18

    stormwolf18 GBAtemp Fan

    Member
    333
    2
    Nov 25, 2006
    Canada
    which game doesnt work ?
     
  11. ipumuk

    ipumuk GBAtemp Regular

    Member
    154
    3
    Apr 6, 2003
    Gambia, The
    Munich / Germany
    I am still using my g6 lite flash card.

    so far all games i have tried worked fine.

    are there any that do not work with it?
     
  12. stormwolf18

    stormwolf18 GBAtemp Fan

    Member
    333
    2
    Nov 25, 2006
    Canada
    no problem here, havent tried a 2gbit game yet, do they work ?
     
  13. staticfritz

    staticfritz GBAtemp Regular

    Member
    117
    0
    Jan 9, 2006
    Canada
    I've played a couple hundred games on my DS with the G6, adn the only games that flat out don't work are 'MBA Allstars' and 'Trauma Centre 2'. Any game after the last update only needs to be written in safe mode, and if it doesn't work, it needs to have the Arm7 fix. I'm still doing this cause I can't justify buying a new card when my old card works. But if you're buying new, get something else.
     
  14. beedog19

    beedog19 GBAtemp Fan

    Member
    386
    0
    Feb 4, 2006
    United States
    Sunny Southern California
    I fear that mine is dying too. At least GBA mode is slowly dying. I can get a good 10-20 minutes before the game crashes. That being said, I've had this thing for 2.5 years and I've put it and my DSL through hell. I still can't believe I've only had that thing for 2.5 years and it looks that bad... Anyways, the G6 lite has played every game I've thrown at it. Yeah, a couple needed patching but none would just flat out not work. I've been happy with this card and will, in all likelihood stick with it at least until Nintendo announces a proper successor to the DS.
     
  15. DarthMingus

    DarthMingus Member

    Newcomer
    32
    1
    Jul 22, 2006
    United States
    Hello,

    Actually most new games still work just fine. I just loaded Metal Slug 7 on my G6 lite with the default settings and it works fine. For the record, the only games I haven't gotten to work are Trauma Center 2 and Zelda. Even Chrono Trigger works great. I'm sure its on its way out support-wise, but it does still work with most games.

    The thing that sucks is that the support has dried up after only 2 years on the market.
     
  16. DarthMingus

    DarthMingus Member

    Newcomer
    32
    1
    Jul 22, 2006
    United States
    Actually, just Trauma Center. I downloaded the Independent Zelda and it worked fine. [​IMG] Chinatown Wars works with no problem too.
     
  17. Melchizedek

    Melchizedek GBAtemp Regular

    Member
    202
    15
    May 7, 2006
    Canada
    How did you make it work?
     
  18. Xii

    Xii Member

    Newcomer
    38
    1
    Aug 17, 2006
    United States
    Detroit, MI
    I used ind-gtafix. Everything works with the exception of Wifi, it sits at searching for network. I was able to get Link working as well. And FFCC EoT works for me as well but again, no Wifi - the setup screen goes white. I did try Wii/DS local play and that worked perfectly (except that the Wii version is quite awkward...)
     
  19. scandal_uk

    scandal_uk GBAtemp Regular

    Member
    165
    0
    Oct 3, 2005
    UK
    Online modes work fine on G6 Lite with GTA:CW, but I haven't got round to multi-cart wireless.

    Which mode is broken for you?
     
  20. chazam1337

    chazam1337 GBAtemp Regular

    Member
    118
    0
    Apr 19, 2008
    United States
    I would consider a dstt =S