Hacking Freezing in most games. Any ideas?

disc0

Member
OP
Newcomer
Joined
Aug 6, 2007
Messages
14
Trophies
0
XP
99
Country
United States
Had my R4 for a few months now, and I've been having trouble with games freezing during gameplay (sound stutters, screens sometimes go white or black, etc.)

I've used two different MicroSD cards, one was a Kingston (Taiwan), one was a PNY (Japan, I think). I haven't had problems using the cards for storage, or reading/writing files to them. No slowdown in any games I've played, including Castlevania POR.

Strangest thing so far is that in Geometry Wars, I get an actual error message when it freezes. Big white "EXCEPTION" on the bottom screen, followed by a list of hexadecimal memory addresses. If anyone thinks this will help diagnose the issue, I can post a picture.

Any ideas? Anyone have the same issues? I've tried the paper/tape trick to keep the contacts in place, and tried reformatting the card, but nothing has worked.
 

Rayder

Mostly lurking lately....
Former Staff
Joined
Jan 14, 2007
Messages
6,606
Trophies
1
Location
USA
XP
610
Country
United States
Try erasing the "_DS_MENU.SYS" file in the root of your card. If you updated your firmware and didn't delete the old one, weird stuff can happen.

It will be re-created by the R4 the next time you boot it. See if that fixes it.


Possibly you have a high amount of fragmentation on your microSD, you need to defrag it. To successfully do this, copy the entire contents of the microSD to your hard drive, format the microSD, then copy everything back to the microSD. Running defragmenting programs on a flashcard is NOT recommended.

If neither of those things work, then I fear your R4 may be malfunctioning.
 

c2ironfist

Well-Known Member
Member
Joined
Nov 27, 2007
Messages
308
Trophies
0
XP
78
Country
Canada
reformat would be my suggestion

if that doesn't work try another Micro SD

The R4s are reliable and simple to use, so I'm assuming its the micro SD card thats the problem
 

DarkAura

Offline
Member
Joined
Aug 20, 2007
Messages
2,385
Trophies
0
Age
30
Location
Over there.
Website
Visit site
XP
223
Country
Canada
Get a new Micro SD and try that. I didn't notice that you said you had tried to reformat at the end of your post.
tongue.gif
 

disc0

Member
OP
Newcomer
Joined
Aug 6, 2007
Messages
14
Trophies
0
XP
99
Country
United States
Thanks for the tips, guys. I've used a couple of different microsd cards, so I don't think that's it, but I hadn't deleted the _ds_menu.sys or whatever it is. I'll let you all know if I manage to sort things out.
 
General chit-chat
Help Users
  • No one is chatting at the moment.
    susbaconhairman @ susbaconhairman: what