For the life of me, I cannot get modmoon working for smash 3ds

Coltonious

New Member
OP
Newbie
Joined
Feb 25, 2021
Messages
4
Trophies
0
Age
24
XP
59
Country
United States
I have tried everything. I have done full deletes of modmoon, saltySD, and the smash id folder inside the luma "titles folder", and then reread the full "short" tutorial at game banana, and still nothing. let me take you through the exact process and let you know what happens.

  1. I uninstall modmoon and delete the above stated folders
  2. I reinstall modmoon
  3. I open modmoon and go through the tutorial
  4. I open smash
  5. I close out of smash and then get into my SD card
  6. I double check that modmoon already installed saltySD
  7. I then try to move the high poly code ips (renamed to USAcode.ips) to sd\3ds\modmoon\00040000000EDF00\Slot_1\codes, but realize that Slot_1 wasn't created by modmoon, so I create it with the exact capitalization and underscore
  8. I then create codes within Slot_1
  9. I move the high poly code ips to that folder
  10. I then move to install the test goku mod on the tutorial to sd\3ds\modmoon\Slot_1
  11. I get out of SD card and go into modmoon
  12. I get 4 errors
    1. Custom SaltySD code.ips move failed! (custom move)
    2. Error code: 2
    3. Custom SaltySD code.ips move failed! (original move)
    4. Error code: 2
  13. I then try to open smash anyway to see if theres any goku skins over ryu and modmoon was just being weird
  14. no goku mods
  15. jump line 1

I have gone through that process multiple times now and been more meticulous about it every time, but the same error messages keep coming up. I have no clue what I'm doing wrong at this point and I have no clue how to fix it.

Specs:
  • System: new nintendo 3ds XL zelda edition (the one with the zelda bird symbol and triforce on it) fully updated
  • CFW: luma fully updated
  • I use FTPD + winscp to mess around in my micro SD so I don't have to constantly unscrew the back of the 3ds.
  • Winscp is on a windows 11 PC, not like that matters.
  • Smash should be fully updated and DLCed, as I backed up my cartridge of smash with godmode9 and updated it with hshop and got the dlc with hshop

if anyone can explain what's going on, I'd really appreciate it :) thanks in advance :)



P.S. I don't know if this happens to anyone else, but when I press the home button to go back to the home menu from modmoon, my entire 3ds freezes and I have to hold the power button to turn it off

P.P.S Whenever I turn my 3ds back on, the bottom screen has a bit of a slight flash fit. Does anyone know what causes this or knows if there's a fix for it?
 
Last edited by Coltonious,

reric88

New Member
Newbie
Joined
Apr 26, 2023
Messages
2
Trophies
0
Age
36
XP
22
Country
United States
Edit: OKAY! I'm going to leave my mess below because it's funny to me. I believe the solution is as follows:
1. Enable game patching in Luma (Hold select on 3DS power-on)
2. Create saltysd folder on sd root.
3. Create smash folder in saltysd. Make sure this is EMPTY.
4, Drop your code.ips in the ModMoon/00040000000EDF00/Slot_2/codes folder. Don't forget to prepend your code.ips with your region, such as USAcode.ips
5. Make sure ModMoon/00040000000EDF00/Slot_1 is EMPTY.
6. The file structure of your Slot_2 folder should look something like: 2 folders: model, codes and 1 text: desc.txt. In the text file you can put a short description of what the mod is.

I'll retry these exact steps above several times to make sure it works.



Hey man, I was having the same problem and I managed to get it working. I'll figure out what it was I was doing wrong and update you. I just wanted to post this to let you know to expect a solution, hopefully.

This will be explained using the Sans Mii Costume located here: [gamebanana url here]/mods/245982
(Because that's what I used.)

I want to preface I made several mistakes along the way because of dumb, or not paying attention or both. Documenting the mistakes anyway because maybe a mistake somewhere caused it to work.

I downloaded and installed ModMoon.

Open ModMoon, get errors, go through tutorial, launch Smash from ModMoon.

Close Smash using Home after entering the game menu (I passed the intro screen.)

I put the mod files in the 'ModMoon/00040000000EDF00/' folder, I didn't make a Slot_2 folder (This didn't work obviously). I say Slot_2 because I was trying another mod at the same time in Slot_1 which actually doesn't work.

Launch ModMoon, get errors, launch smash, no mod.

Close smash.

Realize I forgot to put stuff in Slot_2, so I do that. Also realize I forgot USAcode.ips.

The Sans mod doesn't have a codes folder. Add a codes folder next to the model folder and paste USAcode.ips in there.

Launch ModMoon, get errors, launch Smash, no mod.

Close Smash.

ModMoon never made a 'saltysd' folder on root, I realize it's not supposed to, remember I'm an idiot.

1. Make a 'smash' folder inside 'saltysd'.

2. Launch ModMoon, get errors, launch Smash, no mod.

3. Close Smash. Scratch head with neanderthal fingers.

4. Add a 'desc.txt' file beside the 'codes' and 'model' folders in 'ModMoon/00040000000EDF00/', add description (text didn't show in ModMoon.)

5. Google my heart out. Find a reddit link somehow don't even remember where, didn't save it like the dummy I am.

6. The dude/dudette said the USAcode.ips file needs to go into the luma folder (I think I could be remembering wrong after all.)

7. Go to 'Luma/titles/00040000000EDF00/' and paste it as 'code.ips' (NOT USAcode.ips, shrug idk).

8. At some point, USAcode.ips ended up inside the ModMoon folder itself, next to settings.txt. maybe that's relevant, I doubt it. But there it is.

9. If I remember correctly this is the point it worked. Afterwards (I assume afterwards) the files were moves. The files are now like this on my SD card:

'root:Luma/titles/00040000000EDF00/code.ips'

'root:saltysd/smash/'
(Inside here are codes and model folders with desc.txt. codes folder is empty, but the model folder has all the stuff.)

'root:3ds/ModMoon/USAcode.ips'

'root3ds/ModMoon/00040000000EDF00/'
(The Slot_2 folder is gone. The Slot_1 folder remains with all it's data there.)


I am looking for the reddit link, but here's this info for now if it helps anyone out there in Google land who's as dumb as me.
 
Last edited by reric88,
  • Like
Reactions: AutumnWolf

Coltonious

New Member
OP
Newbie
Joined
Feb 25, 2021
Messages
4
Trophies
0
Age
24
XP
59
Country
United States
Hey man, I was having the same problem and I managed to get it working. I'll figure out what it was I was doing wrong and update you. I just wanted to post this to let you know to expect a solution, hopefully.

This will be explained using the Sans Mii Costume located here: [gamebanana url here]/mods/245982
(Because that's what I used.)

I want to preface I made several mistakes along the way because of dumb, or not paying attention or both. Documenting the mistakes anyway because maybe a mistake somewhere caused it to work.

I downloaded and installed ModMoon.

Open ModMoon, get errors, go through tutorial, launch Smash from ModMoon.

Close Smash using Home after entering the game menu (I passed the intro screen.)

I put the mod files in the 'ModMoon/00040000000EDF00/' folder, I didn't make a Slot_2 folder (This didn't work obviously). I say Slot_2 because I was trying another mod at the same time in Slot_1 which actually doesn't work.

Launch ModMoon, get errors, launch smash, no mod.

Close smash.

Realize I forgot to put stuff in Slot_2, so I do that. Also realize I forgot USAcode.ips.

The Sans mod doesn't have a codes folder. Add a codes folder next to the model folder and paste USAcode.ips in there.

Launch ModMoon, get errors, launch Smash, no mod.

Close Smash.

ModMoon never made a 'saltysd' folder on root, I realize it's not supposed to, remember I'm an idiot.

1. Make a 'smash' folder inside 'saltysd'.

2. Launch ModMoon, get errors, launch Smash, no mod.

3. Close Smash. Scratch head with neanderthal fingers.

4. Add a 'desc.txt' file beside the 'codes' and 'model' folders in 'ModMoon/00040000000EDF00/', add description (text didn't show in ModMoon.)

5. Google my heart out. Find a reddit link somehow don't even remember where, didn't save it like the dummy I am.

6. The dude/dudette said the USAcode.ips file needs to go into the luma folder (I think I could be remembering wrong after all.)

7. Go to 'Luma/titles/00040000000EDF00/' and paste it as 'code.ips' (NOT USAcode.ips, shrug idk).

8. At some point, USAcode.ips ended up inside the ModMoon folder itself, next to settings.txt. maybe that's relevant, I doubt it. But there it is.

9. If I remember correctly this is the point it worked. Afterwards (I assume afterwards) the files were moves. The files are now like this on my SD card:

'root:Luma/titles/00040000000EDF00/code.ips'

'root:saltysd/smash/'
(Inside here are codes and model folders with desc.txt. codes folder is empty, but the model folder has all the stuff.)

'root:3ds/ModMoon/USAcode.ips'

'root3ds/ModMoon/00040000000EDF00/'
(The Slot_2 folder is gone. The Slot_1 folder remains with all it's data there.)


I am looking for the reddit link, but here's this info for now if it helps anyone out there in Google land who's as dumb as me.
Oh man, thank you so much! I'll have to mess with this when I get a good chance!
 

reric88

New Member
Newbie
Joined
Apr 26, 2023
Messages
2
Trophies
0
Age
36
XP
22
Country
United States
Oh man, thank you so much! I'll have to mess with this when I get a good chance!
Edit: I updated my first post to better explain the exact steps.

I just did the mod again on my sons O3DS after a lot of difficulty, just to see how to get it working. Here are two steps I believe fixed the issue that I don't see on your post:

1. Make sure "Game Patching" is enabled in Luma (Hold Select when powering on the 3ds)
2. In the ModMoon/00040000000EDF00/ folder, make sure there is an EMPTY Slot_1 folder. Put your mods in the other slots.

Step 2 is what made my sons 3ds work. I still got errors on booting ModMoon and launching the game from there, but the mod was successfully applied.

Also, double check that saltysd/smash is empty, also, because it moves stuff there and then tries to move stuff again but can't because the files are duplicates, or don't exist BECAUSE they were moved. I don't understand it.

You don't have to read through that mess up above, the key here (I believe) is to make sure slot_1 stays empty, and all other mods get their own slots. It seems like ModMoon is copying the stuff from Slot_1 on load, and when it tries again it can't because, well, it doesn't exist because it moved already. Then it just fails because it couldn't find the mod, even though it's in salty/sd.
 
Last edited by reric88,

Site & Scene News

Popular threads in this forum

General chit-chat
Help Users
  • No one is chatting at the moment.
    K3Nv2 @ K3Nv2: https://youtube.com/shorts/WUOq1dlZWxI?si=LBlEJwZfwtWShljP lol Denmark can't handle the spice